mlusted Absent Member.
Absent Member.
708 views

Parameters errors after saving to JasperReports Server

100% Wintel environment.
I have created a report in JasperStudio with parameters used in the filter the report. It works well when I preview the report in JasperSoft. When I export the report to JasperReports Server it appears to save with no errors. When I try to view the report I receive errors related to the parameters.
Is it possible to create a report with parameters that will be compatible with JasperReport Server?
Labels (2)
0 Likes
1 Reply
mlusted Absent Member.
Absent Member.

Re: Parameters errors after saving to JasperReports Server

I have defined one parameter (a simple text string) for the report. I have created a single text parameter in the ZENworks Reporting to match my report parameter. When I run the report the Input Controls dialog appears, but it is blank; only the form controls Apply, OK, Reset, Cancel, and Save are visible. There is nowhere to enter my parameter text. If I click Apply, the Please Wait dialog appears forever, until I cancel it.
If I do not define a parameter for my report in the ZENworks Reporting interface, when I run the report I get a big error which relates to the fact that the parameter is missing.
In JasperStudio the parameter is defined as MachineType. I created a parameter in ZENworks Reports with the same name.
Can anyone shed some light on why the parameter controls are not showing up in the Input Controls dialog.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.