jmarberg1 Regular Contributor.
Regular Contributor.
311 views

Primary Server not updating

Updated my zone to zenworks 17 recently.  Everything went fine with that upgrade, no errors or issues.  Now trying to update my primary to update 4.  I am able to install the update into system updates and assign the update to my primary.  I have refreshed it several time and cannot get the update to begin, still stuck at assigned.  The updater service shows recent contact but nothing begins.  I started looking at logs and the zeus-messages log shows some errors that look like databse issues. The database is an external SQL server.

This is small cut of the log showing the errors.  It is followed by a lot of what look to be java errors

DEBUG] [06/27/2019 07:36:31.659] [1668] [ZeUSAgent] [44] [] [DefaultDAOManager] [] [***************** End Exception Dump ***********************] [] [] [] [ZeUSService]
[DEBUG] [06/27/2019 07:36:31.659] [1668] [ZeUSAgent] [137] [] [DefaultDAOManager] [] [***************** Exception Dump ***********************] [] [] [] [ZeUSService]
[DEBUG] [06/27/2019 07:36:31.659] [1668] [ZeUSAgent] [137] [] [DefaultDAOManager] [] [Could not fetch connection through C3P0] [] [] [] [ZeUSService]
[DEBUG] [06/27/2019 07:36:31.659] [1668] [ZeUSAgent] [137] [] [DefaultDAOManager] [] [------------------------------------------------------------------------------------] [] [] [] [ZeUSService]
[DEBUG] [06/27/2019 07:36:31.659] [1668] [ZeUSAgent] [137] [] [DefaultDAOManager] [] [Message: Connections could not be acquired from the underlying database!] [] [] [] [ZeUSService]
[DEBUG] [06/27/2019 07:36:31.659] [1668] [ZeUSAgent] [137] [] [DefaultDAOManager] [] [Exception Type: class java.sql.SQLException] [] [] [] [ZeUSService]
[DEBUG] [06/27/2019 07:36:31.659] [1668] [ZeUSAgent] [137] [] [DefaultDAOManager] [] [Stack: com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:118)

Thanks!

 

Labels (1)
0 Likes
6 Replies
Micro Focus Expert
Micro Focus Expert

Re: Primary Server not updating

Could you attach the entire log here?

If you would rather not post it publicly, send me a private message and attach........

0 Likes
jmarberg1 Regular Contributor.
Regular Contributor.

Re: Primary Server not updating

Here is a file from earlier today

0 Likes
raronson Super Contributor.
Super Contributor.

Re: Primary Server not updating

I had a similar set of issues yesterday. I have 3 primary servers at one site running on Sles 12. I was troubleshooting issues with my MDM server.

I tried to apply the 17.4.1a update, which forced me to reapply the 17.4.0 update that I thought I'd distributed months ago.  That went quickly and without an issue once my primary servers redistributed it. My servers didn't reboot after the updates, I dind't think about that much. ZCC let me apply the 17.4.1a update to my primary servers, when I looked at the status it kept reporting the update was assigned and would be applied the next time  my server agent was refreshed. I thought that meant running zac ref on the host. That did nothing.  Next I tried refreshing the server in ZCC. That didn't seem to do anything either. Finally in desperation I rebooted one of my primary servers.  Once I rebooted I didn't see anything, I tried running zac refresh which reported that the agent wasn't loaded. At this point I started my zcm services manually with novell-zenworks-configure -c Start. Once I did that everything started to flow, the system log at /var/log/messages showed all the updates as they happened. 

0 Likes
jmarberg1 Regular Contributor.
Regular Contributor.

Re: Primary Server not updating

Running windows server here.  I've tried rebooting several times, reloading services and still cant get this started.  I reassigned the update today but I noticed when i refreshed the server it caused the zenworks server service to crash.  Once that happened everything else stops.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Primary Server not updating

If it is a virtual server, make sure the Memory is Dedicated.....Lack of Memory can cause issues with large Java Processes like the ZCM Loader and Server Services....Just a generic suggestion.  

 

0 Likes
jmarberg1 Regular Contributor.
Regular Contributor.

Re: Primary Server not updating

I did have memory dedicated but i bumped it up to reserve the full amount. Still no change in operation. Waiting to open an SR once our support is renewed.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.