NovAlf Super Contributor.
Super Contributor.
955 views

Printer policy fails: driver for model can not be found

Hi!
ZCM 11.4.2. Windows 7 Pro SP1. Printer policy with driver included for local printer install. Did work ok with ZCM 11.3.2, I remember. Associated to device. In ZCC I see "Printer <printer_driver_name> cannot be installed as driver for model name <model_name> can not be found. You may add the driver using printer policy.". I do, at least I think I do exactly this. On test device where same printer was previously installed, it does install (previously removed, for testing) printer, but in ZCC I see "Printer driver installation failed for <printer_driver_name>. Check if provided drivers inf file is in proper format.".
Any ideas?
More thanks, Alar.
Labels (2)
0 Likes
4 Replies
Micro Focus Expert
Micro Focus Expert

Re: Printer policy fails: driver for model can not be found

Sounds more like an iPrint issue and the driver assigned to the printer....especially since manually ensuring the printer driver existed locally resolved the issue.
May want to post in the iPrint Forum.

Note: There is a Fix listed for iPrint for ZCM 11.4.3, but it does not contain any fixed code. (I believe Dev flagged as fixed instead of invalid.... since they spent quite a bit of time helping the customer debug their iPrint Setup and wanted 'credit'.....)
I reviewed the bug and the only fix I can see if the customer fixing a few things in their environment. No actual code change.
(Note: The customer having issues was running ZCM 11.3.x not ZCM 11.4.x)
0 Likes
NovAlf Super Contributor.
Super Contributor.

Re: Printer policy fails: driver for model can not be found

Hi and thanks!
Could be something cosmetic, as I was a bit wrongly informed – on both devices (on production one and on test) was printer installed ok (and printing), but with errors in ZCC. iPrint Client is ... 6.05.
More thanks, Alar.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Printer policy fails: driver for model can not be found

NovAlf;2442953 wrote:
Hi and thanks!
Could be something cosmetic, as I was a bit wrongly informed – on both devices (on production one and on test) was printer installed ok (and printing), but with errors in ZCC. iPrint Client is ... 6.05.
More thanks, Alar.


THere is a claimed fix for cosmetic errors in 11.4.3, but I don't believe they were....
I can't find any reference to an actual code change as much as the issue just went away for the customer as they made changes.

The Devs are supposed to detail any changes they make in the bug, but that does not always happen so it is possible there was a code change.....
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Printer policy fails: driver for model can not be found

NovAlf;2442953 wrote:
Hi and thanks!
Could be something cosmetic, as I was a bit wrongly informed – on both devices (on production one and on test) was printer installed ok (and printing), but with errors in ZCC. iPrint Client is ... 6.05.
More thanks, Alar.


There is a claimed fix for cosmetic errors in 11.4.3, However there is not any reference to any code changes or test files given to the customer.
Rather, just the fact the customer made changes and the issues went away.
So it is possible 11.4.3 has a fix, but I would not be surprised if the cosmetic errors remained.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.