Anonymous_User Absent Member.
Absent Member.
713 views

Start Menu Folders causes explorer.exe to hang

I've have an issue that seems related to agent 11.3.2.47407 in that while ZCM desktop icons seem to work fine, the zcm/folder icons when clicked cause explorer.xex to crash/hang
The folder icons work fine in ZENworks Application window. Machines using agent version 11.2.4.3271 do not exhibit this issue.

Has anyone seen this before? Is there a fix? If there isn;t a fix, how can I get back to agent 11.2.4.3271?

thanks
Thomas
Labels (2)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Start Menu Folders causes explorer.exe to hang

Typo. Agent agent 11.2.4.32791 works fine.

Thomas

>>> Thomas Roberts<tom@nowhere.com> 11/05/2015 5:03 p.m. >>>


I've have an issue that seems related to agent 11.3.2.47407 in that while ZCM desktop icons seem to work fine, the zcm/folder icons when clicked cause explorer.xex to crash/hang
The folder icons work fine in ZENworks Application window. Machines using agent version 11.2.4.3271 do not exhibit this issue.

Has anyone seen this before? Is there a fix? If there isn;t a fix, how can I get back to agent 11.2.4.3271?

thanks
Thomas
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Start Menu Folders causes explorer.exe to hang

Thomas,

what desktop OS? Can you reproduce it at will or is it intermittent?
Have you checked zmd-messages at the time you get a problem?

--

Shaun Pond
newly reminted as a Knowledge Professional


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Start Menu Folders causes explorer.exe to hang

Hi SHaun

OS = Windows 7 sp1
It is not intermittent. Any machine with that agent has the issue.
If I click on a blue folder then the pinter wirls around and around and the message about explorer.exe do you want to wait or, close search online comes up. If I wait long enough the blue folder eventually opens. If I try another folder same thing happens and while this is going on explore.xe is pretty much fronzen.

I'll check the logs in the morning.

Thanks


>>> Shaun Pond<shaunpond@no-mx.forums.novell.com> 11/05/2015 10:08 p.m. >>>

Thomas,

what desktop OS? Can you reproduce it at will or is it intermittent?
Have you checked zmd-messages at the time you get a problem?

--

Shaun Pond
newly reminted as a Knowledge Professional
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Start Menu Folders causes explorer.exe to hang

I'm not sure what I am looking for but here is the tail end of the messages log when I click a zcm folder.

Do I need to look further up the file?

[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 15.6 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.290] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.305] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 15.6001 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.305] [1576] [ZenworksWindowsService] [25] [] [BundleManager] [] [Serialization of AppLocalState took 0 milliseconds] [] [] [] [ZENworks Agent]
[DEBUG] [05/12/2015 08:56:48.305] [1576] [ZenworksWindowsService] [25] [] [AppLocalState] [] [Total time for serializing app state files is 312.0006 ms] [] [] [] [ZENworks Agent]






>>> Thomas Roberts<tom@nowhere.com> 11/05/2015 10:51 p.m. >>>


Hi SHaun

OS = Windows 7 sp1
It is not intermittent. Any machine with that agent has the issue.
If I click on a blue folder then the pinter wirls around and around and the message about explorer.exe do you want to wait or, close search online comes up. If I wait long enough the blue folder eventually opens. If I try another folder same thing happens and while this is going on explore.xe is pretty much fronzen.

I'll check the logs in the morning.

Thanks


>>> Shaun Pond<shaunpond@no-mx.forums.novell.com> 11/05/2015 10:08 p.m. >>>

Thomas,

what desktop OS? Can you reproduce it at will or is it intermittent?
Have you checked zmd-messages at the time you get a problem?

--

Shaun Pond
newly reminted as a Knowledge Professional
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Start Menu Folders causes explorer.exe to hang

You may want to open an SR and reference defect#927918
There is a test fix involving nalshell.dll, which hooks into explorer.exe

The issue is not the same as what you describe, but the issue is generic enough that it may be seen under different conditions.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Start Menu Folders causes explorer.exe to hang

Craigdwilson,

glad you posted that, because I can't reproduce it from the OP's
description 🙂

--

Shaun Pond
newly reminted as a Knowledge Professional


0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Start Menu Folders causes explorer.exe to hang

I've never heard this issue reported before or anything close.
However, the only hook into Explorer.exe is via NALSHELL.DLL
The bug references a compatibility issue with another 3rd party shell plugin.
The fix for that compatibility issue is generic enough it could help here.

But I would highly recommend an SR because this is not a known issue and any public fix for the other reported issue is likely still quite a while since the fix is in test and only reported by a single customer.
As a result the fix may not be published widely initially due to the fact most customers would not see the issue.


Shaun Pond;2393924 wrote:
Craigdwilson,

glad you posted that, because I can't reproduce it from the OP's
description 🙂

--

Shaun Pond
newly reminted as a Knowledge Professional
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.