Adeckert1 Absent Member.
Absent Member.
1391 views

Technican Application not starting after Update 2017 Update1

Hello,
I have updated the agent from 2017 to 2017 Update1. Now the "technican application" didn´t start anymore. All other is working. I have FDE installed with 2017, so this part of the agent is not updated. Any dependencies with this?

Andy
Labels (1)
0 Likes
12 Replies
Micro Focus Expert
Micro Focus Expert

Re: Technican Application not starting after Update 2017 Upd

There is not supposed to be a dependency.
You may want to follow the process for updating FDE, which would redeploy the update.
Then if there was some minor issue originally in the SU itself or there was a dependency, you would be covered either way.

However, I am not aware of any issues with the Technical Application related to System Updates being reported during the Update 1 Testing Cycles.
0 Likes
mla_hm
New Member.

Re: Technican Application not starting after Update 2017 Upd

We are having the same issue. Upgrading from 2017 to 2017 update 1.
So far we have heard from 3 users out of the 90 upgraded (119 pending).

The 3 users having the issue all have the "old" FDE.
On the machines there's no notification icon and we cannot start the zenworks application window, but are able to open the technical application manual by running ZenNotifyIcon.exe
0 Likes
mla_hm
New Member.

Re: Technican Application not starting after Update 2017 Upd

More users are reporting the problem. But we also have 2 users without FDE, so think we can rule this out.
Might as well open an SR.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Technican Application not starting after Update 2017 Upd

Leave at least one broken, but the 1st step I would recommend is re-assigning the SU.....possible it did not fully complete.....
Of course also make sure the device has restarted after the SU........
0 Likes
mla_hm
New Member.

Re: Technican Application not starting after Update 2017 Upd

They all completed successfully, so i cannot re-assign the SU.

Been through SU logs and zmd-messages. No errors.

The zapp.<username>.log just stopped from the time the workstation was upgraded.

I opened SR#101095332871, so i hope i can find a solution with a technician.
Would like to avoid complete agent reinstall on all those machines.
0 Likes
Adeckert1 Absent Member.
Absent Member.

Re: Technican Application not starting after Update 2017 Upd

I fixed my problem with updating dotnet to version 4.7
Hope this will help you.

Andy
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Technican Application not starting after Update 2017 Upd

Do you know what version you were Prior?

4.5? 4.6.x?
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Technican Application not starting after Update 2017 Upd

I've definitely seen straight 4.5 work on lab devices....but I can see a major upgrade fixing Misc Dot Net issues that creep into a production system's .NET install or there may be a bug in one specific minor .NET patch between 4.5.0 and 4.7.x
0 Likes
Highlighted
mla_hm
New Member.

Re: Technican Application not starting after Update 2017 Upd

Unfortunately it seems my problem is a bit different. All our machines have 4.7

But i found out that some were missing zapp-1.0.0.js from Program Files (x86)\Novell\ZENworks\zapp

Now they get the tray icon and can open zapp. But it looks like some elements are missing.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Technican Application not starting after Update 2017 Upd

Did you try to repair the SU for the one missing files?
0 Likes
mla_hm
New Member.

Re: Technican Application not starting after Update 2017 Upd

A little update on my issue.

All the workstations with the issue was "successfully" updated in 2nd attempt.
Most likely it was Kaspersky AV causing the missing files.

After a launch of "Verify Last Update" quick task from ZCC and a reboot ZAPP was working fine again.
I was not aware of this feature until now and could save some time in the future since it most likely isn't the last time
i will run into missing files after an update.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Technican Application not starting after Update 2017 Upd

It is a fairly new feature.....
It came in as part of the ZENworks Update Service, which is independent of the core ZCM Agent.
Thus if there are failed updates that impact the agent, they can still be remotely repaired.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.