posty Absent Member.
Absent Member.
8344 views

Tuxera Image Engine: wont work with pxe boot

Hi guys,

i am troubleshooting this problem since release of zcm 11 sp2 and i cant get it fixed by myself.

i want to use the new image engine for my win7 image deployment,
so i followed the documentation on integrating the new tuxera image engine driver in my zcm 11 sp2 environment: Novell Documentation

everything looks good:
- bootcd iso was created
- tntfs.ko + HighPerfDriver.conf (under the tftp root dir) was created
- tftp status under the zcc is available and replicated!
(ZCM is running on Windows Server 2003 Enterprise Edition SP2 (English))

but when i pxeboot one of my machines the tntfs.ko module wont load!
a "modprobe -l | grep tntfs" brings up nothing!

if i boot the same machine with the new created bootcd_tntfs.iso everything is ok "modeprobe -l | grep tntfs" => /lib/modules/2.6.32.24-0.2-default/initrd/tntfs.ko

i also set up a complete new and naked zcm server (complete new zone | single server | seperated in a private lan | vmware) to get a complete naked and untouched tftp directory for testing purposes.
and again the same thing happens: if i pxeboot a machine pointing to the new created primary server with the tuxera image engine driver enabled -> no tuxera driver gets loaded up!

did i miss something? or what seems to be the problem?
i uploaded my tftp directory: so maybe someone can help me figuring out why the new engine wont work!
http://bender4tw.bplaced.net/tftp.tuxera.112.zip

Thx in advance,
Martin
Labels (2)
0 Likes
18 Replies
shaunpond Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Posty,

how about if you boot with new bootcd that has the tntfs driver, does
it load then? I certainly see the driver if i do a modprobe on my PXE-
booted system

--

Shaun Pond


0 Likes
Highlighted
posty Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Hi Shaun and thx for your fast reply:

spond;2186783 wrote:

how about if you boot with new bootcd that has the tntfs driver, does
it load then? I certainly see the driver if i do a modprobe on my PXE-
booted system


as i wrote:
Posty wrote:

if i boot the same machine with the new created bootcd_tntfs.iso everything is ok "modeprobe -l | grep tntfs" => /lib/modules/2.6.32.24-0.2-default/initrd/tntfs.ko


Shaun, could you maybe upload your working tftp directory for me for testing purposes?

Thx,
Martin
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Posty,

I would have to find out if the license for the ntfs driver allowed me
to do that, I'm not sure of the terms... meanwhile here's a listing of
my directory, note I have uploaded winpe...

total 163087
-rw-rw-r-- 1 zenworks zenworks 79 Jan 27 11:30 abortpxe.com
-rwxr-xr-x 1 zenworks zenworks 12288 Mar 1 16:41 bcd
-rw-rw-r-- 1 zenworks zenworks 3170304 Jan 27 11:30 boot.sdi
-rw-rw-r-- 1 zenworks zenworks 26076 Jan 27 11:30 hdlscom1.com
-rw-rw-r-- 1 zenworks zenworks 26060 Jan 27 11:30 hdlscom1.n12
-rw-rw-r-- 1 zenworks zenworks 26076 Jan 27 11:30 hdlscom2.com
-rw-rw-r-- 1 zenworks zenworks 26060 Jan 27 11:30 hdlscom2.n12
-rwxr-xr-x 1 zenworks zenworks 27816484 Mar 1 16:35 initrd
-rwxr-xr-x 1 zenworks zenworks 3166496 Mar 1 16:35 linux
-rw-rw-r-- 1 zenworks zenworks 25772 Jan 27 11:30 pxeboot.0
-rw-rw-r-- 1 zenworks zenworks 25772 Jan 27 11:30 pxeboot.com
-rwxr-xr-x 1 zenworks zenworks 16312725 Mar 1 16:35 root
-rwxr-xr-x 1 zenworks zenworks 1770 Oct 6 2010 settings.txt
-rw-rw-r-- 1 zenworks zenworks 1347 Jan 27 11:30 wdsconfig.inf
-rw-rw-r-- 1 zenworks zenworks 31124 Jan 27 11:30 wdsnbp.com
-rw-rw-r-- 1 zenworks zenworks 116130725 Jan 27 11:30 winpe.wim


--

Shaun Pond


0 Likes
posty Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

thx shaun for your reply.

thats your whole tftp directory? i mean where are your tntfs.ko or HighPerfDriver.conf files?

anyway i added the tntfs.ko file to the initdr by myself following this guide from ENGL (i am also a ENGL user):
https://www.engl.co.uk/documentation/imagingtoolkit/6.0/zim/proc-zim-pxetftp.html (even though it is 6.0, works with 7.0 of Imaging Toolkit)
on step 6 and i just put the tntfs.ko file in the specified directory.

with this updated initrd i am finally able to enjoy the big performance boost with the tuxera driver!

@shaun: can i expect future problems with this solution?

thx again & cheers,
Martin
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Posty,

that's odd - maybe I was on a different server 😞
it shoud be completely unecessary to add it yourself, here's a better directory listing
.:
total 1130
-rw-rw-r-- 1 zenworks zenworks 52 Apr 5 12:36 HighPerfDriver.conf
-rwxr-xr-x 1 zenworks zenworks 405 Mar 1 16:41 autoyast.cfg
drwxr-xr-x 2 zenworks zenworks 520 Mar 21 08:10 boot
-rw-rw-r-- 1 zenworks zenworks 523328 Jan 27 11:30 bootmgr.exe
drwxr-xr-x 2 zenworks zenworks 256 Mar 21 08:10 dell-dtk
-rwxr-xr-x 1 zenworks zenworks 481 Mar 1 16:41 dell-dtk.cfg
-rwxr-xr-x 1 zenworks zenworks 486 Mar 1 16:41 dell-dtk_maint.cfg
drwxrwxr-x 2 zenworks zenworks 80 Dec 1 12:17 imagex
-rwxr-xr-x 1 zenworks zenworks 374 Mar 1 16:41 kickstart.cfg
-rwxr-xr-x 1 zenworks zenworks 19544 Mar 1 16:30 memdisk
-rwxr-xr-x 1 zenworks zenworks 32614 Mar 1 16:37 nvlnbp.sys
-rwxr-xr-x 1 zenworks zenworks 14536 Mar 1 16:30 pxelinux.0
-rwxr-xr-x 1 zenworks zenworks 2704 Jan 27 11:30 pxemenu.txt
drwxr-xr-x 3 zenworks zenworks 72 Mar 1 16:41 referral
-rw-rw-r-- 1 zenworks zenworks 515556 Apr 5 12:36 tntfs.ko
-rwxr-xr-x 1 zenworks zenworks 331 Mar 1 16:41 winpe.cfg
-rwxr-xr-x 1 zenworks zenworks 453 Mar 1 16:41 z_auto.cfg
-rwxr-xr-x 1 zenworks zenworks 453 Mar 1 16:41 z_maint.cfg
-rwxr-xr-x 1 zenworks zenworks 452 Mar 1 16:41 z_zpdis.cfg
-rwxr-xr-x 1 zenworks zenworks 451 Mar 1 16:41 z_zpen.cfg

./boot:
total 163087
-rw-rw-r-- 1 zenworks zenworks 79 Jan 27 11:30 abortpxe.com
-rwxr-xr-x 1 zenworks zenworks 12288 Mar 1 16:41 bcd
-rw-rw-r-- 1 zenworks zenworks 3170304 Jan 27 11:30 boot.sdi
-rw-rw-r-- 1 zenworks zenworks 26076 Jan 27 11:30 hdlscom1.com
-rw-rw-r-- 1 zenworks zenworks 26060 Jan 27 11:30 hdlscom1.n12
-rw-rw-r-- 1 zenworks zenworks 26076 Jan 27 11:30 hdlscom2.com
-rw-rw-r-- 1 zenworks zenworks 26060 Jan 27 11:30 hdlscom2.n12
-rwxr-xr-x 1 zenworks zenworks 27816484 Mar 1 16:35 initrd
-rwxr-xr-x 1 zenworks zenworks 3166496 Mar 1 16:35 linux
-rw-rw-r-- 1 zenworks zenworks 25772 Jan 27 11:30 pxeboot.0
-rw-rw-r-- 1 zenworks zenworks 25772 Jan 27 11:30 pxeboot.com
-rwxr-xr-x 1 zenworks zenworks 16312725 Mar 1 16:35 root
-rwxr-xr-x 1 zenworks zenworks 1770 Oct 6 2010 settings.txt
-rw-rw-r-- 1 zenworks zenworks 1347 Jan 27 11:30 wdsconfig.inf
-rw-rw-r-- 1 zenworks zenworks 31124 Jan 27 11:30 wdsnbp.com
-rw-rw-r-- 1 zenworks zenworks 116130725 Jan 27 11:30 winpe.wim

./dell-dtk:
total 63754
-rwxr-xr-x 1 zenworks zenworks 1806196 Mar 1 16:41 SA.1
-rwxr-xr-x 1 zenworks zenworks 61699969 Mar 1 16:41 SA.2
-rwxr-xr-x 1 zenworks zenworks 406 Mar 1 16:41 dell-dtk.s
-rwxr-xr-x 1 zenworks zenworks 361 Mar 1 16:41 dell-dtk_maint.s
-rwxr-xr-x 1 zenworks zenworks 1657844 Mar 1 16:41 dtktask
-rwxr-xr-x 1 zenworks zenworks 39988 Mar 1 16:41 libsysfs.so.1.0.2
-rwxr-xr-x 1 zenworks zenworks 91 Mar 1 16:41 novell-dtktask

./imagex:
total 473
-rw-rw-r-- 1 zenworks zenworks 481680 Jan 27 11:30 imagex.exe

./referral:
total 0
drwxr-xr-x 2 zenworks zenworks 208 Mar 21 08:10 zfd70

./referral/zfd70:
total 20
-rwxr-xr-x 1 zenworks zenworks 1884 Mar 1 16:41 pxemenu.txt
-rwxr-xr-x 1 zenworks zenworks 453 Mar 1 16:41 z_auto100.cfg
-rwxr-xr-x 1 zenworks zenworks 453 Mar 1 16:41 z_maint100.cfg
-rwxr-xr-x 1 zenworks zenworks 452 Mar 1 16:41 z_zpdis100.cfg
-rwxr-xr-x 1 zenworks zenworks 451 Mar 1 16:41 z_zpen100.cfg


--

Shaun Pond


0 Likes
kevgo Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Same issue here. Upgraded to 11.2 and no change to the /srv/tftp/boot directory structure/drivers etc..

kevgo
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

0 Likes
kevgo Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Last statement was incorrect. initrd/linux/root all updated to the March 1 variety. I see no tntfs.ko modules available.. same when booting from the bootcd.iso (from novell-zenworks-zmgbootcd-11.2.0.16071.msi) I think I'm going crazy.. what should I be looking for?

drwxr-xr-x+ 5 zenworks zenworks 4096 2012-04-07 21:44 .
drwxr-xr-x+ 9 zenworks zenworks 4096 2012-04-07 21:43 ..
-rwxr-xr-x+ 1 zenworks zenworks 12288 2012-03-01 12:41 bcd
-rwxr-xr-x+ 1 zenworks zenworks 27816484 2012-03-01 12:35 initrd
-rwxr-xr-x+ 1 zenworks zenworks 3166496 2012-03-01 12:35 linux
-rwxrwxrwx+ 1 zenworks zenworks 302 2011-08-08 08:40 md5sum.txt
-rwxr-xr-x+ 1 zenworks zenworks 16312725 2012-03-01 12:35 root
-rwxrwxrwx+ 1 zenworks zenworks 2077 2011-07-29 10:11 settings.txt
-rwxrwxrwx+ 1 zenworks zenworks 6273 2012-03-05 17:38 ZUpdate.s
-rwxrwxrwx+ 1 zenworks zenworks 246 2012-03-05 17:38 ZUpdate.sig

kevgo
0 Likes
kevgo Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

More coffee required.. I have tnfs.ko uploaded and integrated. RTFM time.. I had assumed it woud have been as per the last decade not realizing it is a licensed third party driver. kevgo.
0 Likes
crollan Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Hi!

To get it running in the PXE-boot we added the following lines to the file "/srv/tftp/boot/settings.txt"

#
pushd /modules
tftp $PROXYADDR -m binary -c get /tntfs.ko
popd
#


Regards,
Henrik
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Crollan,

you really should not need to do that: glad it's working for you now,
but something's broken, somewhere

--

Shaun Pond


0 Likes
nson Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

spond;2189818 wrote:
Crollan,

you really should not need to do that: glad it's working for you now,
but something's broken, somewhere

--

Shaun Pond


Shaun,

We are not seeing any change in imaging times, are we correct in assuming that all we need to to do is install the new driver, make sure it is available as per doco and the it will be used to create a new image via PXE?

Thanks,
Tony
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

Nson,

yes: see TID 7009549: ZCM 11.2 - putting an image on a device is no
faster when using the new NTFS driver

--

Shaun Pond


0 Likes
crollan Absent Member.
Absent Member.

Re: Tuxera Image Engine: wont work with pxe boot

spond;2189818 wrote:
Crollan,

you really should not need to do that: glad it's working for you now,
but something's broken, somewhere

--

Shaun Pond


Shaun,

We uploaded the driver twice just to test and it's there, the bootcd_tntfs.iso booted fine with the driver but it wasn't in the PXE-boot.

It's not the first workaround since we've installed ZCM... and probably not the last.


Henrik
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.