markvh Trusted Contributor.
Trusted Contributor.
2034 views

Unable to login to ZENworks

After upgrading to ZENwork, the agent is not able to log in.
We upgraded a while ago and have always associated bundles to devices.
The LDAP user source was set and working in the past. I can log into ZCC using LDAP account, but
am not able to log into the ZCM agent on a workstation.

I tried with a older agent 11.2.3a and that fails as well.

Any help would be appreciated. Trying to change passive login reg keys etc...still no joy

Thanks
Mark
Labels (2)
0 Likes
5 Replies
Knowledge Partner
Knowledge Partner

Re: Unable to login to ZENworks

markvh;2394704 wrote:
After upgrading to ZENwork, the agent is not able to log in.
We upgraded a while ago and have always associated bundles to devices.
The LDAP user source was set and working in the past. I can log into ZCC using LDAP account, but
am not able to log into the ZCM agent on a workstation.

I tried with a older agent 11.2.3a and that fails as well.

Any help would be appreciated. Trying to change passive login reg keys etc...still no joy

Thanks
Mark


Anything in the debug log (zmd-messages.log) on the workstation?

Thomas
0 Likes
Knowledge Partner
Knowledge Partner

Re: Unable to login to ZENworks

markvh;2394704 wrote:
After upgrading to ZENwork, the agent is not able to log in.
We upgraded a while ago and have always associated bundles to devices.
The LDAP user source was set and working in the past. I can log into ZCC using LDAP account, but
am not able to log into the ZCM agent on a workstation.

I tried with a older agent 11.2.3a and that fails as well.

Any help would be appreciated. Trying to change passive login reg keys etc...still no joy

Thanks
Mark


Is it workstation specific?
When you say upgrading to ZENworks, what do you mean? Do you mean you did a System Update to say, upgrade the agent from 11.2.4 to 11.3.x?

If the latter, then we have seen about a 10% failure rate (well actually quite a lot more) with ZESM drivers, and when ZESM doesn't work, then the workstation will no longer allow user logins to the ZCM server.

As thomas mentioned, the zmd-messages log may pinpoint some issues.

Usually for us, the diagnostic so far has been:
1) Is the configuration location correct? (we have some where it goes "unknown" or "default configuration location").
2) Is the zesservice running? If not, can you manually start it?

If it's #2, then you'll have to get that working before logins will work properly, IMO

--Kevin
0 Likes
markvh Trusted Contributor.
Trusted Contributor.

Re: Unable to login to ZENworks

The configuration location is set to default "unknown"
It has always been like this but has not seemed to have been a problem in the past.
The server are on ZCM 11.3 and I have tried two agent versions, 11.2.3a and 11.3.
Still get the same error: Unable to log into the network because connection error has occurred.
This is the last bit from the log file.

[] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:19.311] [1448] [ZenworksWindowsService] [24] [] [RemotingService] [] [ZENLogin returning CONNECTION_ERROR] [] [] [] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:58.549] [1448] [ZenworksWindowsService] [28] [] [Remote Management Module] [] [(RM_DEBUG)session.IsTSClientSession : False (RM_DEBUG)] [] [] [] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:58.549] [1448] [ZenworksWindowsService] [28] [] [Remote Management Module] [] [(RM_DEBUG)session.IsTSClientSession : False (RM_DEBUG)] [] [] [] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:58.555] [1448] [ZenworksWindowsService] [28] [] [ZMD] [] [Getting Session Capability] [] [] [] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:58.555] [1448] [ZenworksWindowsService] [28] [] [ConnectMan] [] [FindFirstContent()] [] [] [] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:58.555] [1448] [ZenworksWindowsService] [28] [] [ConnectMan] [] [host xxxxx03.xxx.xx.xx connection status: Good] [] [] [] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:58.555] [1448] [ZenworksWindowsService] [28] [] [ConnectMan] [] [Since IP is good, using location http://xxx.xxx./] [] [] [] [ZENworks Agent]
[DEBUG] [05/25/2015 16:01:58.555] [1448] [ZenworksWindowsService] [28] [] [ConnectMan] [] [FindFirstContent() returning http://xxx.xxx/] [] [] [] [ZENworks Agent]
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Unable to login to ZENworks

I would check your certs, make sure they are correct, verify forward and reverse lookup, etc...
0 Likes
grahamch
Visitor.

Re: Unable to login to ZENworks

markvh;2394704 wrote:
After upgrading to ZENwork, the agent is not able to log in.
We upgraded a while ago and have always associated bundles to devices.
The LDAP user source was set and working in the past. I can log into ZCC using LDAP account, but
am not able to log into the ZCM agent on a workstation.

I tried with a older agent 11.2.3a and that fails as well.

Any help would be appreciated. Trying to change passive login reg keys etc...still no joy

Thanks
Mark


I just went through a similar issue. Have your machines applied windows update kb3061518 (MS15-055)? This update forces the use of DHE encryption keys of 1024. Satellite servers only use 512, so when they send the key to the workstation, the workstation rejects it. According to the person that I was handling my SR, the problem affects both 11.2 and 11.3.x satellites.

My locations were set to "Exclude the closest server default rule", so the workstations would only authenticate to the specified satellite(s) that I had set. I was able to get authentication working again (as a workaround) by unchecking this box and the refreshing the workstations so that they could fail up to authenticating to a primary.

You could also uninstall the update or use the workaround specified in the MS KB (https://support.microsoft.com/en-us/kb/3061518) which forces the use of 512 encryption.

The person I was working with has created a defect for the product.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.