markfritz Absent Member.
Absent Member.
1111 views

Upgrade 11.4.3 primary server problem

Hi,

I am upgrading from 11.4.2 to 11.4.3 on our primary server and the process completed with Errors.

I get the following message when I log into the Zone:

Your zone is being upgraded to ZENworks 11.4.3. However, the following Primary Servers in this zone have not yet been upgraded to ZENworks 11.4.3. You need to take these servers offline, and manually upgrade them at the earliest.
Note: If any of these servers are in the process of being upgraded, you can ignore this warning. They will be removed from this list once the Agent refresh is completed.

And when I check on the deployment status this is the error shown:
An error occurred when trying to execute the move file command (${ZENWORKS_TEMP}/confFilesBackup/${UPDATE_GUID}/loader;${ZENWORKS_CONF}/loader) on the device. Check the system-update.log on the device for details.

I've had a look in the deployment folder and I can see a loader.bak folder but no loader folder.

The actual error in the system-update.log is:
[DEBUG] [10/17/2016 20:13:49.156] [6328] [ZENUpdater] [] [SYSTEM] [SystemUpdate] [] [DEBUG] [Attempting to move file C:\Program Files (x86)\Novell\ZENworks\temp/confFilesBackup/5011040300fc50000000002016100814/loader to C:\Program Files (x86)\Novell\ZENworks\conf/loader] [] [] [ZENworks]
[DEBUG] [10/17/2016 20:13:49.156] [6328] [ZENUpdater] [] [SYSTEM] [SystemUpdate] [] [DEBUG] [Could not find file 'C:\Program Files (x86)\Novell\ZENworks\temp/confFilesBackup/5011040300fc50000000002016100814/loader'. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
Labels (2)
0 Likes
3 Replies
shaunpond Absent Member.
Absent Member.

Re: Upgrade 11.4.3 primary server problem

Markfritz,

I had the same problem - luckily it worked when I went into the failed
column and marked it for deployment

--

Shaun Pond
in my "day job" I work for ENGL; our aim is to make Windows deployment
easy


0 Likes
markfritz Absent Member.
Absent Member.

Re: Upgrade 11.4.3 primary server problem

I'm still having this problem with our primary server, I've deleted the update and tried to re-import it using zman sui but it's been stuck in the 'Downloading' status for days now. Is there a way I can forcefully remove the update and cleanup traces of if to try to re-import it again?
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Upgrade 11.4.3 primary server problem

markfritz;2444796 wrote:
I'm still having this problem with our primary server, I've deleted the update and tried to re-import it using zman sui but it's been stuck in the 'Downloading' status for days now. Is there a way I can forcefully remove the update and cleanup traces of if to try to re-import it again?


zman sudu "systemupdatename" --force


If you are downloading from the internet @ download.novell.com and then you can manually download the SU file and use "zman sui" to import it locally.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.