tweiland Absent Member.
Absent Member.
1267 views

WOL only works via proxy

When I try to send a WOL packet from the server (even to a workstation on the same vlan), I get no magic packet and an error in loader-messages.log:

[DEBUG] [3/4/09 10:34:11 AM] [] [Loader.QueueRunner] [Handler failed to process action ID : 193, Type: WOL_QUICK_ACTION_TYPE, ] [Handler failed to process action ID : 193, Type: WOL_QUICK_ACTION_TYPE, ] [] []
[DEBUG] [3/4/09 10:34:11 AM] [] [Loader.QueueRunner] [java.lang.NullPointerException
at com.novell.zenworks.loader.modules.NetworkInterfac e.convertIPStringToBytes(NetworkInterface.java:92)
at com.novell.zenworks.loader.modules.NetworkInterfac e.getSubnetAddress(NetworkInterface.java:68)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vice(WOLUtil.java:140)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vicesIntoSubnet(WOLUtil.java:97)
at com.novell.zenworks.loader.modules.WakeOnLANHandle r.processAction(WakeOnLANHandler.java:304)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.processAction(QueueThreadWorker.ja va:193)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.run(QueueThreadWorker.java:139)
at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)
] [java.lang.NullPointerException
at com.novell.zenworks.loader.modules.NetworkInterfac e.convertIPStringToBytes(NetworkInterface.java:92)
at com.novell.zenworks.loader.modules.NetworkInterfac e.getSubnetAddress(NetworkInterface.java:68)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vice(WOLUtil.java:140)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vicesIntoSubnet(WOLUtil.java:97)
at com.novell.zenworks.loader.modules.WakeOnLANHandle r.processAction(WakeOnLANHandler.java:304)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.processAction(QueueThreadWorker.ja va:193)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.run(QueueThreadWorker.java:139)
at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)

If I select a workstation as a proxy, the magic packet get sent and works as expected.

ZCM 10.1.3 on Windows 2003 R2
Labels (2)
0 Likes
1 Reply
tweiland Absent Member.
Absent Member.

Re: WOL only works via proxy

My server summary page shows two lines for IP address:

Alias: ozzen99.shbeta.com
Host Name: ozzen99
IP Address: null
172.18.99.19
Last Full Refresh: 10:09 AM
Last Contact: 10:14 AM

including null (which might relate to that java error). Is that normal? If not, how can I get rid of it?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.