rhuhman1 Absent Member.
Absent Member.
2042 views

Windows 7 Implementation with ZCM

I am in the process of moving the school district I work for over to Windows 7 Pro. I have run into several issues specific with Windows 7 during my build of ZCM11. The major issue is Application deployment on Windows 7. I am wondering if anyone has gone through this process and has some possible advice or even web resources that will help in this process.

Currently I am facing the possibility of starting out with all my end users being administrators over there own laptops so that applications can install and attach to the primary laptop users profile correctly.

Thanks for any advice and/or web resources that you can provide.

Rich
Labels (2)
0 Likes
4 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Windows 7 Implementation with ZCM

rhuhman,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Windows 7 Implementation with ZCM

More details about issues would be necessary to offer help.
Disabling UAC can help getting started, so that is one less new thing to
worry about.

Then add UAC later when there is less learning curve going on.

On 5/8/2011 10:36 AM, rhuhman wrote:
>
> I am in the process of moving the school district I work for over to
> Windows 7 Pro. I have run into several issues specific with Windows 7
> during my build of ZCM11. The major issue is Application deployment on
> Windows 7. I am wondering if anyone has gone through this process and
> has some possible advice or even web resources that will help in this
> process.
>
> Currently I am facing the possibility of starting out with all my end
> users being administrators over there own laptops so that applications
> can install and attach to the primary laptop users profile correctly.
>
> Thanks for any advice and/or web resources that you can provide.
>
> Rich
>
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
0 Likes
rhuhman1 Absent Member.
Absent Member.

Re: Windows 7 Implementation with ZCM

Craig, Thanks for responding. I am having issues deploying application (MSI's mainly) to users that don't have administrative access. I know to raise the access level for the deployment to administrative so that the application would install correctly. What I was finding is that the application would deploy but the users wouldn't have full access to the program. An example is iFolder Client. When I was deploying this app I would get a full deployment successfully yet any user that logged in after the deploy still wouldn't have iFolder launching. The app could be manually launch by going to the Program Files location.

Here is what I have found. In using the iFolder deployment as an example. I would deploy the ifolder3-windows.exe file to a local folder then run ifolder3-windows.exe /s /v/qn. The app would deploy in the background without error. If I would log in as Administrator everything would work correctly. But the end user this app was intended for wouldn't have access to the iFolder app due to the fact they were either a users or power users member. To correct this, and this seems to work for most of this type of app, I am now deploying with the following switches. /v /s"/qn ALLUSERS=1"

I do have UAC turned off. Actually have that posted in my xml file during the syspreped deployment of the OS. I also turn off the Windows Firewall in favor of my AV's version which I have a bit more remote control over.

I am interested in any other tips or tricks anyone that has gone through a large deployment of Windows 7 might have.

Thanks for the help.

Rich
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Windows 7 Implementation with ZCM

Yes, The AllUsers option may be required.
It's good to specify it.

By Default, an MSI Bundle action will specify AllUsers=1

http://www.appdeploy.com/faq/detail.asp?id=69

When a value is not given, it goes to a specific profile.
Generall "Allusers" is desired.

When a ZCM bundle launches as "Dynamic Administrator" and you specify a
Profile, it would be that profile, which is not the one you want.

In regards to iFolder, I think it's a bit odd it needs that parameter.
Most software will usually using 1 or 2 for that parameter if its an
EXE. (Most Exes just wrap around an MSI install.)


On 5/15/2011 11:06 AM, rhuhman wrote:
>
> Craig, Thanks for responding. I am having issues deploying application
> (MSI's mainly) to users that don't have administrative access. I know
> to raise the access level for the deployment to administrative so that
> the application would install correctly. What I was finding is that the
> application would deploy but the users wouldn't have full access to the
> program. An example is iFolder Client. When I was deploying this app I
> would get a full deployment successfully yet any user that logged in
> after the deploy still wouldn't have iFolder launching. The app could
> be manually launch by going to the Program Files location.
>
> Here is what I have found. In using the iFolder deployment as an
> example. I would deploy the ifolder3-windows.exe file to a local folder
> then run ifolder3-windows.exe /s /v/qn. The app would deploy in the
> background without error. If I would log in as Administrator everything
> would work correctly. But the end user this app was intended for
> wouldn't have access to the iFolder app due to the fact they were either
> a users or power users member. To correct this, and this seems to work
> for most of this type of app, I am now deploying with the following
> switches. /v /s"/qn ALLUSERS=1"
>
> I do have UAC turned off. Actually have that posted in my xml file
> during the syspreped deployment of the OS. I also turn off the Windows
> Firewall in favor of my AV's version which I have a bit more remote
> control over.
>
> I am interested in any other tips or tricks anyone that has gone
> through a large deployment of Windows 7 might have.
>
> Thanks for the help.
>
> Rich
>
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.