Anonymous_User Absent Member.
Absent Member.
857 views

Wrong imaging update

I've updated my imaging server to ZCM 3.0
I am trying to apply the latest imaging update.
oN the download site I see:

zenworks11.3.1_Oct14.zip applies to ZCM 11.3.0, ZCM 11.3.0 FRU1, ZCM 11.3.1 and 11.3.1 FRU1

The closes match to this file name available is zenworks11.3.1_FRU1_Oct14.zip

I downloaded this and tried this. When I try to apply it I get an error telling me this is the wrong driver update.

I tried the update for 11.2.4 (this was the ZCM version before I upgraded to 11.3) but that also fails with the same error.

Thomas
Labels (2)
0 Likes
5 Replies
shaunpond Absent Member.
Absent Member.

Re: Wrong imaging update

Thomas,

look for the log file in the driver update directory to tell you what
it thinks is wrong

--

Shaun Pond (now working for ENGL)
newly reminted as a Knowledge Professional


0 Likes
beheergelre Absent Member.
Absent Member.

Re: Wrong imaging update

We have the same issue with the last driver update.
There is no log file created. Is there a solution for this problem ?
0 Likes
shaunpond Absent Member.
Absent Member.

Re: Wrong imaging update

Beheergelre,

the first thing the update does it to put things in the log file - what
OS are you running on?

--

Shaun Pond (now working for ENGL)
newly reminted as a Knowledge Professional


0 Likes
Highlighted
elagrew Absent Member.
Absent Member.

Re: Wrong imaging update

Are you still having issues? Have you found a solution?

--El

beheergelre;2348515 wrote:
We have the same issue with the last driver update.
There is no log file created. Is there a solution for this problem ?

El LaGrew elbert.lagrew#katun.com elagrew on twitter
0 Likes
Mue
New Member.

Re: Wrong imaging update

Hi,

i found a solution for this problem. (Example Bash Script, SLES Primary Server 11.3.2)

First step of the Bash Script is to verify the correct ZENworks Version.

if "%revision%" NEQ "%scriptversion%" (
CSCRIPT EchoNoNewLine.vbs //NOLOGO /TEXT:"Applying wrong imaging driver updates ......"
echo.
goto exit_driver_update
)

Scriptversion was set to 113 at the beginning of the script.

revision was set to:

set revision=
for /f "delims=" %%a in (ZUpdate.sig) do (
set line=%%a
if "!line:~0,2!"=="11" (
set revision=!line:~0,3!
)
)

you can find the ZUpdate.sig here :
/opt/novell/zenworks/preboot/imaging/update/ZUpdate.sig (SLES)
%ZEN_HOME%\share\preboot\update\ZUpdate.sig (Windows)

When you open the ZUpdate file with cat you can see:
# Specify the ZEN Imaging client version
[ZEN_CLIENT_VERSION]
113200

[UPDATE_FILES]
/bin/update.s
/grub.s
/grub-mbr.s
/util.s
/zenpart.s
/linux
/initrd
/root
/movezisd
/message
/bootlogo
/chroot
/ZUpdate.s
/ZUpdate2.s
/ZUpdate.sig
/settings.txt
[UPDATE_UEFI_FILES]
/settings.txt
/ZUpdate.sig
/root
/EFI/initrd
/EFI/linux
/EFI/nvlgrub.cfg
/EFI/elilo.conf
/EFI/nvlgrubx64.efi
/EFI/elilox64.efi
/EFI/bootx64.efi
/EFI/EfiZUpdate.s

In my case, the Version was still on 1124, after changing the value to 1132 the update was installed, without any errors .

Maybe its the same problem you have ?!?

cheers,
Andre
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.