Highlighted
davsor Absent Member.
Absent Member.
1754 views

ZCM 10.3.1a - unable to connect to the Zenworks database

We're running ZCM 10.3.1a, currently only for Patch Management and a few bundles - it was just updated in december from 10.2 to latest version 10.

Monday, I got

Error: Unable to connect to the ZENworks database. Please ensure that the ZENworks database is running. One of the possible causes could be the database server IP address changed. Please see the documentation for manual steps required to fix the login issue associated with it.

when attempting login.

SInce nothing has changed in the surrounding environment, I checked the server: /var/opt/ is out of diskspace.

From Google, I learned that such an event could corrupt the ZCM database - sounds mighty strange to me; is it true!?!??

Anyway, advice on how to proceed from here is much appreciated - anyone 🙂 ?
Labels (2)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: ZCM 10.3.1a - unable to connect to the Zenworks database

davsor,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
davsor Absent Member.
Absent Member.

Re: ZCM 10.3.1a - unable to connect to the Zenworks database

Problem solved. With some aid from a ZCM pro, here is what I did:

In VMware vSphere - expanded the virtual secondary disk 40>100GB

enter zen
- gedit /etc/fstab and commented out the /var/opt mount
- since cli kept saying device busy on 'umount /var/opt'

reboot
- enter zen -> YAST partitioner and expand 40GB disk > 100 GB...
- uncomment the line in /etc/fstab

and reboot.. voila!!!
and apparentely the db is intact 🙂

So - I guess it's thanks for nothing on this one 😄

Automatic reply;2088605 wrote:
davsor,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit NOVELL: Support and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
NOVELL FORUMS FAQ

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.