NovAlf Outstanding Contributor.
Outstanding Contributor.
448 views

ZCM 17.4 and “Waiting for ZENworks agent to do ..."

ZCM 17.4 and “Waiting for ZENworks agent to do initial refresh”
Hi over a while!
After ZEN 2017 Update 4 we start to see this kind of weird problems when ZENworks agent can’t start. First we saw this on newly installed Windows 10 device. Agent already setup and ZENworks has doing it’s job for settings programs etc., but suddenly … error “Waiting for ZENworks agent to do initial refresh” appear (days after initial setup) and … ZEN stuck. (I’ve seen this red info on NAL/ZAPP window taskbar, but just at once after setup, not later, ever.) Restarted device, nothing, zac cc (if could access to zac), nothing, re-registered device, still nothing, uninstalled agent and reinstalled … still the same. (Also, noticed, sometimes after … something I messed around … it took almost 10 minutes and … agent start to act normally.) And … also suddenly … it start to act normally again – started device and ZEN started wo delay as usually. Well, we thought some … single case (doubtful, though) and … today same problem appear on Windows 7 Pro SP1 device, out of the blue. Windows 10 on which this problem appear was about to set for use, but W7 device was and is in use and we depend on ZEN as most of users programs and running links etc. is set via ZENworks centrally based on device and on user. Bad situation! So far I haven’t got my hand on this device as user still on it and need to work, so, no logs and I can’t get anything remotely as refresh etc. direct commands do not work (remote control actions do).
So, any experiences on this?
More thanks, Alar.
https://forums.novell.com/showthread.php/507393-ZCM-agent-2017-update-2a-Waiting-for-initial-refresh
Labels (1)
0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Re: ZCM 17.4 and “Waiting for ZENworks agent to do ..."

Sorry...not a clue....

At this point, I'm not aware of any "New to 17.4" issues reported by any customers.
Nor am I aware with any open issues that would relate........

An SR would be best.....
If Remote Actions work...you can likely do a remote file copy to get logs for your SR.
zmd-messages.log would likely be most important.....
Since the issue is random, may want to make sure zone is in "debug" for the agents so the logs have good detail....when the issue pops up on a device.









NovAlf;2496689 wrote:
ZCM 17.4 and “Waiting for ZENworks agent to do initial refresh”
Hi over a while!
After ZEN 2017 Update 4 we start to see this kind of weird problems when ZENworks agent can’t start. First we saw this on newly installed Windows 10 device. Agent already setup and ZENworks has doing it’s job for settings programs etc., but suddenly … error “Waiting for ZENworks agent to do initial refresh” appear (days after initial setup) and … ZEN stuck. (I’ve seen this red info on NAL/ZAPP window taskbar, but just at once after setup, not later, ever.) Restarted device, nothing, zac cc (if could access to zac), nothing, re-registered device, still nothing, uninstalled agent and reinstalled … still the same. (Also, noticed, sometimes after … something I messed around … it took almost 10 minutes and … agent start to act normally.) And … also suddenly … it start to act normally again – started device and ZEN started wo delay as usually. Well, we thought some … single case (doubtful, though) and … today same problem appear on Windows 7 Pro SP1 device, out of the blue. Windows 10 on which this problem appear was about to set for use, but W7 device was and is in use and we depend on ZEN as most of users programs and running links etc. is set via ZENworks centrally based on device and on user. Bad situation! So far I haven’t got my hand on this device as user still on it and need to work, so, no logs and I can’t get anything remotely as refresh etc. direct commands do not work (remote control actions do).
So, any experiences on this?
More thanks, Alar.

https://forums.novell.com/showthread.php/507393-ZCM-agent-2017-update-2a-Waiting-for-initial-refresh
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.