Highlighted
Solid1723
Established Member.
114 views

ZENagent Auto Login Problem

Jump to solution

Hello everyone,

I'm running into a problem with the ZENagent auto login in a VDI environment (VMware View using linked clones)

The registration of the clones in ZCC is looking good and I can log into the VMs via the VMware Client but in allmost all cases, the auto login into the agent won't work.

After provisioning the desktop-pool, the first few logins will sometimes succeed, but will eventually stop working even on the same VM with the same user.

To configure the VM for the Master-Image I used this guide.

Has anyone else run into this problem?

 

 

 

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

Re: ZENagent Auto Login Problem

Jump to solution

I would recommend opening an SR.

This is a known issue on Windows 1803 or Later, due to a Windows Bug.

We have gotten a Private Fix from MS on 1903 that we could provide.  A public fix from MS will most likely be available in the Feb 2020 time frame, but I'm not sure if the fix will be rolled back to all impacted versions.  I believe that will be the case.

There are some hacks to get around the issue without the fix, but a little too involved to try and cover in the forums.

Note: This issue can occur anytime the ZCM Credential Provider is not primary.  Seems there is a bug with the MS Credential provider handing stuff off to others and terminating some processes too soon.  However, the have confirmed the MS patch resolves the issue.

 

 

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
2 Replies
Micro Focus Expert
Micro Focus Expert

Re: ZENagent Auto Login Problem

Jump to solution

I would recommend opening an SR.

This is a known issue on Windows 1803 or Later, due to a Windows Bug.

We have gotten a Private Fix from MS on 1903 that we could provide.  A public fix from MS will most likely be available in the Feb 2020 time frame, but I'm not sure if the fix will be rolled back to all impacted versions.  I believe that will be the case.

There are some hacks to get around the issue without the fix, but a little too involved to try and cover in the forums.

Note: This issue can occur anytime the ZCM Credential Provider is not primary.  Seems there is a bug with the MS Credential provider handing stuff off to others and terminating some processes too soon.  However, the have confirmed the MS patch resolves the issue.

 

 

--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
Solid1723
Established Member.

Re: ZENagent Auto Login Problem

Jump to solution
Thank you for the quick reply, Craig. I'll open an SR then.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.