jcj4235 Absent Member.
Absent Member.
2070 views

Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

Server: Windows 2008R2 and Zenworks 11SP3 with update (System is running as VM on vmware 5.5)

Have made 3 attempts to upgrade the zenworks to 11.4 and each time it gets stuck at "Upgrading Packages: 89% complete" I have let it sit over 3 hours with no results.

Any ideas?

Thanks,

Joel

Zenworsk_Upgrade XML file:

INFO 09/21/2015 09:21:03 CreateUpdateCommandsConfigureAction complete!
INFO 09/21/2015 09:20:56 UpdateSUStatusForDeviceConfigureAction complete!
INFO 09/21/2015 09:20:56 AssignSystemUpdateConfigureAction complete!
INFO 09/21/2015 09:20:56 Windows Installer is not running, return val : 0
INFO 09/21/2015 09:20:56 WriteToFileConfigureAction complete!
INFO 09/21/2015 09:20:56 AuthorizeUpdateConfigureAction complete!
INFO 09/21/2015 09:20:56 UpdateOpaqueDataConfigureAction complete!
INFO 09/21/2015 09:20:56 ImportSUConfigureAction complete!
INFO 09/21/2015 09:11:48 ExecutePreGlobalConfigureAction complete!
INFO 09/21/2015 09:11:48 The preglobal status after ExecutePreGlobalConfigureAction launched :[2015.09.21-09:09:34] FINER: Setting schema version in DB. [2015.09.21-09:09:34] FINER: DatabaseUpgradeConfigureAction: getConnection [2015.09.21-09:09:35] FINER: Upgrading database schema. [2015.09.21-09:09:35] FINER: DatabaseUpgradeConfigureAction: getConnection [2015.09.21-09:11:47] FINER: Pre-global actions executed @SUCCESS
INFO 09/21/2015 09:09:33 isZoneAuthConfigureAction:false
INFO 09/21/2015 09:09:33 UpdateOpaqueDataConfigureAction complete!
INFO 09/21/2015 09:09:33 UpdateSUStatusConfigureAction complete!
INFO 09/21/2015 09:09:32 UpdateSybaseServiceConfigureAction complete!
INFO 09/21/2015 09:08:05 RebuildSybaseDBConfigureAction complete!
INFO 09/21/2015 09:04:46 BackupSybaseTransactionLogConfigureAction complete!
INFO 09/21/2015 09:04:23 UpgradeSybaseDBConfigureAction complete!
INFO 09/21/2015 09:04:04 sybase-asa-12.0.1.3924.x86_64.msi already installed, will not be re-installed
INFO 09/21/2015 09:03:58 AddOEMDBParamConfigureAction complete!
INFO 09/21/2015 09:02:05 Novell TFTP Service is NOT running.
INFO 09/21/2015 09:02:05 Novell Proxy DHCP Service is NOT running.
INFO 09/21/2015 09:02:05 CASA Authentication Token Service is NOT running.
INFO 09/21/2015 09:02:05 The ZDS_SERVER service does not exist
INFO 09/21/2015 09:02:05 Novell ZENworks Join Proxy is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Preboot Service is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Preboot Policy Service is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Embedded Datastore for Audit is running.
INFO 09/21/2015 09:02:05 Novell ZENworks Management Agent is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Remote Management Agent is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Server is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Loader is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Service Monitor is NOT running.
INFO 09/21/2015 09:02:05 Novell ZENworks Embedded Datastore is running.
INFO 09/21/2015 09:01:44 StopZIconProcessConfigureAction complete!
Labels (2)
0 Likes
7 Replies
jcj4235 Absent Member.
Absent Member.

Re: Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

I did another upgrade and watched it in great detail. Before it hits 89% there is a lot of CPU and disk usage. But once it hits 89% the CPU usage and disk just stop.

Here is info from the last accessed log files.

SYSTEM-UPDATE.log
[INFO] [09/21/2015 14:57:21.808] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [INSTALLING_PERCENTAGE] [INSTALLING] [88] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.808] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_SHARE] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.808] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_SHARE] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.824] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to delete file: C:\Program Files (x86)\Novell\ZENworks\share/boe-publish] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.824] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [looking for :C:\Program Files (x86)\Novell\ZENworks\share\boe-publish. Exists: False] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.824] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [] [] [ZENworks]
[INFO] [09/21/2015 14:57:21.824] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [INSTALLING_PERCENTAGE] [INSTALLING] [89] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.824] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_WORK] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_WORK] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_WORK] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Could not find source file 'C:\Program Files (x86)\Novell\ZENworks\work/DnDLogger.db', skipping command.] [] [] [ZENworks]
[INFO] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [INSTALLING_PERCENTAGE] [INSTALLING] [89] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: content.0.path] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [variable not found in knownVariables or in environment : content.0.path] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [looking for item in content list] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.839] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [content id : 49e9a3566619482d5b7de53453e85958] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.855] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [creating path: D:\Common\systemupdate\DBRegUpdater.exe] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.855] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: content.0.path] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.855] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [variable not found in knownVariables or in environment : content.0.path] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.855] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [looking for item in content list] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.855] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [content id : 49e9a3566619482d5b7de53453e85958] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.855] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [creating path: D:\Common\systemupdate\DBRegUpdater.exe] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:21.855] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Starting process: D:\Common\systemupdate\DBRegUpdater.exe Option : ] [] [] [ZENworks]
[INFO] [09/21/2015 14:57:23.431] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [INSTALLING_PERCENTAGE] [INSTALLING] [89] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.431] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_TEMP] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.431] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_TEMP] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.431] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Starting process: C:\Program Files (x86)\Novell\ZENworks\temp\CASARegistryChange-Updater.exe Option : ] [] [] [ZENworks]
[INFO] [09/21/2015 14:57:23.555] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [INSTALLING_PERCENTAGE] [INSTALLING] [89] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.571] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_BIN] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.571] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_BIN] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.571] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_CONF] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.571] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: ZENWORKS_TEMP] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.571] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Attempting to resolve variable: UPDATE_GUID] [] [] [ZENworks]
[DEBUG] [09/21/2015 14:57:23.571] [7024] [ZENUpdater] [] [Admin] [SystemUpdate] [] [DEBUG] [Starting process: C:\Program Files (x86)\Novell\ZENworks\bin\novell-zenworks-configure.bat Option : -c DatamodelCachingMergeConfigureAction -DbaseFolder="C:\Program Files (x86)\Novell\ZENworks\conf/datamodel/caching" -DbackedupFolder="C:\Program Files (x86)\Novell\ZENworks\temp/confFilesBackup/5011040000fc50000000002015073012/datamodel/caching" -nopause] [] [] [ZENworks]
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

The last thing it does is to export the database to:
C:\Program Files
(x86)\Novell\ZENworks
\temp/confFilesBackup/5011040000fc50000000002015073012/datamodel/cachin
g

Any activity there?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
jcj4235 Absent Member.
Absent Member.

Re: Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

Anders

The directory has a modify time of 14:26. It looks like all of the file got backed up.

In the C:\Program Files (x86)\Novell\ZENworks\temp/confFilesBackup/5011040000fc50000000002015073012 directory a tomcat folder was created at 14:50 but is empty.

Joel
0 Likes
jcj4235 Absent Member.
Absent Member.

Re: Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

FYI, I let the install sit at 89% for over 15 hours and nothing changed.

I have gone back to the previous snapshot so I can get the system up and running. Will have try try again later.

Joel
0 Likes
jcj4235 Absent Member.
Absent Member.

Re: Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

After doing some searching the install seems to hang on the command:

C:\Program Files (x86)\Novell\ZENworks\bin\novell-zenworks-configure.bat -c DatamodelCachingMergeConfigureAction -DbaseFolder="C:\Program Files (x86)\Novell\ZENworks\conf/datamodel/caching" -DbackedupFolder="C:\Program Files (x86)\Novell\ZENworks\temp/confFilesBackup/5011040000fc50000000002015073012/datamodel/caching" -nopause

I have manually run this and no errors occur.

The Install-Commands.XML file show:

<UpdateCommand>
<type>PROCESS_START</type>
<Contents />
<options><options><cmdoptions><option>-c</option><option>DatamodelCachingMergeConfigureAction</option><option>-DbaseFolder="${ZENWORKS_CONF}/datamodel/caching"</option><option>-DbackedupFolder="${ZENWORKS_TEMP}/confFilesBackup/${UPDATE_GUID}/datamodel/caching"</option><option>-nopause</option></cmdoptions><zenoptions><HIDE_PROCESS_WINDOW /><WAIT_FOR_EXIT exitCodeExpn="" /></zenoptions></options></options>
<command>${ZENWORKS_BIN}\novell-zenworks-configure.bat</command>
</UpdateCommand>

The next XML commad is:

- <UpdateCommand>
<type>PROCESS_START</type>
<Contents />
<options><options><cmdoptions><option>-c</option><option>UpdateServerVersion</option><option>-c</option><option>CleanupObsoletePackages</option><option>-nopause</option></cmdoptions><zenoptions><HIDE_PROCESS_WINDOW /><WAIT_FOR_EXIT exitCodeExpn="" /></zenoptions></options></options>
<command>${ZENWORKS_BIN}\novell-zenworks-configure.bat</command>
</UpdateCommand

So it is hanging on the completion of DatamodelCachingMergeConfigureAction or on the start of UpdateServerVersion. I'm thinking it is hanging of the completion because I don't get a log entry of it completing.

Any ideas where I should look next?

Joel
0 Likes
jcj4235 Absent Member.
Absent Member.

Re: Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

Problem Solved!

I feel like a dumb DONKEY but I solved my issue..

I was logging in as a domain admin and running the installer as either myself or using the RUN-AS Administrator. Both would hang at 89%. When I logged in as the local administrator, and ran the installer, it installed without a problem.

Joel
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Zenworks Upgrade 11 SP3 to 11 SP4 stuck at 89%

Jcj4235,
> I was logging in as a domain admin and running the installer as either
> myself or using the RUN-AS Administrator. Both would hang at 89%. When
> I logged in as the local administrator, and ran the installer, it
> installed without a problem.


Ah.. Then it was a rights issue. Glad you got it sorted.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.