Anonymous_User Absent Member.
Absent Member.
804 views

agent on OES, installation broken, uninstall impossible

(Second try, maybe was in the wrong group before...)

Hello,

I tried to install ZCM 11 agent on an OES 11 server, which should take the
imaging role.

Agent installation seemed to be successful:

----
s1:/inst #
../PreAgentPkg_AgentLinuxComplete.bin

Cmd: '/bin/sh /opt/novell/zenworks/stage/installJava.sh
INSTALL_JRE'

Starting the installation...
Checking pre-requisites...
Opening the TCP and UDP port 7628 on the firewall...
Installing the packages...
[..]
Adding zone CA certificate to the trust store..
Creating the configuration files...
Cleaning up the installation files...
Starting the agent service /etc/init.d/novell-zenworks-xplatzmd...
The ZENworks Adaptive Agent has been successfully installed.
----


The agent seems to start but nothing works... for example;

s1:~ # zac
Error processing the ZAC command. null

In /opt/novell/zenworks I see hundreds of files like hs_err_pid9996.log
which say something about a fatal error with the JRE.

/opt/novell/zenworks/bin/novell-zenworks-xplat-uninstall fails with a
message like "unable to obtain registration status". The KB mentions a
cleaning tool, but it seems to be available for windows only.


I suspect that the problem has something to do with ports. But I don't find
exact info in the docu which ports are used by the agent and how to change
them. Maybe the agent tries to use 443 which is used by apache. How can I
change the port for the agent?

Alternatively: How can I get rid of the agent to start over again?

Thanks,
Mirko

Labels (2)
0 Likes
2 Replies
peterhine Absent Member.
Absent Member.

Re: agent on OES, installation broken, uninstall impossible

run rpm -q jre please

jre-1.6.0_16-fcs is the one i have


I had a dev server where i had allowed jre to go up to 1.7x, and zenworks programs died badly


p
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: agent on OES, installation broken, uninstall impossible

peterhine wrote:

>
> run rpm -q jre please
>
> jre-1.6.0_16-fcs is the one i have


The same here.

> I had a dev server where i had allowed jre to go up to 1.7x, and
> zenworks programs died badly


I have 1.7 on my SLED, but not on a server.

(BTW: the agent installed fine on SLED.)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.