Knowledge Partner
Knowledge Partner
922 views

specify default proxy server for wake-up

ZCM 11.3.2. Is there a way to specify a default proxy server for
doing wake-up? I have PCs across my WAN link that I always have to
specify a proxy server when I wake them up. It would be nice if I
could tell ZCM to always use a specific server for those PCs.

Ken

--------------------------------------------------------
Create and vote for enhancements!
https://www.novell.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
Labels (2)
0 Likes
12 Replies
Micro Focus Expert
Micro Focus Expert

Re: specify default proxy server for wake-up

This sounds like a WOL question, not a Remote Control Question.

Remote Control Proxies are defined via Location Policies.

For WOL, I recommend White Listing Primary Servers Address for Subnet Broadcasts. (Keep in mind, this is not a network wide broadcast, no device will receive a packet that does not using the Proxy....Just less packets crossing routers/switches...)
Far simpler for the WOL process and reduces network traffic. (Just send the WOL packet over the WAN all the traffic and communication involved for the primary to reach out to the proxy to and tell it what commands to issue.)
0 Likes
Knowledge Partner
Knowledge Partner

Re: specify default proxy server for wake-up

On Tue, 19 Jul 2016 12:36:02 GMT, CRAIGDWILSON
<CRAIGDWILSON@no-mx.forums.microfocus.com> wrote:

>
>This sounds like a WOL question, not a Remote Control Question.
>Remote Control Proxies are defined via Location Policies.


Yes, I was wanting WOL assistance. Just use it all the time when
doing remote so I asked here.

>For WOL, I recommend White Listing Primary Servers Address for Subnet
>Broadcasts. (Keep in mind, this is not a network wide broadcast, no
>device will receive a packet that does not using the Proxy....Just less
>packets crossing routers/switches...)
>Far simpler for the WOL process and reduces network traffic. (Just send
>the WOL packet over the WAN all the traffic and communication involved
>for the primary to reach out to the proxy to and tell it what commands
>to issue.)


Sorry for being dense this morning...I'm not following what you said
there. Can you explain again? What I've been doing is this... I
have a ZCM satellite at my 2nd office across the WAN link. If I
specify that satellite when trying to wake up a device at that office,
the device wakes up. If I leave the WOL setting at "automatically
detect the server", then the device never gets woken up.

Ken

--------------------------------------------------------
Create and vote for enhancements!
https://www.novell.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: specify default proxy server for wake-up

Nope.....
Not Being Dense 🙂

There are 2 Types of Broadcasts Generally.....

Those targeted to the entire network...
255.255.255.255

Those targeted to a specific subnet (Let's say you are using Class C)
10.10.1.255

In the 1st case, the broadcast will try and hit every device on all subnets on your network.
In the 2nd case, a single packet is sent to server/switch handling the 10.10.1 network.
That will then send the broadcast packet to all devices on the 10.10.1.255 network.
(ZCM uses the 2nd type)

In theory, malware of some sort could spam all of your routers with broadcasts packets making it easier to flood more devices than sending out packets one by one.
As a result, by default most Switches Routers do not relay subnet broadcasts by default. Rather you must enable it and define trusted devices to send the packets.
This would be in your Router/Switch Docs.....Google Subnet Broadcasts.

Also keep in mind that the configuration for Full Network vs Subnet Broadcasts are different settings.
Full Network Broadcasts are a good thing to block, but ZCM does not use those.

So when you use a proxy, the Primary must Auth to the Satellite, then send down the details saying send a WOL packet to this Subnet, and then the remote satellite sends the WOL packet. to all devices.
If you enable the primary to forward it, just the one packet goes from the primary to the remote router, and then to all devices there.

Less Traffic, Less Moving Parts, Easier to Operate Day to Day.
0 Likes
Knowledge Partner
Knowledge Partner

Re: specify default proxy server for wake-up

On Tue, 19 Jul 2016 13:36:01 GMT, CRAIGDWILSON
<CRAIGDWILSON@no-mx.forums.microfocus.com> wrote:

>So when you use a proxy, the Primary must Auth to the Satellite, then
>send down the details saying send a WOL packet to this Subnet, and then
>the remote satellite sends the WOL packet. to all devices.


So if I understand correctly, the above is what is happening when I
tell WOL to specifically use the satellite?

>If you enable the primary to forward it, just the one packet goes from
>the primary to the remote router, and then to all devices there.


And if I tell ZCM to automatically detect, it is trying to do this,
but it can't because my router is blocking the packet?

Ken

--------------------------------------------------------
Create and vote for enhancements!
https://www.novell.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: specify default proxy server for wake-up

If you configure your switches/routers to permit the Primary to Allow a WOL packet, the packet can originate from the primary w/o a Proxy.
Auto-Detect will try and find a satellite on the same subnet to relay the request.

If you need to manually select, then I'm guessing it the satellite is on a different subnet or zcm did not calculate it to be on that subnet.
(In this case, the switches were configured for subnet broadcasts within the remote network, but are likely not configured with restrictions on who can send.)
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: specify default proxy server for wake-up

Actually Auto-Detect does not use Satellite, It is the closest Primary...which of course is normally all are equal...In short that normally means "Send from Primary" and your routers need to be setup to allow for this.
Really a complete misnomer IMHO.

Auto-Discovery for a Satellite on the Same Subnet would be that, but that is not how it was configured.
I suspect much of this design dates back to before Satellite Servers Existed.

Since many choose to simply allow the Primaries to do the work, not many requests have come in to update auto-detect to also query satellite server addresses.
0 Likes
Knowledge Partner
Knowledge Partner

Re: specify default proxy server for wake-up

On Tue, 19 Jul 2016 14:56:02 GMT, CRAIGDWILSON
<CRAIGDWILSON@no-mx.forums.microfocus.com> wrote:

>
>Actually Auto-Detect does not use Satellite, It is the closest
>Primary...which of course is normally all are equal...In short that
>normally means "Send from Primary" and your routers need to be setup to
>allow for this.
>Really a complete misnomer IMHO.
>
>Auto-Discovery for a Satellite on the Same Subnet would be that, but
>that is not how it was configured.
>I suspect much of this design dates back to before Satellite Servers
>Existed.
>
>Since many choose to simply allow the Primaries to do the work, not many
>requests have come in to update auto-detect to also query satellite
>server addresses.
>
>
>--


Ok. Looks like I need to investigate how to enable the WOL packets as
mentioned in one of your previous posts. Thanks.
Ken

--------------------------------------------------------
Create and vote for enhancements!
https://www.novell.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: specify default proxy server for wake-up

0 Likes
Knowledge Partner
Knowledge Partner

Re: specify default proxy server for wake-up

On Tue, 19 Jul 2016 15:46:02 GMT, CRAIGDWILSON
<CRAIGDWILSON@no-mx.forums.microfocus.com> wrote:

>
>http://www.cisco.com/c/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans.html
>if u have cisco is a start, but then there are routers etc...


Thanks, but I have a Barracuda handling this traffic. If I can't
figure it out, I'll give their tech support a call.
Ken

--------------------------------------------------------
Create and vote for enhancements!
https://www.novell.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
0 Likes
Knowledge Partner
Knowledge Partner

Re: specify default proxy server for wake-up

On Tue, 19 Jul 2016 15:46:02 GMT, CRAIGDWILSON
<CRAIGDWILSON@no-mx.forums.microfocus.com> wrote:

>
>http://www.cisco.com/c/en/us/support/docs/switches/catalyst-3750-series-switches/91672-catl3-wol-vlans.html
>if u have cisco is a start, but then there are routers etc...


Craig,
Barracuda tech support got it working for me. We just needed to
create a rule to handle the traffic. Thanks for the assistance!
Ken

--------------------------------------------------------
Create and vote for enhancements!
https://www.novell.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: specify default proxy server for wake-up

Great News!
0 Likes
Knowledge Partner
Knowledge Partner

Re: specify default proxy server for wake-up

On Tue, 19 Jul 2016 14:46:02 GMT, CRAIGDWILSON
<CRAIGDWILSON@no-mx.forums.microfocus.com> wrote:

>
>If you configure your switches/routers to permit the Primary to Allow a
>WOL packet, the packet can originate from the primary w/o a Proxy.
>Auto-Detect will try and find a satellite on the same subnet to relay
>the request.
>
>If you need to manually select, then I'm guessing it the satellite is on
>a different subnet or zcm did not calculate it to be on that subnet.
>(In this case, the switches were configured for subnet broadcasts within
>the remote network, but are likely not configured with restrictions on
>who can send.)


I have two subnets - Primary is located at one and Satellite is
located at the other. And WOL packets from the Primary are not
getting to the secondary at the moment.

Ken

--------------------------------------------------------
Create and vote for enhancements!
https://www.novell.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.