Highlighted
HeatherM1 Honored Contributor.
Honored Contributor.
370 views

CM9.2 User Unable to Search for Records

Since implementing CM9.2 last year, we've had 3 different users experience a problem where they search for a record, either via the quick search pane or via Find Records, and get a blank search result screen returned (screenshot attached). It doesn't matter what search method they use, and they also get the same blank screen when opening Favourite Records,  Recent Documents, My Containers, or when running a saved search.

They are able to view records when navigating through the Classification Scheme (although Show Records returns a blank screen, being a type of records search) and can search for all other objects in CM.

It's not a security issue, as the user it happened to this morning is an administrator and in any case, nothing has changed with any of the users' profiles, the records' security and access has not been changed and the standard "No Records found. There may be matching records....." message is not displayed.  It's almost like the records are being found, but the results screen is being blanked somehow.

Exiting CM, logging off and on and restarting the PC does nothing. The first time it happened, I removed the dataset and re-added it and that worked.  For the other two users (one is an account that doesn't have to access CM very often and the other a training account created as an administrator) I am unable to resolve this issue.  Logging onto a different PC doesn't fix it, and other users are able to log onto the PC that the affected user normally accesses with no problems.

I'm just wondering if anyone has seen this and knows a fix, before I resort to a CM reinstall or having to redo the user's roaming profile.

0 Likes
4 Replies
Micro Focus Expert
Micro Focus Expert

Re: CM9.2 User Unable to Search for Records

I notice that in the screen shot the results windows has the word 'Filtered' in it.  Are there any default filters, what do you see if you remove all filters?


Blog | Samples | CM SDK Docs
**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of MicroFocus**
0 Likes
HeatherM1 Honored Contributor.
Honored Contributor.

Re: CM9.2 User Unable to Search for Records

Hi David,

Thanks for replying. 

The only filter being applied is to screen out some legacy record types that are no longer used.  This default filter has been in place since implementation with no issues.  When all record types are included in the search, the affected user still gets the blank screen.  Other users with the same permissions, security levels and access control group membership can run record searches with the default filter with no problems.

0 Likes
Outstanding Contributor.. AG_LTBit Outstanding Contributor..
Outstanding Contributor..

Re: CM9.2 User Unable to Search for Records

Hi @HeatherM1

This might be a long shot as I have never seen this exact issue myself, I have experienced some other display issues that were due to the display settings. 

Can you confirm what resolution the display is set to and if there is any scaling (for that specific user on that specific computer)?
The settings are in the Display Settings (screen shot attached for Win 10)

AG.

-----------------------------------------------------------------------
www.ltbit.com.au
0 Likes
HeatherM1 Honored Contributor.
Honored Contributor.

Re: CM9.2 User Unable to Search for Records

Hi AG,

Thank you for the suggestion - sadly, changing the screen resolution / font size, etc (we're on Windows 7) doesn't fix the issue.

Cheers,

Heather

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.