Highlighted
Regular Contributor.. AndrewV68 Regular Contributor..
Regular Contributor..
294 views

Documents automatically checking in - CM 9.3 Patch 1

We have just upgraded from 8.3 to 9.3.1.300 and we are encountering some issues with documents checking in whilst still being edited by the user. This is resulting in the user losing their changes . We have had 5 reported instances since going live this week. We have a user base of 1550

It is not user error as I have remoted in to their machine to observe how it is behaving

There is no open documents options in 9.3 except by adding an open documents registry key so has anyone applied that 

I haved checked registry settings and noticed our deployment team did not remove the old HPE RM registry settings that contains the same dataset ID as CM 9 - could this also have an impact .

Anyway just wanting to know if anyone else has encountered this issue 

Cheers

 

0 Likes
8 Replies
Strider_1 Honored Contributor.
Honored Contributor.

Re: Documents automatically checking in - CM 9.3 Patch 1

Hi 

I've seen this behaviour once before ... not sure if this information will be useful or not... 

In our instance it was happening to spreadsheets that had 'sharing' turned on.

Cheers

0 Likes
Regular Contributor.. AndrewV68 Regular Contributor..
Regular Contributor..

Re: Documents automatically checking in - CM 9.3 Patch 1

Thanks for that

Unfortunately no 😞 .... these are word docs

 

Have a great weekend

0 Likes
Super Contributor.. davros29 Super Contributor..
Super Contributor..

Re: Documents automatically checking in - CM 9.3 Patch 1

We haven't gone live with 9.3 yet, but we've had good results in our testing with these settings.

 

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Micro Focus\Content Manager\OpenDocuments]
"MinimumDelayDiscard"=dword:00000014
"MinimumDelay"=dword:00000014
"MinimumCloseInterval"=dword:00000005

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Micro Focus\Content Manager\SDK]
"DisableLeakTracking"=dword:00000001

 

See also @Neil Summers post with the links to the doco on the OpenDocuments settings.

https://community.microfocus.com/t5/Content-Manager-User-Discussions/HPE-Wait-Time-Before-Auto-Check-In-is-Too-Long/m-p/1670076/highlight/true#M37550

0 Likes
Strider_1 Honored Contributor.
Honored Contributor.

Re: Documents automatically checking in - CM 9.3 Patch 1

Should I be nervous if I don't have any of those registry keys on my PC after a 9.3 install? 🙄

0 Likes
Super Contributor.. davros29 Super Contributor..
Super Contributor..

Re: Documents automatically checking in - CM 9.3 Patch 1

Nope. We've added them to our deployment package. They're not there by default.

Regular Contributor.. AndrewV68 Regular Contributor..
Regular Contributor..

Re: Documents automatically checking in - CM 9.3 Patch 1

Thank you for that 

What does the "disable leak tracking" key do. That is the only key I do not have 

0 Likes
Super Contributor.. davros29 Super Contributor..
Super Contributor..

Re: Documents automatically checking in - CM 9.3 Patch 1

Just included that for completeness. Probably shouldn't have. It's not related to Edit/TRIMWatcher behaviour.

Certain versions of TRIM were trying to write some diagnostic data to the Windows event log and this bombed out if the current user didn't have rights to do this. This regkey disabled that behaviour.

0 Likes
Regular Contributor.. AndrewV68 Regular Contributor..
Regular Contributor..

Re: Documents automatically checking in - CM 9.3 Patch 1

Just an update

It appears the Auto check-in issue our users are experiencing is related to documents remaining in offline records. The offline Records for users has existed through the upgrades from TRIM 7 to CM 9.3 and some users have an extensive amount of empty containers and documents

So I have cleared out all the empty containers applied the user setting to Automatically remove offline containers when they become empty 

I also made a back-up of the users offline records folder and deleted everything out of the offline records tray in the client.

There was some minor check-in issues with .doc as they would not check-in, changing the format to docx solved that problem 

Tested this with several affected users and they no longer have auto check-in issues

I would like to thank everyone for their help 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.