Highlighted
Mark-sai Respected Contributor.
Respected Contributor.
384 views

HP.HPTRIM.SDK.dll not working with RM8.3 64 bit installation

I am creating some web api  using HP.HPTRIM.SDK.dll to interact with our RM instances. In my dev machine I used to have RM 32 bit installed. But after I upgrade to 64 bit, I am not able to connect to my RM server anymore via the api. I have that version/build mismach error. Is that means in order to user HPTRIM SDK, the workgroup server which has on must always be on 32 bit?

0 Likes
2 Replies
MichaelQ Super Contributor.
Super Contributor.

Re: HP.HPTRIM.SDK.dll not working with RM8.3 64 bit installation

64 bit is perfectly acceptable.  It's more likely that your references weren't updated when you switched bitness versions.

Have you tried removing the 32 bit reference and adding the 64 bit reference in your original Web API project?

Mark-sai Respected Contributor.
Respected Contributor.

Re: HP.HPTRIM.SDK.dll not working with RM8.3 64 bit installation

Yes, i have tried re-adding the reference. But apparently it does not like 64 bit. So now i have revert it back to 32 bit on my client.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.