Highlighted
Absent Member.. Absent Member..
Absent Member..
222 views

HPECM webdrawer doesn´t work after upgr. 8.3 to 9

hi,

did the upgrade to CM 9.0. After opening the web-site webdrawer http://localhost/HPECMWebDrawer/search the errormessage "could not load type ´ServiceStack.WebHost.Endpoints.ServiceStackHttpHandlerFactory"...

Just wanted to quickly check if anyone got a hint during upgrade procedure. (already followed the webdrawer troubleshooting hints)

Regards,

Matthias

0 Likes
5 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Matthias, We haven't seen any issues here, however I will typically never upgrade a version. Rather, un-install and then install the new version.

9 has yet to be released to the public so you won't find too many people in the same position as yourself. If you have gone through the proper channels for the pre-release you should have a contact to register you issues with.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Micro Focus**
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi Greg,

thanks for reply. It is already available for download.

Regards,
Matthias

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Can you check the user accounts that are being used for both IIS and CM are correctly setup.

You need to:

  • Turned UAC off
  • Check that the guest account login and the web apppool user account has been created into the environment

If the account have not been correctly created, you need to change to them and rstart IIS for the changes to take effect.

 

 

(Please state the version of TRIM/RM/CM that you are using in all posts)

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Micro Focus
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Matthias,

How did you go with Webdrawer, was the suggestion from Tony helpful

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Micro Focus**
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi Greg,

it works now. Thanks for support. The users were correct.

To solve the upgrade issue I followed the below procedure to get it working

  1. If already CM 9 installed - De-installed webdrawer through CM 9 setup
  2. delete or rename with win-explorer C:\HP Records Manager\WebDrawerWorkpath
  3. delete or rename with win-explorer C:\Program Files\HewlettPackardEnterprise\Records Manager\WebDrawer
  4. Perform install of web-drawer CM 9 setup

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.