Super Contributor.. AldoH Super Contributor..
Super Contributor..
82 views

Loader database error The dataset with ID '??' has not been configured on this machine and no HPE

Jump to solution

Hi

I'm trying some examples that include the SDK and I'm trying to run one that creates a new record. But when I execute it I get this error message.

Loader database error The dataset with ID '??' has not been configured on this machine and no HPE Records Manager Workgroup Server has been specified to search for it

Can someone tell me what this may be due to. What do I need to configure? What am I doing wrong?

I am using HPRM 8.3 and I am new to using the SDK.

Thank you,

0 Likes
1 Solution

Accepted Solutions
Quinton Bernhardt Respected Contributor.
Respected Contributor.

Re: Loader database error The dataset with ID '??' has not been configured on this machine and no HP

Jump to solution

Hi

I have received this error in the past when I didn't explicitly set the workgroup server property on the database object.

 

After explicitly setting it the error disappeared.

Regards,
Quinton Bernhardt
Meniko Records Management Services
0 Likes
3 Replies
Outstanding Contributor.. Sten28 Outstanding Contributor..
Outstanding Contributor..

Re: Loader database error The dataset with ID '??' has not been configured on this machine and no HP

Jump to solution

Not a developer but I would assume you'd need the HPE RM 8.3 Desktop Client installed on the machine, and make sure it has a dataset that the Account executing the code can connect to.

Easy way to validate:

  • Open HPE RM desktop directly
  • Make sure it connects to a dataset automatically, or, if presented with the Open Datasets window, that you have at least 1 dataset configured. 
  • If no datasets are configured, Add a Dataset by entering in your primary Workgroup server (server address), then selecting your dataset.

Hope this helps.

0 Likes
Quinton Bernhardt Respected Contributor.
Respected Contributor.

Re: Loader database error The dataset with ID '??' has not been configured on this machine and no HP

Jump to solution

Hi

I have received this error in the past when I didn't explicitly set the workgroup server property on the database object.

 

After explicitly setting it the error disappeared.

Regards,
Quinton Bernhardt
Meniko Records Management Services
0 Likes
Super Contributor.. AldoH Super Contributor..
Super Contributor..

Re: Loader database error The dataset with ID '??' has not been configured on this machine and no HP

Jump to solution

Thanks, specifying the workgroupserver eliminated the error.Sorry for the rookie mistake, but I'm learning on the go.Thank you.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.