Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..
1122 views

Opening Word slow with CM9.3 Add-in enabled

Jump to solution

Not sure if this is just our test environment, but our early testing indicates a massive slowdown to opening Word and Excel when the CM9.3 add-in is enabled,

Example

Time to open a new blank Word document

7 Secs (without add-in)

15 secs (with CM9.3 office add-in enabled) + another 15 secs if TRIMwatcher.exe is not yet running. 

Therefore it can take roughly 30 secs to start a blank Word document in my current test environment. This concerns me.

Opening the CM client in the same environment takes about 5-6 secs.

I will conduct further testing but has anyone else noticed similar?

 

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Update

This issue appears to have been related to our test VM desktops not having sufficient CPU resources. Further testing after updating the CPU resources has alleviated our concerns

View solution in original post

5 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Also something which is puzzling to me.

When I open Word with CM9.3 Add-in installed TRIMwatcher.exe kicks off (and adds to the start-up time)

In Excel or PowerPoint this does not happen. TRIMWatcher is initiated only when closing the application after saving into CM.

 My tests are with Office 2013 and CM9.3 Win 10 32 Bit Office and CM

0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Hi Joshua,

I experienced the similar issues in my dev env with Windows 8.1 and Office 2013. In my case, I turned off the Internet Tools - Advance tab - publisher certificate validations. Secondly, I also found that wigh Office 2016 for some reason Office 2016 kept trying to assess if it was Office 365 and trying to connect with Microsoft site (I found these access entries in my Firewall Logs).

Once I unchecked those Publisher Certificate validations, and restart the Office, Word starts loading as normal.


Cheers,
Harry
0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Thanks Harry

No change for me when unchecking that option.

Also nothing listed in the firewall logs directory.

I will need to run Procmon and see what is delaying startup.

I still find it unusual that TRIMwatcer.exe is starting when Word is opened (not editing a document from CM). Is this common to other users?

 

 

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Update

This issue appears to have been related to our test VM desktops not having sufficient CPU resources. Further testing after updating the CPU resources has alleviated our concerns

View solution in original post

Highlighted
Community Manager Community Manager
Community Manager

Thanks for taking the time to let us know the resolution.

--
My computer used to beat me at chess all the time, but then I changed the competition to kick boxing.......
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.