samd_1 Absent Member.
Absent Member.
2421 views

Prereqs for Outlook add-in confirmation from support needed

Since Trim 7.0 and now to 7.1 I have not been installing the Primary Interop Assemblies nor the Visual Studio Tools for the Office system 3.0 that were prereqs for Outlook in Trim 6.25. Fro Trim 7+ there are two new prereqs called HP Visual Basic Runtimes and Visual Studio 2008 Runtimes. I had assumed that these were replacements for the former or were renamed. Normally when I do manual installs I do NOT check Outlook integration as I do the install by logging in as an admin. I let the user enable Outlook integration afterward. Today I checked integration while installing as an admin and noticed it gave me a message about missing prereqs which were Primary Interop Assemblies and the Visual Studio Tools for the Office system 3.0. I decided to uncheck the integration and get the install done. I had the user check the Outlook integration and it worked fine. I have also enabled it on my machine without Primary Interop Assemblies and the Visual Studio Tools for the Office system 3.0 installed and the toolbar at least shows up fine. I haven't done further testing. 1. Are these prereqs needed in 7.1 or is the install wrong? I see no mention of them in the install even though the message says they are in there. 2. Why does the integration work, as far as I can tell if they are required? What problems should I see if they aren't installed? 3. What are the new prereqs for, HP Visual Basic Runtimes and Visual Studio 2008 Runtimes, if not for Outlook integration? Answers from support would be great.
0 Likes
13 Replies
Outstanding Contributor.. raynebc Outstanding Contributor..
Outstanding Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

I've had a long ticket going with HP about this recently.  My experience with 7.1.1132 is that it does not indicate PIA is a requirement, just the VB and VS runtimes.  However, if you install it without the appropriate Primary Interop Assemblies, Outlook 2003/2007 integration isn't going to work.  The 6.25 documentation mentions you need PIA, but 7.x doesn't.  I haven't found what VSTOR is really needed for, HP never got back to me on that one.  I am able to get Outlook 2003/2007/2010 integration working without it.  As of yet, I don't believe HP has admitted that this is a documentation error with Trim.

0 Likes
Outstanding Contributor.. raynebc Outstanding Contributor..
Outstanding Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

Following up on this, as of a few weeks ago, HP support refused to look into further or update the documentation to explain this requirement, giving the following reason (quoted word for word):

"Our documentation doesn’t mention much about Office 2003, except that it’s supported, because we expect people to be upgrading to Office 2007 or 2010 by now."

Without indicating they'd even tried it themselves, they wrote it off as a problem unique to our environment on the basis that it wasn't a "global problem" that had been commonly reported to them.  If the support tech had searched this support forum, he should have found that this isn't just a fluke, it's an issue that's been recreated in another customer's environment.

0 Likes
Grundy Acclaimed Contributor.
Acclaimed Contributor.

Re: Prereqs for Outlook add-in confirmation from support needed

Hi Rayne,

 

Sorry that you've had a less than stellar response from support.

 

I had seen this reported a couple of times in APJ and the support team here raised it with R&D.

There is an open CR, 40515, and I expect that the documentation will be updated in a future release.

 

It is true that we would prefer to move away from Office 2003 support, but that doesn't mean the documentation can't be accurate!

 

So just to confirm:

Yes, the O2003PIA, O2007PIA and vstor30 pre-requisites are still a requirement for the Outlook Integration.

 

 

 - JG

 



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
0 Likes
Outstanding Contributor.. raynebc Outstanding Contributor..
Outstanding Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

Thank you.  I'm glad this issue can finally be cleared up.

0 Likes
Highlighted
Super Contributor.. Erik Wold Super Contributor..
Super Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

Attached is the error you will see after opening Outlook 2003 if the O2003PIA.exe is not installed for the TRIM 7.1 integration.

0 Likes
JasonIMEX Outstanding Contributor.
Outstanding Contributor.

Re: Prereqs for Outlook add-in confirmation from support needed

Yes I have had this issue also... By rule of thumb now I instll the PIA on 2003/2007 it has been my experience that 2010 is fine without them but generally install the 2010 PIA anyway..

 

In terms of the Vsto3.0  I have pretty much done away with that in TRIM 7.1 installs as I was under the impression that it was only a requirement for the Excel integration.

HP Records management suite specialists
www.imexwa.com.au
0 Likes
Outstanding Contributor.. raynebc Outstanding Contributor..
Outstanding Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

Documentation still not corrected as of Trim 7.1.1157.  I don't know why it's taking HP so long, it will literally take a matter of seconds to add a sentence or two to the Trim spec document to address this requirement.

0 Likes
Grundy Acclaimed Contributor.
Acclaimed Contributor.

Re: Prereqs for Outlook add-in confirmation from support needed

There's a fix in 7.1.1:

 

41051 Documentation - Prerequisites not mentioned for client upgrade installation
Fixed. Prerequisites are now correctly documented in the Installation documentation for client upgrades.

 

Though I havn't checked the SPEC/Install PDF to confirm the this is for the Outlook prereqs.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
0 Likes
Outstanding Contributor.. raynebc Outstanding Contributor..
Outstanding Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

That's entirely my point:  I examined those documents with the latest Trim 7.1.1 release, and it does not mention the PIA and Vstor requirements.  Trim install (page 59) says to refer to the Trim spec document for pre requisites regarding upgrading the clients, and Trim spec lists (page 15) "Microsoft Office 2003, 2007 SP2 or 2010" as the only requirement to use the TiO integration.  This is proven to be incomplete information, as PIA is required for the integration for all Office 2003/2007 applications in general, and somebody mentioned on the forum that Vstor was for the Excel integration.

0 Likes
Grundy Acclaimed Contributor.
Acclaimed Contributor.

Re: Prereqs for Outlook add-in confirmation from support needed

Ok, you said 7.1.0 1157, didn't realise you meant everything SINCE then was wrong (including 7.1.1).

Makes sense, I'll check it out.

 

I know the support guys reported this, so don't shoot the messenger! 🙂



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
0 Likes
Outstanding Contributor.. raynebc Outstanding Contributor..
Outstanding Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

7.1.1157 is the latest 7.1.x release I have access to from HP's website as of now, so I don't know if there's a newer one that's fixed.  I spent weeks trying to get HP to admit it was omitted from the documentation instead of being a problem with our Trim environment, so I'd just hate to see all that effort lost.

0 Likes
Grundy Acclaimed Contributor.
Acclaimed Contributor.

Re: Prereqs for Outlook add-in confirmation from support needed

Hmmm, that CR 41051 says it just added the following to the TRIMInstall:

 

Ensure the client computer has a supported operating system and all the necessary components installed.
See TRIM7.11_Spec.pdf

 

That's handy when the TRIMSpec is still wrong....but let me check!

There was an old CR, 37638 that said:

 

 

DOCUMENTATION CHANGE:
On page 30, added:
The HP TRIM add-in for Outlook 2003 requires:
·       Microsoft .NET Framework 3.5 SP 1
·       Microsoft's O2003pia.msi
·       Microsoft's Vstor30.exe
The HP TRIM add-in for Outlook 2007 requires:
·       Microsoft .NET Framework 3.5 SP 1
·       Microsoft's O2007pia.msi
·       Microsoft's Vstor30.exe

 

But this doesn't appear in the 7.1.X doco.

It IS in the 6.2.5 TRIMSpec though.  -_-

 

 

I've raised it again with R&D under incident QCIM2D43785.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
0 Likes
Outstanding Contributor.. raynebc Outstanding Contributor..
Outstanding Contributor..

Re: Prereqs for Outlook add-in confirmation from support needed

It's probably worth having them confirming whether or not those prerequisites are necessary for Office 03/07 applications besides Outlook.  Thank you for your efforts.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.