Highlighted
Micro Focus Expert
Micro Focus Expert
174 views

<(RM) Support tip> - Content Service (engine) won't start due to failed language settings

A content service (engine) was reporting:
28/03/2017 16:12:54 [1] 00-Always: Error: Languagetype englishUTF8 has been changed. Previous definition (lang=ENGLISH, enc=UTF8) will be used.
28/03/2017 16:12:54 [1] 99-Always: Failed to initialise language settings. Exiting

Although there was no evidence that language settings failed before or after a server reboot, the Content Engine was convinced there was a language issue and would stop immediately.

The only recourse is:
1) Restore from backup
2) Reindex

Backup is the best for a large environment, as a reindex could take days.  Find backup files from a date prior to error and then overwrite/move to target Content Engine index folder location.  Once restored, restart the Content Service and see if it is able to function properly.  Check the IDOL Content Service's application.log file to confirm successful startup.

Failing that, a reindex would be necessary.  Contant HPE CM Support team for reindex steps for your environment.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.