Data Discovery Agent failed to install on Windows server 2016 due to SQL Server installation error

Data Discovery Agent failed to install on Windows server 2016 due to SQL Server installation error

Symptoms

Agent installation failed on Windows server 2016 (AWS Instance).

Diagnosis

1, Checked and ensured Agent installation was done using the latest version of  DMA.exe on supported platform.

DMA.exe version  18.0.0.0  as on  May the 1st  2020.

Platform : Windows server 2016

2,  Collected and reviewed the Micro_Focus_FAS_Agent_Install log.

Default log directory :  C:\Program Files\Micro Focus\FAS\Agent\_Micro Focus FAS Agent_installation\Logs

In the Agent install log, it showed only one error during installation, which is an error about  SQL Server installation :

Execute Script/Batch file:   Getting the arguments for the SQL Server installation

                          Status: ERROR

                          Additional Notes: ERROR - java.lang.StackOverflowError

Please note that running a supported version of SQL Server is required before the FAS Agent can be installed on the machine.  When running Agent installation in Complete mode, Agent installation will install  supported version of SQL Server Express bundled in Agent installation program.

If SQL Server Express installation or DB installation fails during the Agent installation process,  Agent installation will fail also and installed files will be uninstalled by installation program.

Solution

1,  Please ensure the latest version of .NET Framework is installed on the Windows server.

In this particular case (Windows server 2016  AWS Instance ),  .NET Framework 4.7.1 should be installed successfully before installing the Agent.

.NET Framework is also pre-requisites for  SQL Server installation.

2, Run DMA.exe as Administrator (Right click on DMA.exe > Run as Administrator ).

After taking the above steps, Agent installation ran through successfully on the VM.

Labels (1)

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
4 of 4
Last update:
‎2020-09-14 14:17
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.