DP 10.x NETIO thread did not connect

DP 10.x NETIO thread did not connect

Symptoms

The file system backup got below error:

[Critical] From: VBDA@server1 "backuplog"  Time: 15/04/2020 16:18:52
NETIO thread did not connect => aborting.

[Major] From: BSM@cell.manager "backuplog"  Time: 15/04/2020 16:19:28
[61:1005]   Got unexpected close from VBDA on server1.

Diagnosis

 It seems Encrypted Control Communication (ECC) is still enabled on the DA client. ECC was the secure communication mechanism used in versions prior to 10.X DP components.

This looks to be the root of this error.

[ 99] 2020-04-17 09:38:29.678 ("/lib/cmn/win32cmn.c $Rev$ $Date::                      $:":630)
[ 99] ===>> (3) CmnGetFile {
[ 99]   Args: path:C:\ProgramData\OmniBack\config\client\config
[ 99]

[ 99] 2020-04-17 09:38:29.678 ("/lib/cmn/win32cmn.c $Rev$ $Date::                      $:":669)
[ 99] <<=== (3) }  /* CmnGetFile */
[ 99]   RetVal: (ptr) 0000000000AF8720
[ 99]
[199] [file_load] loaded version:1, size:622, length:1
[199] [Config_load] return at 349: 1
[260] [SSL_NegotiateConnect] 

Solution

ECC needs to be disabled here as both DA and MA clients are on 10.X versions
Delete the file C:\ProgramData\OmniBack\config\client\config. This is the ECC configuration file.

As a reference, please see the below upgrade prerequisites:

https://docs.microfocus.com/itom/Data_Protector:2019.05/UpgradePrereq 

Additional Information

Labels (1)

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Comments

Isn't ECC newly introduced in v10? My FS this morning that has been backing up  fine all of a sudden gave a "NETIO thread did not connect" error. Looking at the "C:\ProgramData\OmniBack\config\client\config" file shows "encryption=;" What does this mean?

Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2020-06-04 07:41
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.