Honored Contributor.. Alpha_1_1 Honored Contributor..
Honored Contributor..
154 views

DP10.20 - Connection to Media Agent broken => aborting

DP 10.20 - Virtual CM (W2012), Physical MA (W2K8), Physical DA (W2K8)

Hi,

I've been trying to diagnose an issue affecting a client in my environment but I'm no closer to resolving it than when I started.

I have a W2K8 R2 client in a domain separate to the CM but reachable through firewall rules.

The client's backup fails intermittently; I have been able to interactively back up its CONFIGURATION object but not its C:\ or D:\ partitions.

The result is the same whether the backup writes to a Tape Library or to one of our HPE StoreOnce devices.

When the backup runs, it writes between 40-116MB and then fails with the message

"[Critical] From: VBDA@3dsecdmcapp1.pcisecure.net "C:" Time: 02/09/2019 17:39:52
Connection to Media Agent broken => aborting."

and exits. No error code, no earlier message to suggest any problems. I haven't seen anything useful in debug logs either.

Omnirc file on the CM, MA and DA contains the following entries:

OB2SHMIPC=0
OB2IPCKEEPALIVE=1
OB2INETTIMEOUT=150
OB2IPCKEEPALIVETIME=900
OB2IPCKEEPALIVEINTERVAL=60
OB2PORTRANGESPEC=xMA-NET:18000-18025;xSM:20100-20199 (inactive since upgrade to DP 10.0 - reactivated but ineffective)
OB2SHMEM_IPCGLOBAL=1

The service account for Data Protector is in Local Admins on the client, and has the rights "Act as Part of the OS" and "Log On as a Service".

It's strange that I can reach one part of the client but not others - this suggests a security issue but there's nothing that my colleague or I can see that might indicate a lack of user rights.

I'd be interested to learn if anyone has seen this behaviour in DP 10 (or any other version) and has any suggestions on how to resolve it.

Any and all advice welcome.

Thanks,

Bob

GTS I&O - "If you noticed it before we did, it's an application issue..."
0 Likes
6 Replies
Micro Focus Expert
Micro Focus Expert

Re: DP10.20 - Connection to Media Agent broken => aborting

Hello @Alpha_1_1

First of all, the variable OB2PORTRANGESPEC is not needed anymore and useless since DP 9.09, and actually sometimes can cause problems. Please disable it. 

After that, I can think that problem is with secure comm configuration. Run this command between the DA and MA in both ways: omnicc -secure_comm -configure_peer servername

Regards, 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
Knowledge Partner
Knowledge Partner

Re: DP10.20 - Connection to Media Agent broken => aborting

Hello @Alpha_1_1,

Can you share the full session report with us? Do you mean the Windows firewall or a firewall in the network?

If the recommended command shared by @Victor_F_DP does not work (in both directions) then the firewall might cause this. If the firewall also has IPS enabled, it might intercept the connection due to TCP tunnelling used. Have seen this on Sophos UTM in the past and configuring exceptions was the only way around it.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Honored Contributor.. Alpha_1_1 Honored Contributor..
Honored Contributor..

Re: DP10.20 - Connection to Media Agent broken => aborting

Hi Andres,

Thanks for the reply - I had previously disabled OB2PORTRANGESPEC (possibly due to the upgrade to V10) but re-enabled it to test the backup response. I've since disabled it again.

And omnicc -secure_comm had already been run both ways between CM and DA, so no joy there, sorry to say.

Regards,
Bob

PS -Apologies for the delay in replying - MicroFocus' forum pages have been intermittently inaccessible the past couple of days...
GTS I&O - "If you noticed it before we did, it's an application issue..."
0 Likes
Honored Contributor.. Alpha_1_1 Honored Contributor..
Honored Contributor..

Re: DP10.20 - Connection to Media Agent broken => aborting

Hi Sebastian,

Thanks - it's a strange one, isn't it?

Windows Firewall is disabled by policy; 3rd-party firewalls protect our various domains, so our Security team maintain rules to allow traffic move between domains.

As I mentioned in reply to @Victor_F_DP, omnicc -secure_comm -configure_peer has been set in both directions but has made little difference, with backups being intermittently successful.

I've run an interactive backup of the affected client (3dsecdmcapp1.newdomain.net) and the session log is attached - I'd be interested to know what you think.

Cheers,

Bob

PS - apologies for the late reply; I've had trouble accessing the Community site lately...

GTS I&O - "If you noticed it before we did, it's an application issue..."
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: DP10.20 - Connection to Media Agent broken => aborting

Hello @Alpha_1_1,

You can try to enable Reconnect Broken Connections in the Backup Options. But the object fails so quickly there are only two options from my point of view.

  1. An IPS in the firewall dropping the connection for some reason.
    => Talk to the security team if they see an incident at the time when the connection drops.
  2. The Media Agent process on 3dsecdmcapp1.newdomain.net failing.
    => Check the operating system eventlogs for a possible process crash.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Honored Contributor.. Alpha_1_1 Honored Contributor..
Honored Contributor..

Re: DP10.20 - Connection to Media Agent broken => aborting

Thanks Sebastian,
Will do...
Bob
GTS I&O - "If you noticed it before we did, it's an application issue..."
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.