Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Highlighted
Lupson Absent Member.
Absent Member.
1092 views

DP2 integration failure with 12:8019

DB2 integration failed with the following message after patching.

 

libdb2.a: Could not load module /047_48fs01/DB2/lib64/libdb2.a.
System error: Exec format error

 

libdb2.a permissions are set to:

 

-rwxrwxrwx    1 bin      bin        70202037 Jul 02 2012  libdb2.a

Tags (1)
0 Likes
2 Replies
Bob_Clark Absent Member.
Absent Member.

Re: DP2 integration failure with 12:8019

I found one occurrance of this error, it occurred in DP 6.20, and the cause was that he was running an unsupported version of AIX

 

I would need to know your version of AIX (or whatever type of server you are running DB2 on), your version of DB2, and your version of Data Protector, so I can check the support matrix tomake sure that you have a supported configuration

0 Likes
Dennis Handly Acclaimed Contributor.
Acclaimed Contributor.

Re: DP2 integration failure with 12:8019

>-rwxrwxrwx    1 bin      bin        70202037 Jul 02 2012  libdb2.a

 

Ideally the permission shouldn't have "w" enabled.

Also, if this is a load module, why does it have a .a instead of a .so?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.