Absent Member.. Absent Member..
Absent Member..
1000 views

Data Protector 6.11 poor performance

We are having poor performance on single source backups (meaning backing up a single source directory). Our environment implies otherwise.

EVA5000 on 4Gb SAN fabric with dual paths.
MSL6030 Tale library connected to SAN with one LTO3 and one LTO4 drive.
DL380 G5 Dual with 32GB memory and a dual channel 4Gb fiber card.
Windows 2008 R2 and Data Protector V6.11 at the latest patch levels.
The drive (LUN) is defined to the server and so is the tape library drive. Therefore the data should only be traversing the SAN fabric.

It takes approximately 12 hours to backup 366GB to the LTO4 drive. Calculated, it should only take about 3 hours to backup that amount of data on a 50% loaded environment!

Now for the kicker! 🙂 If I run Windows defrag utility against the disk drive I am backing up, I almost get my calculated throughput!!!

Question is why???? I am thinking that Data Protector cannot push the SAN hard enough to cache its data but with defrag running, the SAN pays attention more these I/Os.
0 Likes
8 Replies
Absent Member.
Absent Member.

Just so I understand, the LUN you are backing up is on the Cell Manager?

If that is the case, you should get pretty good performance.

Since you're not, how big is the file system? If it is a ton of small files, the backup will be slow because it is traversing the filesystem looking for all of the files to backup.

I would also turn off the file system tree walk at the beginning of the job. Add the following to the omnirc. file on the cell manager.

# NoTreeWalk=0|1
# Default: 0
# If NoTreeWalk is set to 1, the file system scan is not performed. Used
# to speed up the backup of a large filesystem with a large number of
# small files. Should be only set on the clients that need the performance
# increase.
#
NoTreeWalk=1

Also, I would disable the defrag during your backups, that will cause contention and slow things down.

Defragging the file system is a good thing, but not during the backup.

If the LUN is on another server, is there a media agent loaded on that server? If not, you are talking over the LAN, not the SAN.

Dave

0 Likes
Absent Member.. Absent Member..
Absent Member..

Please read the above again. When defrag IS running the performance is GOOD, and when defrag is NOT running performance is BAD!
0 Likes
Absent Member.
Absent Member.

I read the above to mean the defrag performed well. Not that backup performed well while defrag runs and poorly when it doesn't run.

Sorry.

If that is the case, I suspect it isn't a Data Protector issue, but something with the EVA, HBA, or SAN configuration.
0 Likes
Absent Member.. Absent Member..
Absent Member..

That's my thinking too, but I have no other performace issue that I know of at this point. You would think that if it were an infrastructure issue we would of noticed performance issues prior to installing Data Protector.

Additional information for above.
The drive(LUN) is 1TB of disk space with 52% free space.
We did run the LTT utility to measure the tape drive throughput and disk read throughput. We got 35.9 thru 71.4 MB/sec on the LTO4 taoe drive and 79 MB/sec from the disk drive we are backing up.
0 Likes
Absent Member.. Absent Member..
Absent Member..

Surprise!!!

To all us novices with "Green Support" hardware and operating systems, TURN IT OFF!!! Well you could try varying a few settings to see which one exactly affects your situation.

I turned off mine in the operating system and my peformance shot up (12 hour backup went down to 3 hours!). It was slowing down the PCIe bus on me because Data Protector was not pushing the server hard enough. That explains why running defrag at the same time as my backup would actually increase my throughput on my backup.
0 Likes
Absent Member.. Absent Member..
Absent Member..

See above entry for the solution.
0 Likes
Absent Member.
Absent Member.

Hi I'm having the same issue..

What do you mean by "Green Support"?
What is this setting that we should check?

Thanks in advance!
FLY
0 Likes
Absent Member.. Absent Member..
Absent Member..

Set power settings to performance to avoid any power reduction of the hardware. It's in Control Panel, System and Security, Power Options.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.