Jason Antes [2]
New Member.
8047 views

Data Protector 6.2 - Taking VSS without VSS being enabled

I am having a slight issue with some certain clustered servers that have SQL installed on them.  I have the DA and MA installed on the clients but no VSS integration component.  I also do not have it set in the options to use Volume Shadow Copy but I still get the following:

 

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS Writer 'System Writer':Component 'System Files' successfully added in the snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS Writer 'ASR Writer':Component 'BCD' successfully added in the snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS Writer 'Registry Writer':Component 'Registry' successfully added in the snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS Writer 'COM+ REGDB Writer':Component 'COM+ REGDB' successfully added in the snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS Writer 'IIS Config Writer':Component 'IISCONFIG' successfully added in the snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS Writer 'WMI Writer':Component 'WMI' successfully added in the snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS Writer 'Cluster Database':Component 'Cluster Database' successfully added in the snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:10 PM
    VSS option was specified. Attempting to create snapshot.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:58:35 PM
    Clearing archive flags is not applicable with Volume Shadow Copy backup.

[Normal] From: VBDA@server.net "C:"  Time: 9/11/2011 8:59:02 PM
    Clearing archive flags is not applicable with Volume Shadow Copy backup

 

---------------------

 

When it gets to the drives with SQL installed it's causing an issue with the databases being locked for a few seconds as the VSS writers run through it.  Not all the servers in the same backup job exhibit this issue, only my SQL and Exchange servers.  This is a generic Configuration, C:, D:, E: style backup job.  The actual SQL and Exchange backups are handled by separate jobs.

0 Likes
10 Replies
Micro Focus Expert
Micro Focus Expert

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hi Jason,

 

So this only happens on clustered servers?  I wonder if this is normal DP behaviour in a MS cluster, maybe something to do with backing the quorum?  Just thinking out loud really.

 

As far as VSS goes, the Disk Agent has basic VSS integration built-in for filesystem backup.  The VSS Integration Agent is for higher levels of VSS integration such as application and/or hardware provider integration.

Blueskies from down-under...
0 Likes
Absent Member.. JasonAntes Absent Member..
Absent Member..

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Sorry, I haven't been back to this in a while.  This is still an occuring issue. 

 

-I don't have the DP job set to use Volume Shadow Copy for the filesystem backup.  It is not checked.

-I get this issue with many different backup jobs, but it is especially a problem with SQL clusters.

 

I don't want it using VSS at all, not even a little bit.  It's not enabled on many of our servers.  While this issue causes no issues on my file servers, it is causing a lot of problems for my SQL servers.

 

The problem with the below is that the VSS option was not specified in the backup, ever.

-----------------

[Normal] From: VBDA@fxxx.net "fxxx.net [/G]"  Time: 2/13/2012 12:10:29 AM
    VSS option was specified. Attempting to create snapshot.

[Normal] From: VBDA@fxxx.net "fxxx.net [/G]"  Time: 2/13/2012 12:10:57 AM
    Clearing archive flags is not applicable with Volume Shadow Copy backup.

0 Likes
Jenni_S Outstanding Contributor.
Outstanding Contributor.

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hi Jason,

 

Did you check your backup object summary tab object properties? It is also possible to set the VSS option there and it certainly looks like it has been set from the session messages.

 

Maybe post one of the backup jobs in txt so we can check it out?

regards,
jenni

--------------------------------------------------------------------------------
If my post was useful, please click on KUDOS!
0 Likes
Highlighted
Absent Member.. Hell_Screen Absent Member..
Absent Member..

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hi,

I have the exact same problem as Jason.

I have no ententions to backup with VSS onle raw file backup.

Diska gent and the media agent is the only one installed on out SQL server.

I have attached a picture that shows that i have not specified a VSS option at the backup job i have created.

This is info from the backup job:

[Normal] From: VBDA@kreddb10-clu2.wxxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:18:27
 STARTING Disk Agent for kreddb10-clu2.xxxxxx.se:/I "I: [KREDDB11_DATA]".

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:18:28
 VSS option was specified. Attempting to create snapshot.

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:18:28
 Entering snapshot definition phase.

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:18:28
 Volume 'I:\' successfully added to snapshot set. The volume is now locked.

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:18:28
 Exiting snapshot definition phase.

[Normal] From: VBDA@kreddb10-clu2.wxxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:18:29
 Creation of snapshot volume for I:\ succeeded. Proceeding with backup.

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:18:29
 Clearing archive flags is not applicable with Volume Shadow Copy backup.

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:19:46
 Backup Profile:

  Run Time ........... 0:01:17
  Backup Speed ....... 0,09 MB/s

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:19:46
 Filesystem Statistics:

  Directories ........         0
  Regular files ......         1
  ------------------------------
  Objects Total ......         1
  Total Size .........   7,25 MB

[Normal] From: VBDA@kreddb10-clu2.xxxxxx.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:19:46
 Backup completed. Disconnecting from Volume Shadow Copy Service.

[Normal] From: VBDA@kreddb10-clu2.xxxxxxt.se "I: [KREDDB11_DATA]"  Time: 2012-07-26 09:19:46
 Volume Shadow Copy successfully disconnected. Releasing the volume.


 

Anybody know how to disable this ???

Regards
Heino

Best Regards
Heino

Please assign Kudos - How to assign...
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hello

 

Please add following variable to omnirc file into affected clients.

 

OB2_ENABLE_VSS_WRITERS=0

Absent Member.. Hell_Screen Absent Member..
Absent Member..

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hi

I have change the omnirc file located:
Client:  C:\Program Files\OmniBack\omnirc
Cell server: C:\Program Files\OmniBack\omnirc

#===========================================================================
# Variables for a Disk Agent client
#===========================================================================
#  OB2_ENABLE_VSS_WRITERS=0|1

OB2_ENABLE_VSS_WRITERS=0


After editing the files i did omnisv stop  omnisv start om the cellmanager. On the client i did stop, start the Data protector Inet service.

Still getting the same error.

Do i do i wrong ?

Best Regards
Heino

Please assign Kudos - How to assign...
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hello

 

You did it rigth, so as I as can see for Windos 7 and Windows 2008 VSS is selected by default.

 

With DP 6.2 the default behavior has been changed. Backup specifications for Windows Vista, 7, and Server 2008 clients will have the filesystem VSS option selected by default.

This is documented in the DP 6.2 online help

Option: Use Shadow Copy
Select this option if you want to perform a point-in-time backup using Microsoft Volume Shadow Copy Service (VSS). VSS allows you to create shadow copy backups of volumes, exact point-in-time copies of files, including all open files. This means that the VSS mechanism finishes all pending I/O operations and holds incoming write requests during the preparation of a shadow copy volume. In this way all files on the filesystem level are closed and unlocked during the shadow copy creation.

On Windows Vista, Windows 7, and Windows Server 2008 systems, if an entire volume is selected for backup and this option is selected for the volume, Data Protector additionally ensures that data of each Windows server role or third-party application which stores its data on the volume is made consistent before being backed up, provided that a corresponding VSS writer is available. The same behavior applies when an entire client system is selected for filesystem backup.

This option is selected by default on Windows Vista, Windows 7, and Windows Server 2008.

On non-Windows systems, this option is ignored.

Caution
When configuring a backup specification for a Windows Vista, Windows 7, or Windows Server 2008 system for disaster recovery purposes, this option must be selected, otherwise the backup data may not be usable for disaster recovery.

This online help can be seen by pressing the F1 key while the "Win FS Options" windows is open

0 Likes
Absent Member.. Hell_Screen Absent Member..
Absent Member..

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hi,

This means that it can't be disabled ?

Best Regards
Heino

Please assign Kudos - How to assign...
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

Hi

 

You are rigth, at least from point of view.

0 Likes
JohnEllis Absent Member.
Absent Member.

Re: Data Protector 6.2 - Taking VSS without VSS being enabled

The Filesystem Options-Advanced button under the Option tab has a WinFS Options tabs with what appears to the the settings for using Shadow Copy.  I my experience, this doesn't work.  You need to go to the Backup Options Summary tab.  highlight an object and select the WinFS tab there.  You will see the Use Shadow Copy has been checked by default.  You will need to uncheck it for each object.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.