Rejaine_SM Regular Contributor.
Regular Contributor.
588 views

DataProtector VEPA (backup job removing disk from vcenter)

Jump to solution

Hello people,
 
I need help with DataProtector with integration with VMWARE (VEPA)
 

I'm using DataProtector 8.00, a ESXi 5.5 cluster with 2 physical servers and 3Par datastore with FC disks.


I was studying a way to improve the performance of VM backups because backups were failing very often, leaving large snaphots and consequently degrading overall system performance, etc.  Then I found some interesting recommendations in this article:

  https://support.hpe.com/hpsc/doc/public/display?docId=c04318203

So, I followed the instructions in the article to use CBT., removed all snapshots from the virtual machines and enabled via PowerCLI the CBT on all virtual machines (I used theise PowerCLI scripts/commands to make the changes without turning off the machines:  https://www.veeam.com/kb1940) Then I also configured the DataProtector to activate the CBT (from HP article instructions)

But after activating CBT,  some jobs the DataProtector are 'removing' Disk 0 from VCenter, causing a reboot of VCenter. In the .vmx file, the disk configuration "scsi0: 0.present" is equal to "FALSE".  I shutdown vcenter, change back to TRUE, and everything goes back to normal, until the next backup job removes the disk again.

This happens after some backup jobs create the snapshot of the virtual machines and start copying the data ... But it does not happen with all jobs , but all jobs are configured in the same way with the use of CBT and are triggered using the same DataProtector and using the same VCenter as backup agent.

In the face of these problems, I decided to remove all the CBT settingsin DataProtector and VM's (to disable the CTB in the VMs I used same  the PowerCLI scripts/commands from: https://www.veeam.com/kb1940)

Finally, I do not currently have any VMs with CBT enabled (confirmed via PowerCLI script from Veeam article), no DataProtector backup job is over with CTB enabled (all are with Snapshot Handlin=Disable and Enable changed block tracking disabled) and even then the problem with Vcenter losing disk persists.

I do not know where else to look for the error and I have been working with a problem to backup multiple virtual machines since last week ..

 I've already tried changing the Vcenter from the physical host, but it did not resolve the issue. I think it is related to the use of CBT this problem happened to occur when I started to use it, but already already disabled the problem still persists ...

Thanks any help and sorry for any mistakes. (english is not my native language and I'm using google translator)

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: DataProtector VEPA (backup job removing disk from vcenter)

Jump to solution

Hello

You are using unsupported and very old DP version, I kindly offer to you two topics.

1º Upgrade your DP at least to version 9, 9.09_116 exactly

2º Use a different server as backup host, is not recommend to use Vcenter server as backup host.

If you still has the same issue after that please open a support case and collect debugs reproducing issue for further troubleshoot.

 

Best Regards

4 Replies
Micro Focus Expert
Micro Focus Expert

Re: DataProtector VEPA (backup job removing disk from vcenter)

Jump to solution

Hi @Rejaine_SM,

Thanks for all the details.

In the document that you add, suggest to add some variables. 

This one OB2_VEAGENT_DISABLE_CBT_VALIDATION=1 could cause the problem. Try to remove it and monitor. 

Regards, 

 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Rejaine_SM Regular Contributor.
Regular Contributor.

Re: DataProtector VEPA (backup job removing disk from vcenter)

Jump to solution

 

 Yes, I already removed this configuration from omnirc and restarted the DataProtector server, but it did not resolve.

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: DataProtector VEPA (backup job removing disk from vcenter)

Jump to solution

Hello

You are using unsupported and very old DP version, I kindly offer to you two topics.

1º Upgrade your DP at least to version 9, 9.09_116 exactly

2º Use a different server as backup host, is not recommend to use Vcenter server as backup host.

If you still has the same issue after that please open a support case and collect debugs reproducing issue for further troubleshoot.

 

Best Regards

Rejaine_SM Regular Contributor.
Regular Contributor.

Re: DataProtector VEPA (backup job removing disk from vcenter)

Jump to solution

Hello, JBasilio.

Yes the problem was exactly that, after I changed the backup host to another server, the problem did not occur any more ...
Thanks for the tips (we will also update the DataProtector and VCenter version soon)

Solved, thank you

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.