Samy_4 Absent Member.
Absent Member.
882 views

Disabling native windows driver for MSL5060

Jump to solution
Hi all,
I have the following config for DP 5.5:
Cell server : Windows 2003 with SP1
Client : HP-UX (DP Media agent + DP Disk agent)
SAN environnement, MSL 5060 with 2 LTO drives
When I start SAN backup on a HPUX server, tape is loaded correctly into the correct device, and the backup is done, but for the unload, I got an I/O error and the tape is blocked in the drive. I've patched the system and the DP but still got the same problem. Someone said that I have to disable the windows native driver for the medium changer and the two drive. So, DP will use its own drivers. It is exlained in the Installation and Licensing Guide : Appendix B : Using Tape and Robotics Drivers on Windows. The problem is how to create the SCSI files on a Windows system. I've followed the guide and didn't get a result : when the scsi adress is modified from changer0:0:0:0 to scsi3:0:0:0 or from tape 0:0:0:1 to scsi0:0:0:1 (the media agent installed on the client recognize new adresses), the robot seems to be not respending for any DP request : backup, scan, format, ....
How can I create the filename device after disabling the native driver ?? should I re-install DP or just modify the scsi adresses ??
0 Likes
1 Solution

Accepted Solutions
Kurt Beyers. Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Samy,

I'm sorry to diasgree but the driver for the medium changer MUST be disabled. This is not an option, but mandatory.

On the HPUX server, only the drive must be defined. The robot arm is only controlled by one server, in your case the cell manager.

Do you use logical devices or multipath devices for the library setup?

What is the outbut of 'devbra -dev'?

best regards,
Kurt
0 Likes
12 Replies
Kurt Beyers. Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Samy,

After disabling the native driver, the hardware adresses just must be changed from changerx:x:x:x to scsix:x:x:x. Nothing more must be done.

Make sure that the Removable Storage Service of Windows is disabled too.

best regards,
Kurt
0 Likes
Samy_4 Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Removable Storage Service of Windows is disabled. How can I check in the windows system that adresses have changed ?? and why the robot is not responding to any request ?? In the debug file I got an SCSI error. I will send it later
0 Likes
Georges Esteves Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Samy,

when the changer have no driver, it is reported as "unknow medium changer" under the hardware devices list.

you should remove the tape and changer drivers (remove the HP tapes and MSL .inf files from the inf directory), then reboot your server

once reboot check under hardware devices list , that tapes and medium changer have no driver loaded

if all is ok, reconfigure the MSL and drives under DP , with the devices like scsi#:#:#:#


Hope It help.
0 Likes
Kurt Beyers. Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Samy,

First things first, check your SCSI connections.

Then run a new autoconfigure of the library and compare the hardware paths found in there with your original definition. There will be a mismatch.

I wouldn't uninstall the Windows device drivers because you get then after every reboot the 'Found new hardware' popup. Disabling them is enough.

best regards,
Kurt
0 Likes
Samy_4 Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Well
After disabling the exchanger and the two LTO drives, when I make an autoconfig device with DP, DP recognize the LTO drives and I can check them but it didn't recognize the exchanger : I got the scsi adresse (scsi3:0:0:0) but there's no check box to define it !!!!! What's wrong with that. I tried it many times but still got the same pbm
Thanx
0 Likes
Jorge_43 Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Hi Samy, I had the same problem,you have to enable the autochanger under device manager of windows, you only must desable the tapes.

lucky...
Jorge
0 Likes
Samy_4 Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
OK I think that it will works with that but in the DP documentation, they said that you have to disable the medium changer !!!!!
I will try it and see the result
Thanx
0 Likes
Kurt Beyers. Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Samy,

I'm sorry to diasgree but the driver for the medium changer MUST be disabled. This is not an option, but mandatory.

On the HPUX server, only the drive must be defined. The robot arm is only controlled by one server, in your case the cell manager.

Do you use logical devices or multipath devices for the library setup?

What is the outbut of 'devbra -dev'?

best regards,
Kurt
0 Likes
Samy_4 Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
I'm using logical devices and no multipath for devices. So each client has its own adresses.
The medium changer is defined for only the cell server on DP but all its natives drivers (hp-ux and windows) are up for all client. So have I to disable all natives drivers for clients and cell server ?? If I disable it on the cell server, I got the problem I discribe below.
I think that I will disable the medium changer on all clients (hp-ux and windows) and let it for the cell server. And I will disable drives for only the cell server. So, DP will use its own driver for the two LTO drives
For 'devbra -dev', I have to execute it where ??? on the cell or on hp-ux client ???
Thanx
0 Likes
Highlighted
Kurt Beyers. Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Samy,

The robot arm must only be defined in DP on the cell manager, here the windows medium changer must be disabled.

On Windows clients that see the library through the SAN, disable the Windows tape driver too. Only the logical drive must be defined in DP.

On HPUX clients that see the library through the SAN, just define a logical drive in DP. The drive path is here /dev/rmt/?mn, the stape driver is used and must be added to the kernel of course.

Make also sure that for each logical drive that corresponds to the same physical drive, a lock name is used for it on every client that sees the drive through the SAN.

That is how a library in a SAN must be setup.

best regards,
Kurt

ps. Have also a look at http://forums1.itrc.hp.com/service/forums/pageList.do?userId=CA1248875&listType=unassigned&forumId=1 . Just closing a thread isn't quit polite either.
Samy_4 Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Thanx Kurt
But as I said, when I disable the windows native driver for the cell, and make an autoconfig, I didn't get the check box for the medium changer on the cell server !!!!

PS :Sorry but I didn't understand what you mean about http://forums1.itrc.hp.com/service/forums/pageList.do?userId=CA1248875&listType=unassigned&forumId=1
I've closed the thread thoughting that the RSM windows service was the problem but I was wrong. Sorry for that
0 Likes
Samy_4 Absent Member.
Absent Member.

Re: Disabling native windows driver for MSL5060

Jump to solution
Finally, and as Kurt said, I've disabled the medium changer windows native driver for all windows clients that see the library in the SAN. Everythind is going well
Thx
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.