Highlighted
Lieutenant Commander
Lieutenant Commander
2453 views

Exchange Server 2016 backup "Unable to browse instance 12:8102"

Hi Experts

I am using Data Protector A.10.00 and after integarating MS Exchange Server when I try to take backup of Exchange Server 2016 on windows server 2012 using Data protector GUI  and select client then try to select application database it prompt a message " Unable to browse instance 12:8102 ".  Check the attached screen shot. Please help to solved this issue.

Thanks in advance

0 Likes
22 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello

Please be sure that you are using account with necessary rights

Configuring user accounts
Windows domain user account for backup and restore sessions
Backup and restore sessions are started by the Data Protector Inet service, which by default runs
under the Windows local user account
SYSTEM. Consequently, a backup or restore session is
performed using the same user account.
However, you can specify that the
Data Protector Inet service should use a different Windows
domain user account to start a session:
l To perform a backup session under a different user account, specify the Specify OS user option
(see
"Specifying view type" on page 272) when creating a backup specification.
l To perform a restore session under a different user account, specify the User name and
Group/Domain name options in the Options page (see "Restore options" on page 294).
Before you specify a different Windows domain user account, configure the user account as follows:
1. Grant the user appropriate permissions to back up and restore Microsoft Exchange Server
databases.

2. Add the user to the Data Protector admin or operator user group. For details on adding users, see
the
HPE Data Protector Help index: ”adding users”.
3. Save the user and its password to a Windows Registry on the Microsoft Exchange Server system
on which you plan to start the integration agent (
e2010_bar.exe). To save the user account, use
the Data Protector
omniinetpasswd or omnicc command.
Note: The user account saved in the Windows Registry will be used by the Data Protector
Inet
service when needed.
For details on setting accounts for the Inet service user impersonation, see the
HPE Data
Protector Help
index: “Inet user impersonation”.
Example
To save the user jane from the domain HPE and with the password mysecret to a Windows
Registry, log on to the Microsoft Exchange Server system and execute the following command:
omniinetpasswd –add jane@HPE mysecret

 

Best Regards

 

0 Likes
Highlighted
Lieutenant Commander
Lieutenant Commander

Hi JBasilio

Thanks for reply

I am using Administrator account with full permission to take backup not other user account. I am using Data protector A.10.00  on Windows Server 2012 R2  to take backup Exchange Server 2016 (CU9).

 

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello

Please run this command into exchange server

"e2010_bar.exe -browse -debug 1-500 dbg.txt"

Upload commnand output and files created into c:\program data\omniback\tmp

Best Regards

0 Likes
Highlighted
Lieutenant Commander
Lieutenant Commander

Hi JBasilio

I have run this command "e2010_bar.exe -browse -debug 1-500 dbg.txt"

But there is no command output. No file created at the location c:\program data\omniback\tmp

There are some precreated files. See the attach file.

Thanks

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello

Please open a support call for be able to help you with further troubleshoot.

Best Regards

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello @Anuj,

Please check the c:\program data\omniback\tmp directory on the Exchange Server where you have executed the command in debug mode.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Highlighted
Lieutenant Commander
Lieutenant Commander

Hi Koehler

Thanks for reply

I have checked the c:\program data\omniback\tmp directory on the Exchange Server but there is no file other than "CRS.pid"

I am using Exchange Management Shell to run the command. I want to know also how run command in debug mode. Please check the attached screen shot.

How can I solve this issue so I could take the Exchange server 2016 backup using Data protector A.10.00 ?

Thanks

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi @Anuj,

CRS.pid is a trace of the Cell Manager. Does this mean you have installed the Cell Manager on the Exchange Server? This does not look right. On the Exchange System you will need at least the Disk Agent, Exchange 2010+ and the Volume Shadow Integration. Also install the old .NET Framework accroding to the prerequesites.

2018-05-15_15h02_19.png

Running the command from an elevated command prompt or Powershell works well on my system.

2018-05-15_15h01_15.png

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Highlighted
Lieutenant Commander
Lieutenant Commander

Hi Koehler

Thanks for reply

I have Installed the Cell Manager on the Exchange Server 2016 on Windows Server 2012 R2 with following components :

ClientComponent.jpgand also try to run the command on Windows Powershell but no output.

PowerShell.jpg

 and no dbg.txt file created at location : 'C:\ProgramData\OmniBack\tmp"

tmpFolderFiles.jpg

Try again to take Exchange Server Backup but prompt same error message :

ErrorMessage.jpg

No able to understand where is the problem.

Please request to solve this issue.

Thanks

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello @Anuj,

Is this Exchange Server the only client you want to backup with Data Protector? If not, then you should better install the Cell Manager on a external backup server and just use the Data Protector client on the Exchange host.

Since this seems to be a fresh instalation I would recommend using Data Protector A.10.03 to make sure we do not face any possible bugs that have been fixed in the meantime. I don't understand why no debug files are created, but most likely the agent is just crashing. So please use the latest version and let us know if it works.

You can try to emable the Specify OS user checkbox and enter the name of a administrative user and group having rights to backup Exchange (below the error in your screenshot).

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Highlighted
Lieutenant Commander
Lieutenant Commander

Thanks for Reply

I have reinstalled  the Data Protector A.10.03 and try to take backup of Exchange server 2016. But faching the same problem.

HPE103.jpg

SameError.jpg

9.jpg

Not able to under stand the problem.

While I try to take backup on Exchange Server 2007, Data protector automatic display the application database as I select the client.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.