Community in read only mode June 18 & 19
This community will be set in READ ONLY mode for a while on Tuesday June 18 into Wednesday June 19 while we import content and users from our Micro Focus Forums community site. MORE INFORMATION
Trusted Contributor.. quiz Trusted Contributor..
Trusted Contributor..
1306 views

HP DP 9.08 - problem to start hpdp-as

Hi all,

it's not possible to start hpdp-as service. It ends with error

Cannot start "hpdp-as" service, system error:
[1053] Unknown error 1053

I found that it's problem of jboss - see next error

ERROR [org.jboss.msc.service.fail] (MSC service thread 1-23) MSC00001: Failed to start service jboss.web.connector.https: org.jboss.msc.service.StartException in service jboss.web.connector.https: JBAS018007: Error starting web connector
Caused by: LifecycleException:  Protocol handler initialization failed: java.iIo.FileNotFoundException: /etc/opt/omni/server/certificates/server/server.keystore (Permission denied)

I tried to change permission of server.keystore but it didn't help. Do you have any idea where is the problem?

OS - RH 7.x

Thanks a lot

0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Re: HP DP 9.08 - problem to start hpdp-as

Hello quiz, 

This could be possible that some war files was not deployed. 

Follow these steps: 

  1. Go to the run.log (/var/opt/omni/log/AppServer/) and check if some .war shows error like "remove/reinstall". 
  2. Go to /opt/omni/AppServer/bin/ and run: standalone.bat --admin-only 
  3. Then open another connection and run this in the same path and run this: jboss-cli.bat 
  4. Then connect. 
  5. And start to make the redeploy of the war. 

deploy "c:\program files\omniback\bin\dp-scgui.ear" --force 
deploy "c:\program files\omniback\bin\DPOptionsEditor.war" --force 
deploy "c:\program files\omniback\bin\components\dp-gui.war" --force 
deploy "c:\program files\omniback\bin\components\dp-jobexecutionengine-backup.war" --force 
deploy "c:\program files\omniback\bin\components\dp-jobexecutionengine-consolidation.war" --force 
deploy "c:\program files\omniback\bin\components\dp-webservice-server.war" --force 
deploy "c:\program files\omniback\bin\components\jce-dispatcher.war" --force 
deploy "c:\program files\omniback\bin\components\jce-serviceregistry.war" –force 

6. Stop and start services. AS should start. 

7. Regenerate certificates and restart the services again. 

Go to /etc/opt/omni/client/components/ and search the files (ls). Open the webservice.properties (cat webservice.properties). Copy the keystorePassword.

Run this command:

/opt/omni/bin/perl /opt/omni/sbin/./omnigencert.pl -server_id FQDN -server_san ip:ip_address -user_id hpdp -store_password keystorePassword

Then restart the services (omnisv -stop; omnisv -start)

Hope this works,

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.