naranjomastin1
New Member.
152 views

Hana sessions finish and hang

Hello, 

Both Cell Manager (Windows 2012) and clients run DP 9.09. Some SAP Hana database instances run on several linux clients, however even though the incremental backups may take 2 minutes to complete, in the Data Protector Monitor tab, the incremental backup session may be displayed as active even from 2 days ago (actually, it seems as if no Hana sessions had run today).

In addition, these Hana backup sessions are the only type of backups which record the "IPC cannot allocate shared memory segment":

[Critical] From: BMA@ "HP:Ultrium 6-SCSI_2_" Time: 24/07/2019 08:40:04 p. m.
IPC Cannot Allocate Shared Memory Segment

[Critical] From: OB2BAR_SAPHANA_BACKINT@ server1.com "HRD" Time: 24/07/2019 08:41:58 p. m.
[80:1031] Received ABORT request from NET => aborting.

[Critical] From: BMA@ "HP:Ultrium 6-SCSI_2_" Time: 24/07/2019 08:45:10 p. m.

[90:23] IPC failure reading NETIO message (IPC Read Error
System error: [10053] The software caused the abort conexion.
) => aborting

Even though the following values are assigned to these variables in the omnirc file for both the Cell Manager and linux clients:

OB2SHMIPC=0
OB2INETTIMEOUT=60
OB2IPCKEEPALIVE=1
OB2IPCKEEPALIVETIME=900
OB2IPCKEEPALIVEINTERVAL=60
OB2IPCLINGER = 1
OB2SHMEM_IPCGLOBAL= 1

Regards, 

 

0 Likes
4 Replies
Knowledge Partner
Knowledge Partner

Re: Hana sessions finish and hang

Hello @naranjomastin1,

Try to kill all hanging BSM processes on the Cell Manager. This should also terminate processes on the clients. On the HANA server kill any process (look for omni in ps -faxuw) stuck and try again.

If this does not help look at the SHMMAX value and increase it.

I guess the omnirc options on the HANA server has been added as part of troubleshooting? Since they are not helping removing them and restarting xinetd would be good.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
naranjomastin1
New Member.

Re: Hana sessions finish and hang

Thanks for your suggestion Sebastian. 

I killed the running BSM processes on the Cell Manager, however it did not go through because some new Hana sessions run but seems they never end (as shown in the Monitor tab), so the only way to get rid of those sessions is by killing the BSM process in the Device Manager. 

I also tried to increase the value for the SHMMAX variable, but this variable is not either recorded in the Cell Manager nor in the clients.  

Any other suggestion ?

Regards, 

 

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Hana sessions finish and hang

Hi @naranjomastin1,

SHMMAX is an operating system tuneable (sysctl). Check the SLES/Redhat documentation on changing that.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
nikhil_d Honored Contributor.
Honored Contributor.

Re: Hana sessions finish and hang

First put omnisv in maintenance mode, then kill BSM processes, that way no new sessions start while you are killing the old processes. After killing old BSM, make sure to run omnidbutil -clear and omnidbutil -free_cell_resources. When no backups are running, also use free_locked_devs. That way you start from a lean slate....now turn the maintenance mode off by running omnisv -maintenance stop and you should be good.

Reg IPC omnirc variables, I also have OB2IPCNOSENDRECVLOOP=1 in some environments.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.