ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins. Read more for important details.
ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins.Read more for important details.
Captain Captain
Captain
1732 views

Issue with Backup Schedule after migration from 9.08 to 10.20

Jump to solution

Hi,

We have recently migrated DP 9.08 to 10.20, After migration backup schedule giving error ("Details unknown."
 error occurred in expression:  -full -exclude -day Sun Mon Tue Wed Thu Sat -at 06:00").

In our environment almost all the backup schedule are configured as : Full Backup on specific day/month and exlude other day.

Kindly advise, as practically it would be difficult to re-configure all the backup schedules.

 

Thanks

Murtaza

0 Likes
1 Solution

Accepted Solutions
Captain Captain
Captain

Hi,

Thanks to Support team for resolving the issue on high priority.

it was resolved by following below steps (attached fix).

1) Take an offline copy of program files\omniback\bin and Programdata\omniback\config\server directory (This is important since we could rollback if there are any issues)

 2) Browse to x8664\A.10.20\CC\DP_HOME_DIR\bin  from the fix and then copy all the contents to program files\omniback\bin on the server (You can overwrite the existing files)

 3) Browse to x8664\A.10.20\CS\DP_HOME_DIR\bin  from the fix and then copy all the contents to program files\omniback\bin on the server (You can overwrite the existing files)

Regards

Murtuza

 

View solution in original post

13 Replies
Micro Focus Expert
Micro Focus Expert

Hello @MurtuzaS

The problem with this schedule is that have the option -exclude but does not indicate the day you want to exclude. 

I test your schedule in my environment. If I keep this format: 

-full
-day Sun Mon Tue Wed Thu Sat
-at 06:00

The backup was schedule like this: 
image.png

 

I I try to exclude one day (January 1st), the schedule format changes like this: 

-full
-every
-day Sun Mon Tue Wed Thu Sat
-at 06:00

-full
-exclude
-day 1 -month Jan -year 2019
-at --:--

I don't understand yet if you want to run it all the day except Friday, or only Friday and want to exclude all the other days. Please explain me and I can help you to modify the schedule correctly. 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Captain Captain
Captain

Dear Andres,

Our scenario is something like below

Example 1. (FileSystem):

1. Incremental backup should be running everyday except 3rd Friday,

2. On 3rd Friday only Full backup should be running instead of incremental

3. On 3rd Friday of December Full backup should be running with retention Permanent instead of retention of 52 Weeks.

Example 2. (MSSql)

1. Incremental backup should be running everyday

2. On every Friday/saturday full backup should be running with retention 5 weeks

3. On 4 Friday  of everymonth full backup should be running with retention 52 weeks instead of retention 5 weeks

4. on 4 Friday of Dec Full backup should be running with retention permanent instead of 52 weeks.

Since you have tested our environment so i am not attaching any schedule.

let me know if you need any further details.

 

Regards

Murtuza

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Hello @MurtuzaS

I configured your specifications like this: 

  1. For Filesystem requirements: 
    • I configure the backup incremental to every day. 
    • Manually delete the job the 3rd Friday every month. And configure the full. (I was not able to configure it to run the 3rd Friday. I tried configuring it weekly every 4 weeks, but if a month have 5 Fridays will change the date of the next backup. So I recommend to configure it manually.)
    • Attached is the result of the script configured. 
  2. For MSSQL requirements: 
    • Configure the incremental to run every day. 
    • Happened the same as before, if a month has more than 4 Fridays the schedule every 4 weeks is not correct. I recommend this should be done manually. 
    • The script attached too. 

In conclusion, Incrementals is easy to configure. But fulls in a specific day of a month is not easy and should be done manually. If you want to run it on a specific date should be easier. 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Captain Captain
Captain

Hi Andres,

Reason being day is selected is, Full backup should'nt be running during working hours, specially for critical application, as it can impact the applications performance.

Moreover whenever there is monthly backup job, that day incr/trans backup shouldnt be running, that's why exclusion are defined.

There are many backup jobs so doing manually every month is not an option.

Seems like "-exclude -day Sun Mon etc " is not working in DP 10.2, So i believe MicroFocus to provide any hotfix/patch to resolve the issue.

Regards

Murtuza

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Hello @MurtuzaS

Software is working as design at this moment. This will be a good enhancement. My suggestion here is to add it on the Idea Exchange forum to be considered in future releases. 

https://community.softwaregrp.com/t5/Data-Protection-Idea-Exchange/idb-p/DP_Ideas 

Regards, 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Captain Captain
Captain

Hi Andres,

I have posted the Idea on the Idea Exchange Portal.

Kindly "Like" and share the idea to your colleague, so that it can be included in next hotfix/patch.

Regards

Murtuza 

0 Likes
Micro Focus Expert
Micro Focus Expert

Hello, 

I saw the answer on the Idea. Feel free to open a support ticket explaining the issue and we can work on it. Refer to Idea link and this forum too. 

If you open the support ticket please send me the ID too to follow up. 

Regards,

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Captain Captain
Captain

Dear Andres,

Support ticket is already raised ( SD02368368  ). Kindly do the needful.

 Regards

Murtuza

Micro Focus Expert
Micro Focus Expert

Hello, 

Case is being worked with the highest support level and lab. Please let us know when a solution is provided. 

Regards, 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Captain Captain
Captain

Hi,

Thanks to Support team for resolving the issue on high priority.

it was resolved by following below steps (attached fix).

1) Take an offline copy of program files\omniback\bin and Programdata\omniback\config\server directory (This is important since we could rollback if there are any issues)

 2) Browse to x8664\A.10.20\CC\DP_HOME_DIR\bin  from the fix and then copy all the contents to program files\omniback\bin on the server (You can overwrite the existing files)

 3) Browse to x8664\A.10.20\CS\DP_HOME_DIR\bin  from the fix and then copy all the contents to program files\omniback\bin on the server (You can overwrite the existing files)

Regards

Murtuza

 

View solution in original post

Micro Focus Expert
Micro Focus Expert

Hello @MurtuzaS

Thanks for sharing with us the solution. I am really glad to know that works. 

Looking on the case the hotfix is this: 

https://softwaresupport.softwaregrp.com/doc/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR2A82175

In case that someone needs the fix is better to request it to support team. 

Best regards, 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.