Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class
704 views

Media Report incorrect

I have created a weekly report that lists all media from all pools.  However it is incomplete.  Any media that is not used does not appear in the report.

 

An example; I purchased new tapes, inserted them, formatted and added them to a media pool.  They show up in the Tape Library and in the media pools, but they do not show up in the weekly report that lists of ALL media.

 

If Data Protector happens to use the new tape in a backup job, then it will show up in the weekly report.

 

Can someone please explain what filter is applied that omits it from my report, as far as I can see I am including everything and haven't got any filters applied.

 

0 Likes
7 Replies
Micro Focus Expert
Micro Focus Expert

Most likely the report will only display "protected" media. Review your report and/or create a new one that matches your requirements.

Regards,
Sebastian
---
Please use the Like button below, if you find this post useful.
Tags (2)
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Here is a copy of the report below, taken straight from the Weekly reports file.  As you can see there are no protection filters in there.  Just to be certain I looked at the media pools and the tapes that don't show in the report show up in the media pools with a protection of "none".

 

I think this might be a bug with Data Protector.

 

 

NAME "Weekly Reports"
{
    REPORT "List of ALL LTO Media"
    {
        ID "media_list_extended"
        HEADER
        USEDL 1
        USECPL 1
        USECNL 1
        USEVERL 0
        POOL
            "Daily Backup Tapes"
            "Default LTO-Ultrium"
            "Monthly Backup Tapes"
            "Permanent Archive"
            "Retired Media"
            "Weekly Backup Tapes"
        CLASS "LTO-Ultrium"
        SMTP
        {
            TYPE HTML
            TO
                mailgroup@somewhere.com

        }
    }
}

 

It seems that the media will only show up in the reports once they have had data written to them.

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Which Data Protector version are you running? Please provide omnicheck -patches from CS to see what patches are applied.

Regards,
Sebastian
---
Please use the Like button below, if you find this post useful.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

The version we are running is;

 

A.06.20  internal build 370

 

No patches found

 

 

0 Likes
Admiral Admiral
Admiral

Hi Craig,

 

There have been a number of patches released for DP6.2 most notably version B6.21 - you need to apply patches to ensure that you receive all the fixes.

 

http://support.openview.hp.com/selfsolve/patches

 

Login with your HP Passport (you must link your HP DP SAID to this account) and then select your version, Installation Server OS and download the patches and install on your Installation Server.

 

Then see if you still have the same issue 🙂

regards,
jenni

--------------------------------------------------------------------------------
If my post was useful, please click on KUDOS!
0 Likes
Micro Focus Expert
Micro Focus Expert

I just did a test with List of media report on 6.21. It does report all media in specific pool(s) with and without protection as well as new media.

 

Regards,

Sebastian

---
Please use the Like button below, if you find this post useful.
0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Once I have patched Data Protector, I will test the report and post results here.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.