phil foster Absent Member.
Absent Member.
192 views

OB 3.1 remote unix client install

while attempting to perform the remote install of
omniback 3.10 to a unix machine, it prompts me
for root login. Then it does not take the root password
in the install GUI.
I checked and moved the /etc/securettys so it wasn't
seeing that as root not being allowed remote login access.
(and then tested by being able to login via telnet as root)

How do I perform this? and if I can't perform
the remote install this way (it works for NT just dandy)
Where does the client software reside to perform the install
manually.

For History, my OB server is an 9000 class machine running hpux 11.00,
I am trying to run the install on both linux and hpux 10.20 systems.

And is there a place just dedicated to omiback issues? it's a bit of a pain to find
omniback articles at times.

Thanks!

-phil.
I like omiback when it works
0 Likes
6 Replies
Andreas Voss Absent Member.
Absent Member.

Re: OB 3.1 remote unix client install

Hi,

for a manual installation on HP-UX 10.20 here the locations:
On the cell server the installation file for the disk agent lies at:
/opt/omni/databases/vendor/da/hp-ux-1020/A.03.10/packet.Z
Just copy the packet.Z to your client e.g.:
cd /opt/omni/databases/vendor/da/hp-ux-1020/A.03.10
ftp
mkdir /tmp/ob2
cd /tmp/ob2
binary
put packet.Z
bye

On the client machine unpack the file:
cd /tmp/ob2
zcat packet.Z | tar xvf -
Then you can install it with:
cd /
swinstall -s /tmp/ob2

Greetings

Andrew
0 Likes
phil foster Absent Member.
Absent Member.

Re: OB 3.1 remote unix client install

Andreas-

Thanks for the tips. I got most of it to run, but when I fired up the swinstall,
it dropped me into the gui and gave me this error:

"Cannot establish a lock on this target because of an external error (for example, the lock file could not be created.)"
I like omiback when it works
0 Likes
Andreas Voss Absent Member.
Absent Member.

Re: OB 3.1 remote unix client install

Hi,

try a swlist -s /tmp/ob2 before swinstall.
0 Likes
alberto vasquez Absent Member.
Absent Member.

Re: OB 3.1 remote unix client install

The problem you are having is usually an access problem due to remote services not being setup properly between the Cell Manager and the target client. Try testing at the Cell Manager's command line using 'rexec' or 'rsh' commands to access the client system. There is detailed information located in the manual entitled "HP Omniback II Installation & Licensing Guide" in the section entitled "Installing the Linux Client System". You can view this PDF format manual online or download & print it. The website to access it is

www.openview.hp.com

Use the Contents table "Library" selection
and navigate to "Product Manuals -> Omniback II 3.1" If you cannot solve your problem
using this manual then I recommend you place a call to the HP Response Center.

-Tim Lovejoy - HP Omniback Support Team
0 Likes
Highlighted
Nazmal Kanji Absent Member.
Absent Member.

Re: OB 3.1 remote unix client install

I had the same problem recently. The problem seems to be with Linux and how it does not allow anyone to rsh or rlogin as root. The workaround is doing a local install of the disk agents.
0 Likes
ESC Team Absent Member.
Absent Member.

Re: OB 3.1 remote unix client install

Linux Client installation Troubleshooting: This is explained in the Installation and Licensing Guide, 66-67, available at ftp://hpat937.external.hp.com/pub/ovnsmdps/pdf/b6960-90019.pdf

If you run into problems with remote installation on a Linux client system, ensure that root account has rights to access the system either by using rexec or rsh services. To achieve this, do the following:

1. Edit the /etc/inet.conf file by adding the -h flag after the in.rexecd or in.rshd lines:

shell stream tcp nowait root /usr/sbin/tcpd in.rshd -h

2. Kill inetd process with the HUP signal:
kill -HUP $(ps ax|grep inet|grep -v grep|cut -c1-7)

3. Create a ~root/.rhosts file with the entry:

root

That will allow administration access from the Installation Server. After you have installed OmniBack II, you can remove the entry from ~root/.rhosts file, -h flag from the /etc/inet.conf file and repeat
the kill command from the step 2.
ESC Team
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.