Vice Admiral Vice Admiral
Vice Admiral
1190 views

RDS using all memory

Hi,

 

I have a problem in that the RDS service on the cell manager uses up all of the memory when an IDB backup is run and won't release it until the RDS service is restarted.  This happens on both of the cell managers that I use.  Eventually the entire server grinds to a halt and requires the RDS service restarting.

 

Both cell managers are DP7.01, Win2K8R2 with 32GB RAM.  They have both been upgrades from v6.11 and are patched up to the latest level for v7.01.

 

Can anyone tell me whether this is a known issue and if so, is there a fix?

 

Many thanks,

 

John

------------------
Kudos gratefully accepted - How to assign...
Tags (3)
0 Likes
2 Replies
Absent Member.
Absent Member.

I found a couple of  lab cases that references this problem

 

This problem is well known for intensive data driven applications running on Windows Server Family operating  systems.

 

The problem is in the behaviour of Microsoft Windows's "Dynamic Cache Service", but it is not clear if an adjustment should be made to "Dynamic Cache Service" or to Data Protector's setting of an option that "Dynamic Cache Service" uses.  Possibly both are needed.

 

Regarding Windows "Dynamic Cache Service", I read:
SUPPORT COMMUNICATION - CUSTOMER ADVISORY
Document ID: c03117812
Version: 1
CUSTOMER ADVISORY: Configuring the cache usage on Windows 2008 R2 system

as well as MS articles and blogs and forums and QuIXy cases about Windows "Dynamic Cache Service".

 

http://support.microsoft.com/kb/976618

 

There was a test binary issued, but, I don't know if it changed anything in Data Protector, or enabled you to download Dynamic Cache Service

 

You can try upgrading to DP 7.03, with no guarantee that this will fix the problem

 

Unless someone in the Forum has another idea, I advise that you open a Response Center case about this issue, and make reference to

 

QCIM2A46342

QCIM2A47219

 

 

 

0 Likes
Absent Member.
Absent Member.

This is a known issue with MS windows 2008 R2 due to their change in the Cache manager

 

 

UNDER the DPHOME\db40\datafiles\catalog

 

You will find the RDMSERVER.ini

 

under the [Engine] 

 

add the line


WindowsFileRandomAccessFlag=no

 

 

Save the file and restart the services...

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.