Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..
384 views

RMAN integration SBT Error 0

Jump to solution

Hello,

We are currently evaluating the Data Protector Oracle RMAN integration and are experiencing issues in implementing it.
The backup job fails with the following message, no matter how the backup destination is configured in the backup job (StoreOnce, Filelib, directly to tape) or how the backupset string is formatted:

RMAN-03090: Starting backup at 25-OCT-19
RMAN-08048: channel dev_0: starting incremental level 0 datafile backup set
RMAN-08010: channel dev_0: specifying datafile(s) in backup set
RMAN-08522: input datafile file number=00003 name=D:\APP\ORACLE\ORADATA\ORCL\SYSAUX01.DBF
RMAN-08522: input datafile file number=00001 name=D:\APP\ORACLE\ORADATA\ORCL\SYSTEM01.DBF
RMAN-08522: input datafile file number=00005 name=D:\APP\ORACLE\ORADATA\ORCL\UNDOTBS01.DBF
RMAN-08522: input datafile file number=00007 name=D:\APP\ORACLE\ORADATA\ORCL\USERS01.DBF
RMAN-08038: channel dev_0: starting piece 1 at 25-OCT-19
RMAN-08031: released channel: dev_0
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on dev_0 channel at 10/25/2019 10:13:20
ORA-19506: failed to create sequential file, name="rmantest<ORCL_435_1022580797_1>.dbf", parms=""
ORA-27028: skgfqcre: sbtbackup returned error
ORA-19511: non RMAN, but media manager or vendor specific failure, error text:
SBT error 0 in function sbtbackup - sbterror did not return error message

The backup script is rather simple and cut down to its basics at the moment:

run {
allocate channel 'dev_0' type 'sbt_tape'
parms 'ENV=(OB2BARTYPE=Oracle8,OB2APPNAME=ORCL,OB2BARLIST=rmantest)';
backup incremental level <incr_level>
format 'rmantest<ORCL_%s_%t_%p>.dbf'
database;
backup
format 'rmantest<ORCL_%s_%t_%p>.dbf'
archivelog all;
backup
format 'rmantest<ORCL_%s_%t_%p>.dbf'
current controlfile;
}

The target database is a 12.2 DB running in archive log mode, the backup user that Data Protector uses has been granted the SYSBACKUP role. We already tried adding the server's Oracle user as a Data Protector admin as well as the database user - none of which had an effect. The same issue appears when starting a backup from RMAN directly. RMAN backups to disk (without Data Protector) work perfectly fine though.

Do you have any idea what the cause of this problem might be? "sbterror did not return error message" is a rather unhelpful error message.

Thanks in advance!

Update: The target database is running on Windows Server 2016. We also tried setting ZDB_SMISA_AUTOMOUNTING = 2 according to the Integration guide.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,

This happens if the user running the database is not configured in the Data Protector User Management. It should be there with admin or operator rights. You should see traces of this misconfiguration in the debug.log and/or oracle8.log on the Oracle Client during the backup. Data Protector needs to match username, group/domain and client (FQDN).

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
20 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,

This happens if the user running the database is not configured in the Data Protector User Management. It should be there with admin or operator rights. You should see traces of this misconfiguration in the debug.log and/or oracle8.log on the Oracle Client during the backup. Data Protector needs to match username, group/domain and client (FQDN).

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..

Re: RMAN integration SBT Error 0

Jump to solution

Hello Sebastian ,

thanks for your answer. The user running the database is configured in Data Protector and granted admin rights. The entry in userlist looks like this:

"Oracle Backup User" "ORACLE" "*" * "admin" "Yes"

The user running the database is a local windows user called "oracle".
Is there anything to correct?

Regards,
Marco

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,

This will be okay for older versions of Data Protector. Current versions such as A.10.50 are more strict on this kind of wildcard entries. What is the Data Protector version? Anything useful in the log files mentioned on the client?

If the oracle user is a local account on the database server dbsrv.domain.com use:

Username: ORACLE, Group/Domain: DBSRV, Client: dbsrv.domain.com

If the oracle user is a domain account in domain DOM1 and the database server is dbsrv.domain.com use:

Username: ORACLE, Group/Domain: DOM1, Client: dbsrv.domain.com

Make sure the database server resolves itself to it's FQDN. Had the same issue recently with a Linux server with no DNS domain name configured.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..

Re: RMAN integration SBT Error 0

Jump to solution

We are currently running Data Protector version 10.30. The user originally had more restrictive rights and I gave him "any" rights for debugging. The backup fails, regardless of restrictive rights or wildcards. Connecting to the GUI from the target server works fine though. The server's FQDN is resolved as it should be.

There is an interesting error message in oracle8.log:

[OB2_SetUpOracle] Exiting with (-1), msg: OB2_Init != OBE_OK
, ob2error=1012: Marked error: 1012

This is the first entry for every session and results in these error messages:

[sbtbackup] Exiting with (-1), msg: OB2_StartBackup() failed, ob2error=1012: Marked error: 1012
[sbterror] Exiting with (-1), msg: Error engine not supported for this mode
, ob2error=1012: Marked error: 1012

I'm not sure what sort of variables OB2_Int and OBE_OK are but this seems to be the root of the problem.

Regards,
Marco

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,

Problem in my case was that the Oracle server itself resolved it's own name to hostname instead of hostname.domain.com. This was used by the Oracle integration and rejected from the Cell Manager. You can verify this by running Check Installation from Clients context on the Oracle client.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..

Re: RMAN integration SBT Error 0

Jump to solution
Hello Sebastian,

the server name is being resolved to "hostname.example.tld" and is identified by Data Protector as such. The server also identifies itself correctly.

Checking the installation doesn't throw any errors or warnings. I don't think DNS is an issue here.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,


@Systemtechnik wrote:


Update: The target database is running on Windows Server 2016. We also tried setting ZDB_SMISA_AUTOMOUNTING = 2 according to the Integration guide.


I guess you have tried a regular, non-ZDB, backup already? Can you share the full session report with us?

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..

Re: RMAN integration SBT Error 0

Jump to solution

Hello Sebastian,

I only tried regular backups.

I didn't really expect it to work since we don't use ZDB anyway - I just set the parameter for good measure because it said so here:

https://docs.microfocus.com/itom/Data_Protector:10.03/Integrate/about_this_guide/PRE_About_TG/oracle_server_integration

A session report is attached.

Regards,
Marco

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,

Be careful when using older documentation. The one you have shared is for 10.03. Please use this.

https://docs.microfocus.com/itom/Data_Protector:2019.08/OracleServerIntegration

I think this is not related to the error, but can you try to backup without the Recovery Catalog?

recovery catalog database Password: RMAN-06008: connected to recovery catalog database
RMAN-06619: recovery catalog schema release 18.03.00.00. is newer than RMAN release

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..

Re: RMAN integration SBT Error 0

Jump to solution
Oh, sorry - thanks for the hint.

Using the database's control file instead of the catalog results in the same error unfortunately (minus notices concerning the catalog of course).
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,

Before we look at the debugs. Have you tried to run the backup with the sys account (including the omnirc option that enables that for Oracle 12c)? Adding the sys account to the Data Protector UserList would be also required.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..

Re: RMAN integration SBT Error 0

Jump to solution

Hello Sebastian,

yeah, that results in the same error. How should the userlist entry be formatted? I tried the following variants:

"RMAN Test" "SYS" "HOSTNAME" hostname.domain.tld "admin" "Yes"
"RMAN Test" "SYS" "orcl" hostname.domain.tld "admin" "Yes"
"RMAN Test" "SYS" "orcl" * "admin" "Yes"
"RMAN Test" "SYS" "*" * "admin" "Yes"
"RMAN Test" "SYS@ORCL" "HOSTNAME" hostname.domain.tld "admin" "Yes"
"RMAN Test" "SYS@ORCL" "*" * "admin" "Yes"

All result in the same error.

Regards,
Marco

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RMAN integration SBT Error 0

Jump to solution

Hello @Systemtechnik,

Well, thanks for asking the right question, because this might lead to something. Starting with DP 10.x directly editing the UserList file is no longer supported. You must add the users using the GUI or the omniusers command (which now  also exists on the Windows CM). It will properly format the UNIX users all lowercase and the Windows users all uppercase. The password for a user is only required if GUI or WebUI access is required.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Trusted Contributor.. Systemtechnik Trusted Contributor..
Trusted Contributor..

Re: RMAN integration SBT Error 0

Jump to solution
Oh, I'm sorry that was explained ambiguously on my part.

I edited the user via GUI and just copied the entries from the userlist because it's easier share - I didn't edit the userlist directly.

My question wasn't referring to the format in the userlist itself but on how the user should be added (like dbuser@dbname, only dbuser etc.).

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.