Absent Member.
Absent Member.
482 views

Red Hat /opt/omni/lbin/uma issue, DP9

I'm running DP 9 on a Windows 2012 R2 virtual machine.  This replaced the Cell Manager that Ed and I originally were pointing two when you put together the VNX Snapshot scripting for me.

I have a client running Red Hat Enterprise Linux 6.7 (updated to latest patches) on a physical server (Proliant DL380) that I'm trying to use as a media server to stream data to tape.

Server is connected to fibre channel switches and zoned to see two Quantum Scalar i80 tape libraries.

When I look in the dmesg output, I can see the libraries (changers and tape drives) showing up.  However, when I try to use the matching device entries for the changer with the uma command, I get either one of two results, neither successes.  The command I'm trying is:

echo stat x | /opt/omni/lbin/uma -tty -ioctl <device>

Using /dev/ch0: command executes, but never returns any information (ar at least not within 3 minutes when I aborted it)

Using /dev/sg5: command executes but immediately fails with generic "Segmentation fault (core dumped)" message

I have used this for the past 10 years in various versions of DP, but always from an HPUX server to an HPUX cell manager.  When I upgraded to DP8 the cell manager moved to a Red Hat Linux VM, and still worked fine.  Even more recently we rolled out the DP9 Windows-based cell manager, and I can do the above commands from a Cygwin shell running on the Windows server that is connected to the libraries through the same switches.

It is only from the Linux server that I'm having this problem.

Any thoughts?

0 Likes
2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Red Hat /opt/omni/lbin/uma issue, DP9

Hi,

What happens when you start the uma and run some commands from the uma prompt? You could do this in debug mode (-debug 1-500 DBG) and capture the output and send it together with the generated debugs to support. Obviously, if this would work fine then the problem is most likely not with uma itself and more/other troubleshooting would be required.

Koen

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Red Hat /opt/omni/lbin/uma issue, DP9

Hi Rick.

    It looks like you've hit a bug that has been fixed in the recently released 9.05 bundle - https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR2A64323. Time to apply the bundle?

Regards,

Shishir

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.