Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Super Contributor.. rsamora Super Contributor..
Super Contributor..
460 views

Reports - Database Purge & Sync Settings

Jump to solution

I have just started playing with the Reports under the Home screen and it seems that every time I want to run some of the reports, I see that the database purge is in progress or the database sync is in progress and I can't do anything.  I have one cell to sync every 8 hours and one to sync every 12 hours hoping to find a happy medium that will allow me to run reports during normal working hours but still no luck.

What should the sync frequency be?  If database purge is in progress, can I manually stop it?  Can I manually stop the sync if it is in progress?  Is there a way to get those processes to run only after hours?

Thanks,

Randy

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hello @rsamora,

Please upgrade the Reporting Server to match the Cell Manager version A.10.50.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
14 Replies
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hello @rsamora,

The sync settings depend on the performance and size of reporting server and Cell Managers. In general 30 to 60 minutes sync intervals would be no problem for most environments. At least it never was a problem for Backup Navigator in the past. A sync is incrementally and I have never seen it blocking any reports even when running at 30 minute intervals.

A purge should not do much if the data retention is set to 5 years (default). Since the Reporting Server is new there should be no/little data to remove.

Can you comment on the initial sync with your Cell Managers? Did it worked well? It should complete pretty fast. What version are you running?

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Super Contributor.. rsamora Super Contributor..
Super Contributor..

Re: Reports - Database Purge & Sync Settings

Jump to solution

I have never taken the time to monitor how long the sync takes, I just come back later and check. 

I'm monitoring one cell now.  The Sync Frequency is 8 hours and it shows that the database successfully synced at 5:10 PM on 10/15...two days ago!!  Right now, it shows "Database purge is in progress."

On a second cell, with a 12 hr sync frequency, the database was successfully synced at 8:46 PM, also two days ago.  Right now, it shows "Database sync is in progress."

When either process, sync or purge, are in progress, I can't run any reports.  I can setup a report, select the time frame for example, but when I click on Generate, for just a split second I see the two blue arrows, but then the "Database sync/purge is in progress" window pops back up and stays.

This is the first time I noticed that that the last sync was days ago.  Before, I just looked at the time, not the date, and assumed it was hours ago.  Something is obviously hung up.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hello @rsamora,

Can you do me a favour and collect and attach the logs stored in /var/opt/omni/log/AppServer (Linux) or C:\ProgramData\OmniBack\log\AppServer (Windows) on the Reporting Server?

What version of Data Protector and the Reporting Server are you running?

After that restart the Reporting Server and monitor if the issue is resolved.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Super Contributor.. rsamora Super Contributor..
Super Contributor..

Re: Reports - Database Purge & Sync Settings

Jump to solution

The log files have been attached.  Reporting server is running 10.40, all 3 cells are running 10.50, all Windows servers.

After the reboot:

Cell 1 - Home screen, click on Reports, shows me "Database successfully synced for <server1> at 10/17/2019, 1:12:01 PM"  The sync frequency is set at 1 hour.  If I go through the steps of running a report, click on Configuration Reports, click on Average Time Per Backup Specification, I see "Database sync is in progress" and I can't do anything.  However, if I click on Configuration/Settings, it shows "Purge is running."

Cell 2 - Home screen, click on Reports, shows me "Database successfully synced for <server2> at 10/17/2019, 11:45:35 PM"  The sync frequency is set at 1 hour.  If I go through the steps of running a report, click on Configuration Reports, click on Average Time Per Backup Specification, I see "Database sync is in progress" and I can't do anything.  However, if I click on Configuration/Settings, it shows "Purge is running."

Cell 3 - Different messages - Home screen, click on Reports, shows me "Database sync for <server3> is in progress (60% completed).  The sync frequency is set at 1 hour.  If I go through the steps of running a report, click on Configuration Reports, click on Average Time Per Backup Specification, I see "Database sync is in progress" and I can't do anything.  Under Configuration/Settings, it confirms "Database sync for <server3> is in progress (60% completed.)

Thank you for the responses,

Randy Samora

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hello @rsamora,

Please upgrade the Reporting Server to match the Cell Manager version A.10.50.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Super Contributor.. rsamora Super Contributor..
Super Contributor..

Re: Reports - Database Purge & Sync Settings

Jump to solution

[NORMAL_DETAIL] Service Data Protector Inet started.
[NORMAL_DETAIL] Service Data Protector RS DB started.
[NORMAL_DETAIL] Service Data Protector Reporting Application Server started.
[CRITICAL] Reporting Server port configuration failed.
[CRITICAL_DETAIL] Reporting Server port configuration failed with the output: 8443
[CRITICAL] Reporting Server packages deployment failed.
[CRITICAL_DETAIL] Reporting Server deployment of C:\Program Files\OmniBack\bin\components\reporting.war failed with the output: Failed to connect to the controller: The controller is not available at localhost:14505: java.net.ConnectException: WFLYPRT0053: Could not connect to http-remoting://localhost:14505. The connection failed: WFLYPRT0053: Could not connect to http-remoting://localhost:14505. The connection failed: Connection refused: no further information
[CRITICAL] Reporting Server packages deployment failed.
[CRITICAL_DETAIL] Reporting Server deployment of C:\Program Files\OmniBack\bin\components\reporting.war failed.
[CRITICAL] Reloading the Reporting Server configuration data failed.
[CRITICAL_DETAIL] Reloading the Reporting Server configuration data failed with the output: C:\Program Files\OmniBack\bin\components\reporting.war
[CRITICAL] Reporting Server configuration failed.
[NORMAL] All services successfully started.
[NORMAL] Successfully upgraded users in Inet impersonation database.

 

When we first upgraded to 10.20 (I think) we lost the home screen because clicking on the Reports section generated an "ERROR - Reason - Internal Server Error" pop up.  10.40 restore Reporting capabilities.  Now i'm back to my "Internal Server Error" and "Unable to connect Reporting Server.

If I completely uninstall DP from the reporting server and start with a fresh install of 10.50, is there a way to preserve all of the data that has been collected so far or will I have to start from scratch?

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hello @rsamora,

Sorry to hear that. Yes, please start with a fresh Reporting Server. You can use omnisetup.sh -Uninstall and omnisetup.sh -Delete for that. There should be no "data lost", because Reporting Server right now only holds current data that is synced from Cell Managers IDB. Since you had problems before I would consider that data not fully trustworthy anyway.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Super Contributor.. rsamora Super Contributor..
Super Contributor..

Re: Reports - Database Purge & Sync Settings

Jump to solution

Success!!  I'm back online.  I set the sync frequency to 1 hour and I'll check back Monday morning to see how everything looks.

Thanks again for the help.

Randy

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hi @rsamora,

Thanks for the update. If you still seeing issues with the new RS version then share a new set of logs here.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Super Contributor.. rsamora Super Contributor..
Super Contributor..

Re: Reports - Database Purge & Sync Settings

Jump to solution

Good morning Sebastian,

It's me again.  I'm attaching new Appserver log files along with some screenshots to show you what I'm seeing.  Even though my sync frequency is set for 1 hour, the last successful sync shows as yesterday at 11:47 PM.  Even when I manually click on the SYNC NOW button, and I get another successfully synced message, the screen still shows last successful sync was last night.  To make matters worse, even though the sync just ran to completion, if I try to run a report, I get a "Sync in progress" message on my screen.

If I wait long enough, probably later this afternoon, I might be able to run reports again.  But any ideas on what's causing the delays?  All 3 cells show last successfuly sync was late last night.  Two cells show "sync in progress" and the 3rd shows "purge in progress" and I can't run reports on any of them.

Thanks,
Randy

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hello @rsamora,

This is something for support. I can see plenty null pointer exceptions in the server.log and the last sync was 2019-10-29 23:47:06 according to the log. Can you send this to Micro Focus support?

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Super Contributor.. rsamora Super Contributor..
Super Contributor..

Re: Reports - Database Purge & Sync Settings

Jump to solution

I was starting to think the same thing but I really appreciate your help earlier with this.  I'll open a case with support.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Reports - Database Purge & Sync Settings

Jump to solution

Hello @rsamora,

Feel free to share the support request ID here once you have it. At least you're running a good setup now so this should make things easier to troubleshoot and resolve.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Super Contributor.. rsamora Super Contributor..
Super Contributor..

Re: Reports - Database Purge & Sync Settings

Jump to solution

Case SD02578417

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.