Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Ken Krubsack Absent Member.
Absent Member.
14973 views

Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

Our friend RETVAL 8010 is showing up when I try to configure a backup job on DP 8 for Exchange 2013 integration.  Fortunately, right now this is in my test lab, but I'm going to need a solution for Exchange 2013 in a month or so.

 

Is this a known issue (read: an easy fix)?

 

Thanks

Ken

0 Likes
1 Solution

Accepted Solutions
Bob_Clark Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

According to Microsoft, exception 0xC0000142 (STATUS_DLL_INIT_FAILED) means that initialization of the  dynamic link library failed. It looks like some of dll's linked to e2010_bar are missing or not correctly registered.

 

1) In Windows 2012 environment .net framework 3.5 is not installed by default,  so please install it manually through ServerManager on all windows 2012 machines and after that try again to configure Exchange  integration. If configuration fails again, proceed with following steps.

 
2) Start command prompt at client testlabex04 (if possible also try on other machines), execute following commands and send us  output:
    
"C:\Program Files\OmniBack\bin\e2010_bar.exe" -v
"C:\Program Files\OmniBack\bin\e2010_bar.exe" -chkconf
"C:\Program Files\OmniBack\bin\e2010_bar.exe" -getexchversion
 
3) If you receive error as expected in step 1, try to reinstall Microsoft Visual C++ 2008 and 2010 runtime (download:  http://support.microsoft.com/kb/2019667) and after that try again commands from previous step, and if they are working, try again  to configure Exchange integration
 
This case is still an open issue, no clear solution yet

View solution in original post

19 Replies
Ken Krubsack Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

This is what I get from the debug log on the Exchange 2013 client when I try to set up the job:

 

11/25/2013 3:51:07 PM  INET_thread_e2010_bar.exe.80872.82176 ["/lib/cmn/win32exe.c $Rev: 35470 $ $Date:: 2013-01-14 17:58:40":255] A.08.00 b596
Process PID:82968 exited with exception: 0xC0000142!

 

And nothing in the debug log of the cell manager.  Now, granted, this is basic debugging - nothing advanced.

 

Ken

0 Likes
Bob_Clark Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

According to Microsoft, exception 0xC0000142 (STATUS_DLL_INIT_FAILED) means that initialization of the  dynamic link library failed. It looks like some of dll's linked to e2010_bar are missing or not correctly registered.

 

1) In Windows 2012 environment .net framework 3.5 is not installed by default,  so please install it manually through ServerManager on all windows 2012 machines and after that try again to configure Exchange  integration. If configuration fails again, proceed with following steps.

 
2) Start command prompt at client testlabex04 (if possible also try on other machines), execute following commands and send us  output:
    
"C:\Program Files\OmniBack\bin\e2010_bar.exe" -v
"C:\Program Files\OmniBack\bin\e2010_bar.exe" -chkconf
"C:\Program Files\OmniBack\bin\e2010_bar.exe" -getexchversion
 
3) If you receive error as expected in step 1, try to reinstall Microsoft Visual C++ 2008 and 2010 runtime (download:  http://support.microsoft.com/kb/2019667) and after that try again commands from previous step, and if they are working, try again  to configure Exchange integration
 
This case is still an open issue, no clear solution yet

View solution in original post

Ken Krubsack Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

Bob,

 

The tests you wanted me to run have returned the following output:

 

PS C:\Program Files\OmniBack\bin> e2010_bar.exe -v
HP Data Protector A.08.00: E2010_BAR, internal build 596, built on Monday, May 20, 2013, 4:25 AM

 

PS C:\Program Files\OmniBack\bin> e2010_bar.exe -chkconf

[Critical] From: OB2BAR_E2010_BAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 2:01:19 PM

 Configured User svc-d-dataprotector is not a member of MS Exchange built-in group 'Organization Management'.

 

(which I find interesting because I have a screen shot from my Exchange guy that says this is NOT the case - the account in question IS in fact in the built-in group 'Organization Management')

 

PS C:\Program Files\OmniBack\bin> e2010_bar.exe -getexchversion

MS Exchange Server version = v15

 

Thanks

Ken

0 Likes
Ken Krubsack Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

Reapplied Visual C++ 2008 and 2010 redistributables (not sure VC++ 2010 was ever on the Exch 2013 server)... second command changed:

 

PS C:\Program Files\OmniBack\bin> e2010_bar -chkconf

MS Exchange 2010+ Configuration check success

 

Now I am able to configure the backup job.

 

HOWEVER...

 

DP8 doesn't seem to recognize the DP 7 licenses I had in place.  It tells me there is no cell manager license.

 

I seem to recall seeing that one out here somewheres... time to start digging!

 

Ken

Tags (1)
0 Likes
Ken Krubsack Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

OK, THAT was interesting.

 

Somehow the DP 7-8 upgrade smoked my cell manager license right out of the file.  Re-applied it and started my Exch 2013 backup job...  however... now, I get the "no hardware providers".  Any clues out there?

 

[Normal]

From: BSM@wkfntddpcm81.dev.lz.com "D-Exch11-2013"  Time: 11/26/2013 3:08:47 PM

Backup session 2013/11/26-2 started.

 

[Normal]

From: BSM@wkfntddpcm81.dev.lz.com "D-Exch11-2013"  Time: 11/26/2013 3:08:47 PM

OB2BAR application on "wkfntdexch11.dev.lz.com" successfully started.

 

[Normal]

From: OB2BAR_E2010_BAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:04 PM

Analyzing MS Exchange Server 2010+ environment.

 

[Normal]

From: OB2BAR_E2010_BAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:07 PM

Mailbox Databases selected for backup on server wkfntdexch11.dev.lz.com

DEV MBX DB EXCH11\WKFNTDEXCH11

 

[Normal]

From: OB2BAR_E2010_BAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:07 PM

Initializing DP VSS Interface.

 

[Normal]

From: OB2BAR_E2010_BAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:07 PM

Starting backup using DP VSS Interface.

 

[Normal]

From: OB2BAR_VSSBAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:09 PM

Performing Full Transportable Backup.

 

[Normal]

From: OB2BAR_VSSBAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:09 PM

Connecting to Volume Shadow Copy Service.

 

[Major]

From: OB2BAR_VSSBAR@wkfntddpcm81.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:10 PM

There are no hardware providers installed on the system.

Backup cannot continue.

 

[Major]

From: OB2BAR_VSSBAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:10 PM

There are no hardware providers installed on the system.

Backup cannot continue.

 

[Major]

From: OB2BAR_VSSBAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:46 PM

Backup failed.

 

[Major]

From: OB2BAR_E2010_BAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:46 PM

Error occurred while executing backup for component DEV MBX DB EXCH11(f93f6a41-61d7-4f41-bbbd-57b18ea3e1b5).

 

[Normal]

From: BSM@wkfntddpcm81.dev.lz.com "D-Exch11-2013"  Time: 11/26/2013 3:09:48 PM

OB2BAR application on "wkfntdexch11.dev.lz.com" disconnected.

 

[Critical]

From: BSM@wkfntddpcm81.dev.lz.com "D-Exch11-2013"  Time: 11/26/2013 3:09:48 PM

None of the Disk Agents completed successfully.

Session has failed.

 

[Normal]

From: BSM@wkfntddpcm81.dev.lz.com "D-Exch11-2013"  Time: 11/26/2013 3:09:48 PM

Backup Statistics:

         

Session Queuing Time (hours)         0.00       

-------------------------------------------     

Completed Disk Agents ........          0         

Failed Disk Agents ...........          0         

Aborted Disk Agents ..........          0         

-------------------------------------------     

Disk Agents Total  ...........          0         

===========================================     

Completed Media Agents .......          0         

Failed Media Agents ..........          0         

Aborted Media Agents .........          0         

-------------------------------------------     

Media Agents Total  ..........          0         

===========================================     

Mbytes Total .................       0 MB       

Used Media Total .............          0         

Disk Agent Errors Total ......          0   

 

============================================================================

                      Session failed!

============================================================================

0 Likes
Bob_Clark Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

I found only one reference to this error, it goes back to 6.11, so, I can't swear as to its relevance

 

Apparently, this is caused by activating Instant Recovery when doing Zero Downtime Backups

 

I could reproduce the issue in the lab as well. Pls refer the following.
<---
C:\>cd "Program Files\OmniBack\bin"

C:\Program Files\OmniBack\bin>omnidbvss -resolve -apphost XYZ
[Normal] From: OB2BAR_VSSBAR@XYZ "MSVSSW"  Time: 9/29/2010 10:02:40 AM
        Resolving system 'XYZ'.

[Normal] From: OB2BAR_VSSBAR@XYZ "MSVSSW"  Time: 9/29/2010 10:02:40 AM
        Connecting to Volume Shadow Copy Service.

[Major] From: OB2BAR_VSSBAR@XYZ "MSVSSW"  Time: 9/29/2010 10:02:41 AM
        There is no hardware provider installed on the system.
        Backup cannot continue.

(I changed the actual hostname to XYZ to protect the innocent)

 

The command "omnidbvss -resolve -apphost cpewit25.intg.cpe.net" will be used only in case of ZDB.
I am not sure why customer is attempting this if he is not running transportable/ZDB backup.

Pls refer the CLI user guide content.

<---
-resolve {-apphost ApplicationSystem|-all}

Resolves the specified application system (if -apphost is used) or all application
systems (if -all is used) in the Data Protector cell.

The command applies only to instant recovery-enabled backup sessions and must
be run always after:
- installing or upgrading Data Protector
- your source volumes configuration on the application system has changed
    (for example, you have modified the existing source volumes or you have
     presented new source volumes)
- you have added a new storage object (for example, a Microsoft Exchange
Server storage group)

 

For more information, see the HP Data Protector zero downtime backup integration
guide.
--->

After reading the above text, it is clear that resolve is used only
"to instant recovery-enabled backup sessions"

Hence could you pls let me know the reasoning behind running this command. Also,
confirm the following.

1. Customer wants to backup file system or a application writer
2. Customer has any luns presented or not, if so from EVA/XP.

 

This was in the context of trying to configure an Exchange 2010 backup, so I don't know how much relates to you.  But, I would check the options in the Backup specification to make sure that you don't have this enabled

 

 

0 Likes
gilles_cadrin Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

Your issue  is the way you defined your backup job

 

[Normal]

From: OB2BAR_VSSBAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:09 PM

Performing Full Transportable Backup.

 

[Normal]

From: OB2BAR_VSSBAR@wkfntdexch11.dev.lz.com "MS Exchange 2010+ Server"  Time: 11/26/2013 3:09:09 PM

Connecting to Volume Shadow Copy Service.

 

 

If you want to use  VSS Transportable Backup.. this is the equivalent of Microsoft to our Exchange Instant Recovery.. so you need to have a Hardware provider in order to create the transportable snapshot

 

 

Rededine a new job

 

At the first screen select instead LOCAL OR NETWORK BACKUP instead of the VSS Transportable backup ( Unless you do have an EVA or an XP DISK ARRAY or any other 3rd party that will provide you with the hardware provider to manage the snapshots / copies )

 

hope this help you

 

 

Gilles

Ken Krubsack Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

Well, I'm back to DP thinking my service account isn't part of the built-in 'Organization Management'.  HAve to have my Exchange guru check that on Monday - but I don't think anything has removed it.

0 Likes
Ken Krubsack Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

This works in our production environment.

 

But HP - come on, folks, get your documentation complete.  Please list the pre-reqs for using DP 8 with Exch 2013:

     - .NET 3.5

     - Visual C++ 2010 redistributable

(thanks, Bob Clark, for those two)

 

0 Likes
Bob_Clark Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

I actually found a lab case where this dependency was reported, and the documentation was supposed to have been updated.  I wanted to look at the integration Guide to see if it made it in, but, that site is down right now (go figure).  I'll try again tomorrow

0 Likes

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

The same problem of the DP user reported as not belonging to "organization management" group where it is instead.

Running DP 9.01

Any idea ?

thanks

 

0 Likes
Absent Member.. Peter UDP Absent Member..
Absent Member..

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

Bob, is there an escalation on this issue?  We're in the same boat, Exchange admins are very worried about having to grant full blown access.  Have you tried incrementally enabling services to see what the baseline threshold is?   Thanks for any input.

0 Likes
Bob_Clark Absent Member.
Absent Member.

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

Not only are there no Escalation on this issue, there is not even any lab cases open that I can file.  I did some 'google' searching, and did find a couple of things

 

http://h30499.www3.hp.com/t5/Data-Protector-Support-and-News/DP-6-11-Failing-to-Backup-Exchange-2010-via-VSS/td-p/4644566#.VRmshvnF8eo

 

Similar problem with 2003, turned out to be permissions on C:\exchsvr\bin\ and account not being exchange admin. But I tried an advanced backup using windows backup locally and I could see everything. So the problem was from the backup software. No Firewall so no problem with 5555. Agents installed ok, just no ntfs permissions.Even though path variable added. 

 

==============

 

This may also be a problem with Windows VSS function

 

http://blogs.technet.com/b/josebda/archive/2008/05/29/installing-the-vss-hardware-provider-for-the-microsoft-iscsi-software-target-on-windows-server-2008.aspx

 

 

0 Likes
Absent Member.. Peter UDP Absent Member..
Absent Member..

Re: Retval 8010, DP 8, and Exchange 2013 integration

Jump to solution

I'm pushing the issue with HP, the documentation looks like it's two years behind the software.  This running with full permissions is too much of a security risk. 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.