karesz55 Frequent Contributor.
Frequent Contributor.
350 views

The web interface is not running, because of the vendor.js error

Hi all,

 

Today, I found that I didn't reach the web interface.  I am using 10.20.

Error message:

2019-06-14_9-44-01.jpg

I didn't change anything, only a windows update was installed a few days ago.

In a self-solving knowledge base, I found a solution to: replace this file, but by now, this file is not available nowhere.

I've tried these with:

  1. Server restart
  2. Services restart

 

Have you ever experienced a similar look? What is the solution?

 

 

 

Labels (1)
0 Likes
11 Replies
Respected Contributor.. Andy___H1 Respected Contributor..
Respected Contributor..

Re: The web interface is not running, because of the vendor.js error

Hi,

I can't tell you the solution, but I can say I have exactly the same error, but I am using 10.30, and mine is a brand new install of 10.30, our first, upgraded from 9.09. Our Windows GUI is on Windows Server 2012.

If you find a solution I'd like to know also so I can get our home page working also for 10.30. For now we are just testing 10.30 and have backed out to 9.09, but we will be trying again next week to install again and diagnose this issue, and others we have. I am sure all are local issues to my environment, but need to be fixed before we can commit to upgrades to our live DP environments.

Thanks,

Andy

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: The web interface is not running, because of the vendor.js error

Hello @karesz55 and @Andy___H1

This is a known issue in DP 10.20 and 10.30. You need to request the vendor.js to support. Sometimes also fails with main.js after applying the vendor.js, this is known too. 

You will need to request this fix: QCCR2A83398. Open a case and refer to this fix. 

Regards, 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Respected Contributor.. Andy___H1 Respected Contributor..
Respected Contributor..

Re: The web interface is not running, because of the vendor.js error

Hi,

Many thanks for confirmation, I'll raise a case.

Cheers,

Andy

0 Likes
karesz55 Frequent Contributor.
Frequent Contributor.

Re: The web interface is not running, because of the vendor.js error

Hi,

 

I tried deleting the latest installed windows updates and after deleting it, the web interface is restored and works. That day when we updated several security and system updates were installed. I will have a look at it later and I will put them one by one and I will send you the bad pack ID. Or will I reinstall all of them and I open the case as you recommended?

Micro Focus Expert
Micro Focus Expert

Re: The web interface is not running, because of the vendor.js error

You can do this, and let us know the wrong package. 

Anyway, when you update your Windows, you will need the vendor.js and main.js to apply them. So open a case and request them. 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
karesz55 Frequent Contributor.
Frequent Contributor.

Re: The web interface is not running, because of the vendor.js error

I reinstall all windows update and now works.
I don't understand what why. That what has changed since then...
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: The web interface is not running, because of the vendor.js error

Interesting behavior. At least now you know that there is a hotfix in case you need it in the future. 

Regards, 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Frequent Contributor.. Ricardo B Frequent Contributor..
Frequent Contributor..

Re: The web interface is not running, because of the vendor.js error

Hello,

The users can access Data Protector web services using their web user name, as listed in the GUI (User contextselect the user name to display its properties) and in CLI (omniusers –list). 

 To access calendar, open Internet Explorer and access to:

https://CellManager.domain.com:7116/dp-nextgen/js/index.html

It may be necessary to create a specific user in Data Protector.

0 Likes
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: The web interface is not running, because of the vendor.js error

Hello,

Here is a quick tutorial on how to setup the WebUI for external use as a workaround. Using any browser other than IE (Chrome, Firefox, etc.) works.

https://www.data-protector.org/wordpress/2018/06/access-data-protector-webui/

Those problems are fixed with Data Protector A.10.40 which is no longer using the embedded Internet Explorer engine.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
Respected Contributor.. Andy___H1 Respected Contributor..
Respected Contributor..

Re: The web interface is not running, because of the vendor.js error

Many thanks Sebastian and others, that's got us working on the WebUI now using 10.30. First I had to set the WebUI password via the GUI, and then accept the right certificates, and I was in. Next thing to look at is doing the full LDAP configuration.

Now that I am in I'm a little disappointed by what it's telling us and it's implementation. Under the licenses box on the dashboard it is showing 0 licenses, and when we click that box we just get the spinning Micro-Focus logo that never seems to return anything. Is this normal, should it be showing licenses?

Does it change much if we upgrade to 10.40, would we get more functionality out of it?

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: The web interface is not running, because of the vendor.js error

Hi @Andy___H1,

The biggest change is the Chromium engine and bugfixes in A.10.40.

The license loading could take some time because it will, depending on your configuration also query the vCenter server(s), which is slow. I do not rely on this license module because omnicc -check_license -detail is more reliable. But I agree, it is there and should work properly/fast.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.