Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Ken Krubsack Absent Member.
Absent Member.
1841 views

Upgrade from 7.03 to 8.1 failing

Bob Clark: This is the new topic I promised.

 

I do need one of the new functions in 8.1x - specifically, I understand the SMI-S backups on 3PAR P7x00 systems are supported in 8.1x.  However, when I do the in-place upgrade from 7.03 to 8.1, I wind up with the IDB service simply not starting (Bob - I *HAVE* applied the security thing we discussed in case # 4647454951 we worked on trying to get 8.x to install to something other than C:).

 

Can the upgrade process handle moving the database drive from D: to C:?  Or is it strictly going to keep everything on the same drive letter?  Also, what about getting all the history in?  I guess I can understand trying to keep the upgrade from taking forever when a 40 GB database needs imported, but I don't like the idea of having to manually rebuild all my history by importing tapes one-by-one.  And not everyone can afford to keep two sets of equipment around just to deal with two different cell managers to keep longer-retention tapes around before they can be imported.

 

A few random thoughts here, yeah... but the need for the SMI-S agent is real - the EVAs are on the way out and the 3PARs are coming in here.  And soon.  I really don't want to lose that SMI-S snapshot functionality.

 

Ken

Tags (1)
0 Likes
5 Replies
Highlighted
Bob_Clark Absent Member.
Absent Member.

Re: Upgrade from 7.03 to 8.1 failing

Ken, what are the results of the command

 

   omnisv status

 

If it is something like this:

 

    ProcName      Status  [PID]

===============================
    crs         : Active  [3464]
    mmd         : Active  [5364]
    kms         : Active  [5440]
    hpdp-idb    : Down
    hpdp-idb-cp : Active  [5604]
    hpdp-as     : Active  [4284]
    omniinet    : Active  [4980]

    Sending of traps disabled

 

check the top level of  both C: and D: for the file 'Program', and if you see it, delete it

 

==============

 

Problem:

During the update to DP 8.1, the hpdp-idb service does not start.
As a consequence, the import of the IDB (core update) does not work and needs to be repeated.

Example:

The DP 7.0 installation has been done in a way that binaries and data files are located in        C:\Program Files\OmniBack.
The same applies for
D:\Program Files\OmniBack (or other volumes).

 

During the update, 2 omnimigrate logs are created.
One for the export and one for the import.

In case the IDB cannot start, the import log file C:\Program Files\OmniBack\log\omnimigrate_2014-03-21_03-06-15.log shows:

Cannot start "hpdp-idb" service, system error:
[1053] The service did not respond to the start or control request in a timely fashion.

 

Solution:

The solution consists of the sequence of the following steps (assuming that common path C:\Program Files\OmniBack has been used).

1)
Delete the file "C:\Program".

2) Do "omnisv stop" and "omnisv start".

3) Use "omnisv status" to check that all services have been started.

4) Check the location where the IDB has been exported to (default is C:\Program Files\OmniBack\tmp\export):
     You should see a mmdb and a cdb folder there.

5) Open power shell and go to
C:\Program Files\OmniBack\bin

6) Run the import manually:

    PS C:\Program Files\OmniBack\bin> perl omnimigrate.pl -import -shared_dir "C:\Program Files\OmniBack\tmp\export" -force

 

 

Ken Krubsack Absent Member.
Absent Member.

Re: Upgrade from 7.03 to 8.1 failing

Bob,

 

I found that file on D:, killed it - and the HP-IDB service still doesn't want to start.

 

Ken

0 Likes
Bob_Clark Absent Member.
Absent Member.

Re: Upgrade from 7.03 to 8.1 failing

Hi Ken

 

  That's really all I had on this.  Open a case, and get debugs from the 'omnisv'

 

      omnisv start -debug 1-500 IDB.txt

0 Likes
utsavchs Absent Member.
Absent Member.

Re: Upgrade from 7.03 to 8.1 failing

Hello,

 

Solution for the error: 

 

The IDB process hangs as the PostGre service gets hung. You can go to the Task manager and kill that particular process by using the PID from the event log. Once done, the omnisv -start will work without any further problem.

 

Enjoy!

 

 - UtsavChs

0 Likes
Juliano_Flores Frequent Contributor.
Frequent Contributor.

Re: Upgrade from 7.03 to 8.1 failing

Hello Bob,

Your first step "1) Delete the file "C:\Program"." solved our problem.

Thanks!

 

Best Regards,

Juliano Flores

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.