Highlighted
Andy___H1 Super Contributor.
Super Contributor.
387 views

Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

Hi,

We've recently started to upgrade from 9.09 to 10.30 - we have a Linux Cell manager and a Virtual Center appliance running ESX 5.5. In this environment we use VMware integration, and at the end of the Cell manager upgrade it threw up a message saying that the VMware GRE plugin couldn't be unregistered. We were told we'd need to run 'omnicc -upgrade_greplugin' after all mount proxies were upgraded. We upgraded the mount proxy (Windows VM) and ran the command but got the error: ' unregister of advanced GRE web plug-in from vcenter unsuccessful. License checker internal error'. We saw license mentioned in the error so applied our license - although didn't think this would really help (and it didn't!). We've tried deleting the Virtual centre client and re-adding and all of the messages suggest this has worked - we get successfully unregistered/registered messages. However when we look in the VSphere web client we can't see the GRE management tabs. Within the virtual center GUI we can see the 'vmware granular recovery extension web client plug-in' showing as an installed plug-in but it still shows as 9.09. We thought that this might need manually removing and found notes that say to log into the vmware MOB GUI (https://VCserver/mob), but here we are not seeing any data protector extensions installed.

Another strange thing is that if we try and import the Virtual Centre server and get the username and password wrong on purpose, we still get the possitive messages about registering the GRE, and the server is added to the client list! It's almost as if it's not really trying to talk to the VC server ... just pretending to. On the other hand if we try and import a made up server name (but with the correct domain details) it throws up an error stright away.

This came about because during backup testing of VM's we have started seeing the message 'virtual centre: download of disk descriptor file failed'. Our huch was that by ensuring the GRE extension was at the correct version, this error may go away.

Any help apprectiated!

Thanks,

Andy.

0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

Re: Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

Hello @Andy___H1

Just to understand better. You have vCenter 5.5 right? Unfortunately, this vCenter is not supported in DP 10.30:

image.png

It is not supported for GRE either. 

image.png

https://docs.microfocus.com/DP/SupportMatrix/10.30/Virtualization_Support_Matrix_DP10.x.pdf

 

Could you please clarify this? 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.

View solution in original post

6 Replies
Micro Focus Expert
Micro Focus Expert

Re: Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

Hello @Andy___H1

Just to understand better. You have vCenter 5.5 right? Unfortunately, this vCenter is not supported in DP 10.30:

image.png

It is not supported for GRE either. 

image.png

https://docs.microfocus.com/DP/SupportMatrix/10.30/Virtualization_Support_Matrix_DP10.x.pdf

 

Could you please clarify this? 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.

View solution in original post

Andy___H1 Super Contributor.
Super Contributor.

Re: Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

Ah, many thanks for confirming, we really should have checked that!!!

So our hosting team wanted to get to 6.5 from 5.5, and we needed to upgrade DP from 9.09 to 10.30 to match it. We went first "assuming" it would still work for 5.5, but obviously not.

So really we both need to upgrade at the same time then. However given this is a non-prod environment only we'll leave our upgrade at 10.30 and shout to out hosting team to put the pressure on them to upgrade also.

Thanks, Andy

0 Likes
Andy___H1 Super Contributor.
Super Contributor.

Re: Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

Hi,

An update on this, and we still have issues.

So DP is now 10.30, and VMware is 6.5. VMware backups are working fine, as are other filesystem and SQL backups. However the GRE integration is still not appearing in the VMware Web GUI. We see the GRE plugin available in the VMware Managed Object Browser (MOB), but never in the Web GUI, which suggests DP is sending the code out, but VMware can't process it to the Web GUI.

I've raised a case with Micro Focus support, with the following info. Anyone here on the forums seen this before and can advise? This was all done on a request to create debug logs for further analysis, but as you can see below, no debugs were being written for the GRE plug-in install:

  • I updated the omnirc file on the Windows mount proxy and restarted it successfully, debugs were being written when I was using the GUI
  • I then went in to the VMware MOB (managed object browser) “content/ExtensionManager” screen and could see the “Microfocus.DataProtector.VMWareGREang.Webclient” extension in the list from a previous attempt. This was not available in the VMWare Web GUI.
  • In the DP GUI I went in to Clients option from the drop down list, then in to the VMWarehost client, and the Login tab. Debug logs were being written when I went in to the Clients screen. I then stopped for at least a minute before continuing.
  • In the Login tab of the VMWarehost client, I unticked the “Advanced GRE Web Plug-in” box, and clicked Apply. This successfully processed in the DP GUI. VMWare MOB screen shows the GRE extension was gone. But, there were no updates in the debug logs at all since I had unticked the box.
  • I then waited another minute, and ticked the “Advanced GRE Web Plug-in” box again, and clicked Apply. This successfully processed in the DP GUI. VMWare MOB screen shows the GRE Extension is there, correct 10.30 version, as before. However in VMware there is no DP GRE option in the Configure tab of a VM. But again, no updates in the debug logs at all.
  • I then moved in to another option other than Client, Monitor, and the debug logs were updated.

So as you can see during the whole process of disable and enable of the “Advanced GRE Web Plug-in” box for the VMware host, there were no debug logs written out on the mount proxy.

Is there something else we can see in VMware which can show us why the webclient will not install itself successfully beyond appearing in the MOB screen?

Thanks,

Andy

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

You will need to remove it from MOB and then try again to add it. 

https://softwaresupport.softwaregrp.com/doc/KM03486500

Those steps can help you to remove the plug-in. 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Andy___H1 Super Contributor.
Super Contributor.

Re: Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

Hi Andres,

I should have mentioned this previously but our vCenter is an appliance rather than a server, so we couldn't perform all the actions on that Knowledge Base article. Also when we use the DP GUI to uninstall and re-install the GRE plug-in it does show in the MOB as the correct 10.30 version every time, but just won't show up in the vCenter Web GUI. 

But I did perform the actions in the MOB to de-register and re-register the plug-in rather than using DP to unregister it, and re-registered it via the DP GUI, and it shows in the MOB ok, but still not in the Web GUI of vCenter.

Any other ideas on how to get this working vCenter Web GUI? Are there different types of instructions to use when it's a vCenter appliance, something from the CLI of vCenter?

Cheers,

Andy

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Upgrade from DP 9.09 to 10.30 and VMware integration

Jump to solution

Hello @Andy___H1

I had a situation with a customer with this same behavior. And they asked VMware to remove the plug-in from MOB. They had a vCenter Appliance also. Unfortunately, I do not have the steps they performed. 

 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.