Trusted Contributor.. Kam_Melb Trusted Contributor..
Trusted Contributor..
441 views

Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

We recently upgraded to DP 10.30. We have 2 new SQL servers which need to be added to backups, I've had network guy open up ports 5555 and 5565 between the client servers and CM. When I try to import the host on the CM, it fails saying traffic on 5565 not allowed. I checked the omnirc file and made sure ports are opened (see below). Port 5555 seems to work, but since these are new clients, CM wants/needs to use 5565 for new installation.

Any ideas what I'm missing here?

OB2INETTIMEOUT=120
OB2IPCKEEPALIVE=180
OB2IPCKEEPALIVETIME=900
OB2IPCKEEPALIVEINTERVAL=60
OB2RECONNECT_ACK=3600
OB2_OLDMAIL_FORMAT=1
# OB2PORTRANGE=64270-64440
# OB2PORTRANGESPEC=64270-64400
VI_API_TIMEOUT=300
OB2PORTRANGESPEC=BMA-NET:5555-7116
OB2PORTRANGESPEC=xMA-NET:5555-7116
OB2PORTRANGESPEC=xSM:5555-7116
# Default: 1
# This options is used to determine if Reports sent via email(SMTP)
# is sent as attachment or embedded. Setting this option to 1 means
# reports will be sent as embedded and setting it to 0 means reports
# will be sent as attachement. By default it is set to 1.
#
OB2_SMTP_CONTENT_TRANSFER_ENCODE=1
# Default: 0
# This variable controls the encoding format for SMTP notifcations and reports.
# By default the encode format selected is base64 format. This option should be
# set to 1, if you want to send notifications and reports encoded in ASCII format.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Knowledge Partner
Knowledge Partner

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Hello @Kam_Melb,

There is only one INET port that is used at a time per cell (CM and all clients). By default it is 5555 for upgrade scenarios and 5565 for new installs. If you perform a local installation you must specify the port during the setup if the client in the cell is configured for 5555.

This is true for the Windows setup (on the page where you enter the CM name) and omnisetup.sh for Linux/UNIX with the -inetport switch.

If the wrong INET port is used on a client you can change it via omnicc -update_local_port InetPort which is recommended over editing the registry.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
12 Replies
Micro Focus Expert
Micro Focus Expert

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Hello @Kam_Melb

First of all, the variable OB2PORTRANGESPEC is not needed anymore since DP 9.09 because this version and newer includes Network Consolidation. This feature means that all the communication is between the Inet port. 

Second, you mention that you have 2 new servers? Are these clients installed locally? If so, the port used by default is 5565. So you need to change it in the Regedit modifying these keys:

 • HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard\OpenView\OmniBackII\Common\InetPort
• HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard\OpenView\OmniBackII\Common\Parameters\InetPort

After that restart the services. 

Remember that clients need to have the same Inet port than CM. If they are different will fail. All the communications will only work if the servers have the same port. It does not support to have some clients in 5555 and others in 5565. No matter if DP 10.x have the port 5565, the only port that matters is the current configured in the CM. 

Also, DP 10.x introduces Secure Communication, so, if the clients have DP 10.x installed, you need to run this command between both servers: 

omnicc -secure_comm -configure_peer <hostname>

If your problem is installing the agent remotely, make sure that client can do telnet to CM using the Inet port. 

If the error persists, send us the exact message you receive in the installation. 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Trusted Contributor.. Kam_Melb Trusted Contributor..
Trusted Contributor..

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Hi

have attempted to configure peer but got the following error.

C:\Program Files\OmniBack\bin>omnicc -secure_comm -configure_peer client_server.domain
Error getting certificate from the peer 'cell_manager.domain'.

IPC Cannot Connect
System error: [10061] Connection refused
(cell_manager.domain:5565)

C:\Program Files\OmniBack\bin>omnicc -secure_comm -reconfigure_peer cell_manager.domain
Host 'cell_manager.domain' exported from secure configuration successfully.
Error getting certificate from the peer 'cell_manager.domain'.

Port 5565 on client_server is up and listening

  TCP    [::]:5565              [::]:0                 LISTENING       5596

I've tried to import the client from cell_manager but because there's no response from client_server on 5565 (cell_manager is running 5565 as I've tested by trying to communicate itself on this port and it worked) it failed.

[12:1625] Import Host Failed
The host information cannot be added/updated in the Cell Manager configuration file.
* Please check that the Data Protector services on the Cell Manager computer are running.
* Also check that Data Protector Inet service on the remote computer is running
(use: telnet 5565 to see if the service responds).
* Make sure that the remote client is not already part of another cell.

 

 

0 Likes
Trusted Contributor.. Kam_Melb Trusted Contributor..
Trusted Contributor..

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Also have tried to configure peer from client server.

C:\>omnicc -secure_comm -configure_peer cell_manager.domain
Error getting certificate from the peer 'cell_manager.domain'.

IPC Cannot Connect
System error: [10061] Connection refused
(cell_manager.domain:5565)

C:\>telnet cell_manager.domain 5565
Connecting To cell_manager.domain...Could not open connection to the host, on port 5565: Connect failed

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Here you clearly have a problem with the network and you will need to involve your networking team. 

As you mention the telnet does not work from client to CM. This is not correct and until you don't fix this problem the import will not work. 

 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Trusted Contributor.. Kam_Melb Trusted Contributor..
Trusted Contributor..

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Thanks Andreas. I already spoke to Network Team who opened up 5565, 5555 bi-directional between CM and client and says it's no longer networking issue.He's asked me to find another server that we already do backups for that uses port 5565 back to CM. My understanding is that DP only uses this port for new installs and then reverts to using 5555, correct?

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

No exactly. DP only uses the Inet port established in the CM to perform all the connections (installations, backups, restores). 

If your CM has the port 5555 all the DP environment should have 5555. DP cannot work with two ports, only one. 

So, if a client has the Inet running in port 5565 and the CM is 5555, this never will work. 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Trusted Contributor.. Kam_Melb Trusted Contributor..
Trusted Contributor..

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Okay.

Then how come when I try to import the client into the CM it fails with the below messages referring to port 5565? I can confirm that Inet service is running on client.

* Please check that the Data Protector services on the Cell Manager computer are running.
* Also check that Data Protector Inet service on the remote computer is running
(use: telnet 5565 to see if the service responds).
* Make sure that the remote client is not already part of another cell.

When I telnet from client to CM on port 5555 it works but CM is insisting on using port 5565 to add the new client to CM.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

This message is by default, you can have any port and this message will always show 5565 because is the default port of DP 10.x. 

But you need to have clear that both servers should have the same port. You can check it here: 

  • In Windows check these two registry keys:
    HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard\OpenView\OmniBackII\Common\InetPort
    HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard\OpenView\OmniBackII\Common\Parameters\InetPort
  • In Linux you can run this command: cat /etc/services | grep omni

Regards, 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Trusted Contributor.. Kam_Melb Trusted Contributor..
Trusted Contributor..

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Thanks. So have confirmed that client is using port 5565 and CM is on 5555, so I'd need to change that in registry for the client.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Yes, both of them. And restart the Inet after the change. 

Andres Fallas Salazar
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the bottom at the left of the post and show your appreciation.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Hello @Kam_Melb,

There is only one INET port that is used at a time per cell (CM and all clients). By default it is 5555 for upgrade scenarios and 5565 for new installs. If you perform a local installation you must specify the port during the setup if the client in the cell is configured for 5555.

This is true for the Windows setup (on the page where you enter the CM name) and omnisetup.sh for Linux/UNIX with the -inetport switch.

If the wrong INET port is used on a client you can change it via omnicc -update_local_port InetPort which is recommended over editing the registry.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Trusted Contributor.. Kam_Melb Trusted Contributor..
Trusted Contributor..

Re: Upgraded to 10.30 but CM doesn't allow 5565

Jump to solution

Thanks Sebastian.

I uninstalled DP on the client, then re-installed and changed the Inet port from 5565 (default) to 5555. Once that was done, I was able to import the host to the Cell Manager in DP.

 

Thanks guys for all your help.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.