Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Captain
Captain
641 views

nss volume incremental backup error #Bad catalog access for message #1 in set 222

Jump to solution

Hi,

I have 1 server with nss volume /media/nss/VOL1, /media/nss/VOL2 /media/nss/VOL3, and I have a test job for all volumes full backup. The full backup is running without errors, but the incremental backup is showing man errors for all volumes. Just a sample:

[Major] From: VBDA@server.whatever.com "/media/nss/VOL1"  Time: 2019. 04. 04. 14:37:50
VBDA: Bad catalog access for message #1 in set 222

On the client's debug log: 

 

2019-04-04 14:37:50.596  VBDA.14674.0 ["/smsres.c $Rev$ $Date::                      $:":1059] A.10.30 b105
ERROR: NWSMTSCloseDataSet() (CCODE = fffdffb1)

The backup is looks running after the errors, but what is that, and how can I eliminate that?

The backup specification:

DATALIST "teszt"
DYNAMIC 1 2
DEFAULTS
{
FILESYSTEM
{

-vss no_fallback

} -protect weeks 1 -keepcatalog same_as_dataprotection
RAWDISK
{

}
}

DEVICE "HP:Ultrium 5-SCSI_1_1-bld"
{
-pool "Default LTO-Ultrium"
}

DEVICE "HP:Ultrium 5-SCSI_2_1-bld"
{
-pool "Default LTO-Ultrium"
}

FILESYSTEM "/media/nss/VOL2" servername.whatever.com:"/media/nss/VOL2"
{
}

FILESYSTEM "/media/nss/VOL3" servername.whatever.com:"/media/nss/VOL3"
{
}

FILESYSTEM "/media/nss/VOL1" servername.whatever.com:"/media/nss/VOL1"

 

cell manager version: 10.30

0 Likes
1 Solution

Accepted Solutions
Captain
Captain

Hi,

We diabled the tsafs caching mode, on OES 2018 client, and the incremental backups are running successfully. Maybe it's must to set at OES2018+DP10 for correct backups.  See the documentation:

https://www.novell.com/documentation/open-enterprise-server-2018/bkup_sms_lx/data/hhc3nq5m.html

Non-Caching Mode of Operation
TSAFS by default uses a predictive caching mechanism to cache ahead data sets for backup operations. Some backup applications process incremental or differential backups by filtering the data sets themselves rather than use TSAFS options. Under such circumstances the cache built up by TSAFS is not used. This leads to slower backups as TSAFS spends more time caching unwanted data sets.

The non-caching mode of operation disables TSAFS predictive caching thus eliminating any performance issues when used with applications that do their own filtering.

To enable the non-caching mode of operation in TSAFS, use the following switch:

smsconfig -l tsafs --noCachingMode

 


@Sebastian.Koehler wrote:

Hello @kofop,

Can you confirm the incremental backup itself (and the restore from it) is working as expected? Then this might be cosmetic with a message translation missing.

Since the full backup works I guess that the proper OES agent is installed. Have you tried to remotely upgrade the client again? Otherwise the pieces for the NSS login would be missing.

Regards,
Sebastian Koehler




 

View solution in original post

0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

Hi @kofop,

What version of Open Enterprise Server and Data Protector client are you running? Have you loaded tsafs with Dual according to https://docs.microfocus.com/itom/Data_Protector:2019.02/NovellOES?

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Captain
Captain

Hi,

The OS is SUSE Linux Enterprise Server 12 (x86_64), the client 10.30 Disk Agent.

The tsafs with Dual according is correct - like the guide.

0 Likes
Micro Focus Expert
Micro Focus Expert

Hello @kofop,

Can you confirm the incremental backup itself (and the restore from it) is working as expected? Then this might be cosmetic with a message translation missing.

Since the full backup works I guess that the proper OES agent is installed. Have you tried to remotely upgrade the client again? Otherwise the pieces for the NSS login would be missing.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
Captain
Captain

Hi,

We diabled the tsafs caching mode, on OES 2018 client, and the incremental backups are running successfully. Maybe it's must to set at OES2018+DP10 for correct backups.  See the documentation:

https://www.novell.com/documentation/open-enterprise-server-2018/bkup_sms_lx/data/hhc3nq5m.html

Non-Caching Mode of Operation
TSAFS by default uses a predictive caching mechanism to cache ahead data sets for backup operations. Some backup applications process incremental or differential backups by filtering the data sets themselves rather than use TSAFS options. Under such circumstances the cache built up by TSAFS is not used. This leads to slower backups as TSAFS spends more time caching unwanted data sets.

The non-caching mode of operation disables TSAFS predictive caching thus eliminating any performance issues when used with applications that do their own filtering.

To enable the non-caching mode of operation in TSAFS, use the following switch:

smsconfig -l tsafs --noCachingMode

 


@Sebastian.Koehler wrote:

Hello @kofop,

Can you confirm the incremental backup itself (and the restore from it) is working as expected? Then this might be cosmetic with a message translation missing.

Since the full backup works I guess that the proper OES agent is installed. Have you tried to remotely upgrade the client again? Otherwise the pieces for the NSS login would be missing.

Regards,
Sebastian Koehler




 

View solution in original post

0 Likes
Micro Focus Expert
Micro Focus Expert

Hi @kofop,

Thanks for sharing. I asked the documentation team to look into it and adopt what matters to Data Protector.

Regards,
Sebastian Koehler

---
Please use the Like button below, if you find this post useful.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.