New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Lieutenant Commander
Lieutenant Commander

omnirpt - Get List of Virtual Environment Hosts (9.07)

G'day all.

I'm currently trying to write up a pre-exec script for our Hyper-V backups, we simply want to run a few checks before the backup runs.

In order to do this, I need to be able to look up a list of hosts and backup destination in the backup session... I have this working successfully for regular old filesystem backups, but I cannot see the hosts for Hyper-V sessions.

So, if I run an omnirpt for a filesystem backup, I get this output:

omnirpt -report session_objects -session 2018/07/16-2113 -tab

#Session Objects Report
#Cell Manager: <omitted>
#Creation Date: 16/07/2018 10:18:12 AM
#Session Type: Backup
# Headers
# Object Type   Client  Mountpoint  Description Object Name Status  Mode    Start Time  Start Time_t    End Time    End Time_t  Duration [hh:mm]    Size [kB]   # Files Performance [MB/min]    Protection  # Errors    # Warnings  Device
BAR server1.domain.local    EPT:1   Hana    EPT:1   Completed   trans   16/07/2018 10:06:45 AM  1531699605  16/07/2018 10:13:26 AM  1531700006  0:06    648 0   0.09    30/07/2018 10:13:26 AM  0   0   gw1
BAR server2.domain.local    EPT:2   Hana    EPT:2   Completed   trans   16/07/2018 10:07:21 AM  1531699641  16/07/2018 10:13:26 AM  1531700006  0:06    2840    0   0.46    30/07/2018 10:13:26 AM  0   0   gw1

BUT if I run the same for a backup under Virtual Environment, I get the following:

omnirpt -report session_devices -session 2018/07/16-1957 -tab
Session Devices Report Cell Manager: <omitted> Creation Date: 16/07/2018 10:08:31 AM No devices used in the session.


Any help would be greatly appreciated!


2 Replies
Lieutenant Commander
Lieutenant Commander

Hello Ryan,

Please check if the session shows correctly the devices using the command:

omnidb -session {sessionID} -detail

For example:

omnidb -session 2018/07/16-1957 -detail

The command will shows the information about the objets and devices. If this information shows everything fine related to the device, please provide:

omnirpt -version

 Possible the issue is related to the Data Protector version used and you will need to update the Data Protector to the latest patches for 9.0, that will be 9.09.


Lieutenant Commander
Lieutenant Commander

Hi Kikefasa,

Thanks for the response, I tried your command but unfortunately yeilded no results. I think this may be a limitation of virtual environment backups being nested under parent objects...

omnidb -session 2018/07/16-1957 -detail
No objects within session 2018/07/16-1957 have been found.

Standard filesystem backup specs look like this:


Whereas Hyper-V backup objects are under a parent object:



Super frustrating! I guess I may end up just supplying a static list of VMs to the script.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.